WD is not showing up

My WD external hard drive is not showing up although the light is on and there is a sound in the external drive when I connect it to the USB port, I have DATA and I don’t want to format my external hard drive , What can I do to open it again ,


Please help me

I wish I had an answer because I’m having the same problem with my WD My Book Essential external hard drive. The other night I had it plugged in and it loaded up once, but everything froze when I tried to copy the files on it to a new external hard drive and it malfunctioned. I keep plugging it into my laptop and it still registers that it’s connected, but it still won’t load up. I’ve tried googling a solution, but I’m nervous about doing anything that will cost me my files on it. So I’m following if anyone who knows better has a solution. If I find anything that works, I can let you know.

Well, there can be various reasons for a storage drive to become unresponsive. It can be a hardware issue or some technical issue. Reconnecting the drive won’t help in most of the cases. The drive remains visible and may be detected by the system if you connect it to another PC, but it doesn’t respond.

Below are the few possible reasons for a drive being unresponsive:

  1. A Lot of bad sectors
  2. Infected File (Virus or Malware)
  3. Driver issue
  4. Mechanical failure

In that case, recovering data from the faulty drive is the best option. If you don’t have any backup & you want to recover data from the drive then here, I suggest you to check out the below blog to know the possible solution for the same: https://www.stellarinfo.com/blog/how-to-fix-not-responding-hard-drive/

Hope this will help.

As per the screenshot you have shared it is showing unallocated status which directly says that your drive has lost its file system and now become unrecognized. You can fix this issue by changing the file system of your drive. In order to assign a new file system to your drive first your need to clean the drive using diskpart command and then create a new partition.

Note: Using diskpart command to clean disk will vanish existing data from the drive. So it is recommended before cleaning and creating a new disk try data recovery software to secure your data first.

I am having the same issue,Have completed all the steps in the WD troubleshooting guide.
Disk Management screen shows exactly as the poster ceemo_km.
Drive responds,beeps,flashes,clicks like it normally did but just will not seen in Win Explorer.Device Manager shows it,drivers are up to date,windows updates are always done.When I right click the Disk 1 it shows offline,try change it to online and receive the message Fatal device hdwe error.I am at a loss as to what can be done next,been quoted $300 to recover,yikes!