WD External Hard drive not recognized in my computer


#1

I have a  MyBook Essential 500GB that is acting up. It started last night. Windows won’t recognize it. I’ve read the forum here, and tried some of the suggestions, to no avail.

Symptoms

  1. Won’t shutdown with the computer. I have to pull the power cable out to get it to shutdown. If left running, such as in a restart situation, it will not cycle and as a result is not recognized after the PC starts up.

  2. If I shutdown the PC, unplug the WD power, and then repower it, it shuts off. When I restart the PC, the drive is sometimes listed in Windows Explorer, but the files are not accessible. The one time the files became accessible, the products associated with those file types - such as image programs for JPG, PNG, TIF, etc. didn’t recognize the file format.

  3. I swapped USB cables, the WD drive starts/stops with the PC, and the New Hardware Wizard starts up. Unfortunately, it says it cannot find the necessary software for the device. Go figure - its USB!

  4. I cycled the PC on/off and the WD drive, restarted both, stepped away while rebooting. Returned, didn’t recognize the drive, can’t find the software for it using the Found New Hardware Wizard. I went to move the drive out of the way, and it is too hot to touch or hold. Looks like the fan went too.

I’ve got images I’ve rendered, family photos, etc on this drive and do not want to lose them. I’m open to other suggestions. This is really disappointing.

Much appreciated,


#2

I had the same thing happen and lost everything - even tried ESS Recovery service.  My #1 lesson learned was to stop trying to troubleshoot it yourself and get it to a professional.  Something mechanically broke inside my drive and scratched the hard drive completely up.  They said it wouldn’t have been so bad if I got it to them at the first sign of trouble.  Everytime I turned it on & off, trying to troubleshoot it, the hard drive just kept getting more and more scratched…  So stop now and have a better chance of recovering whatever is still on the hard drive.  Good luck.


#3

Exactly the same situation hit me this morning with the same external drive.