WD Elements External Drive Randomly Cannot Be Read

Hi! Late August, I ordered a WD Elements 1 TB external hard drive from Amazon for one of my college classes. It works perfectly for the most part, but I have had it not register on any computer or laptop twice now. The flashlight will come on, showing that there is power running to the device, but it does not pop up in the computer’s system, Mac or PC. It eventually just starts working again miraculously, but I am curious if anyone else has had this issue and if it is able to be corrected, or if I will need to just buy a new one.

Before rushing out to buy a new one, the first simple thing i would try is using a different USB Cable in case the one you’re using is intermittently faulty.

I tried a different cable, and it still wasn’t working. It seems like there is an issue with the formatting since it started doing that because I formatted it to work on both Mac and PC, but when it is working, it isn’t popping up on a PC. Not sure if there is a correlation or not

I had to take it in to my university’s IT department because it wouldn’t let me format it myself on my Mac for some reason. That might’ve been what they did, though.

Could that be the source of the main problem?

It sounds like you are experiencing some intermittent connectivity issues with your WD Elements external hard drive. This issue could be caused by a variety of factors, ranging from a loose connection to problems with the USB port, cable, or the drive itself.
Try using a different USB cable to rule out any issues with the current one. Sometimes faulty cables can cause connectivity problems.
Ensure that the device drivers on your computer are up to date. Outdated drivers can sometimes lead to compatibility issues.
Sometimes a simple restart can resolve connection issues.
Run disk error checking tools like First Aid (Mac) to scan and repair any errors on the drive.
If you’ve tried these steps and the issue persists, you might consider reaching out to WD Elements customer support for further assistance. They may be able to provide more specific guidance or determine if your device is eligible for a replacement under warranty. If the drive is still under warranty, you may be able to get a replacement if the issue persists.

I have tried some of those suggestions, but not all of them. I’ll try to do the ones I haven’t this evening and see if it fixes it. Thank you!

1 Like


Please attempt all the suggested methods outlined and inform me if you are still encountering the same issue.

I tried the ones I hadn’t tried yet, and I am still encountering the same problem. The drive isn’t even appearing in my Disk Utility.

Firstly, ensure that the USB cable connecting the hard drive to your computer is securely plugged in on both ends. You might also want to try using a different USB port or even a different computer to see if the issue persists. If the problem continues, you can try updating the drivers for the hard drive or running diagnostic tests provided by WD to check for any potential hardware issues. If none of these steps resolve the issue, it may be worth contacting WD customer support for further assistance or considering a replacement if the drive is still under warranty. Hopefully, you’ll be able to resolve the issue without needing to purchase a new one!

I tried everything, and nothing worked. There was an issue with the drive itself. I eventually just contacted WD support, and they sent me a replacement that works great!