WD Elements 4TB - can't format on OS X 10.11.6 El Capitan

Just bought a new Elements 4Tb and when I try to erase/format the drive using Disk Utility the erase fails with “mediakit reports not enough space on device for requested operation” I have an older WD 4Tb drive which works fine on my iMac. I eventually managed to erase/format the new drive using disk utility on an old iBook G4 running OS X 10.4.11.

I then tried to erase and reformat the disk once again on my iMac and the same error occurred. Why can’t I erase/format the disk using Disk Utility in El Capitan?

I have now started Time Machine on my iMac using the new drive formatted on the iBook and will wait and see if that is successful.

If not the new elements drive will be returned for refund to Currys/PC World.


Please click on this link and review the steps to format the drive on Mac.

I am having the same problem. Ordered two of these drives and tried formatting exactly following the instructions, both drives failing, and both now seem to be unusable. Must be something with the Mac OS (I’m using 10.13.1 - High Sierra) Is there any resolution? Otherwise, I will return these drives. Thank you to anyone who can help.

I saw some mention of a Sierra utility/fix but nothing for High Sierra.

Thanks for the update. I found a fix. I was able to format the disks on another iMac running an older OS version than High Sierra. No problems at all, so now I can use them on the Mac with High Sierra.

I’m also having this problem. New 4TB drive on MBP running Sierra 10.12.6. I cen eject the drive from the desktop (by throwing it in the trashcan) but it does not vanish from Disk Utility and the lights are still blinking (so I assume something’s still going on in it).

Format the ENTIRE drive not the volume.

Make Sure you’ve selected the Drive (NOT THE PARTITION)
(you may have to select View/Show all Devices, instead of Show Only Volumes in order to see the Drive instead of the partition - that’s what caused me to fail was this setting)

Click Erase

I’ve been advised when Formatting EXFAT to select “Master Boot Record”

hope this helps.(it worked for me)