WD Elements 2TB might be dead - what do I do?

I had absolutely no issues with my drive up until a week ago. I went to watch a film with my family, came back, tried to access a file on my hard drive, and Windows Explorer started to lag up. I waited a few minutes, it wasn’t resolved, so I restarted the Windows Explorer process. Tried repeating the process, same outcome. I restarted my computer in the hopes of resolving the issue, but once I did this, the hard drive refused to show up.

I’ve tried using a different USB port on my computer, a different USB cable, and a different computer with a different operating system. Nothing worked. To this point, nothing I have done has been able to make a difference. I have noticed that when it starts up, it spins up, and then starts making an audible “seeking” noise. It’s not quite a click but it sounds similar.

Is my drive dead for good?


If possible, try testing the unit with the DLG tool.

Check the link below for instructions on How to test a drive for problems using Data Lifeguard Diagnostics for Windows.


If you have a desktop version of the WD Elements, try using a different power adapter.

Doesn’t work, I tried. The drive doesn’t appear.

I don’t think the power adaptor is the issue because the power light is on, and I can clearly hear the sound of the drive spinning up