WD Elements 14Tb not recognized

I have an almost new (less than a year old) WD Elements 25A3 1030 and today with win10 laptop the disk does not appear in File explorer and is not recognized. I tried to use another pc with the same result.
Only Windows disk management see it, but it says not initialized and does not give any info on its size, though it reports correctly its name above.

The disk management utility tends to ask me to initialize it and pops up with the window. I am unsure on what to do.
It has the original partition (a single one) in NTFS, and I fear to lose it with all my files.
Three questions:

  1. Can you give advice on what is the best practice in this case?
  2. Do you have an utility more targeted to re-initialize the disk (I tried AOMEI Partition Assistant - rebuilt MBR - with no results, although it says “success”).
  3. If I initialize it with Windows the partition will be lost?

I do not why the disaster occurred. My guess is that the laptop attempted to boot from the WD Elements (I attached it before booting in windows, and it was a long boot time in this occasion) and this may have caused the corruption of the first sectors. Before I did not have perceivable problems. I tried to use some recovery software like r-studio, but without initialization they do nothing.

Thanks for any advice.

Hi @science2002,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Thanks for your suggestion.
I did not open anything. This also because I did not find strange noises in the HD nor it was completely silent. As I said, I just tried once to rebuilt the Mbr (in this case GPT), with the tool that was suggested in another post even here.