WD Discovery doesn't connect to MyCloud Home

For the past few days, WD Discovery is unable to connect to my MyCloud Home.
The app stays stuck on the sign in page, waiting for a response.

I tried to enter erroneous sign in details and got an errror feedback immediately.

The weird thing is that I can access my drive through the web app, the mobile app (connecting through the same router as my drive,) and even through the mapped drive in File Explorer (Windows.)
Nothing changed on my computer or router or drive recently to explain for this error.

Has anybody ever experienced that?
In case so, how did you solve it?

The exact same has happened to me.
I tried to uninstall and reinstall WD Discovery without success.

I think this is a problem with their WD Discovery App.

At least you are doing better than I am … brand new My Cloud Home is undiscoverable by web or iOS app … just the slow breathing light ad infinitum. Support is B#*&^ useless … tell me I connecting out of hours (I tried the APAC site as I am in Australia).

After discussing with the WD support, I reinstalled WD Discovery and that solved the issue.
However, I have to re-sync all the folders that were previously sync’ed :expressionless:

I also have exact the same problem. I installed the program several times, butt stil nothing (arggghh)

I have the same problem and have also reinstalled WD Discovery. It has no knowledge of my device at all. Thank goodness I can access it through (windows) file explorer. Otherwise neither WD Discovery nor the “new for me” Acronis True Image for WD has the foggiest idea that I have that device on my wifi network.
Everything functioned until yesterday when I upgraded my firmware to ver 3 as directed and downloaded the Acronis software, which required me to uninstall my previously purchased version. The only option I seem to have with the Acronis software is to re-format the disk and erase all the files I have stored–I’m not doing that!

I have spent most of today trying to set up my new My Cloud Home 2tb, although WD discovery can see it and it appears as a mapped drive Acronis for WD cannot find it. When I first installed Acronis yesterday it did find the drive, but not today, tried uninstalling and installing again as well as resetting My Cloud to factory settings. Finds my old My Cloud though.

Also just installed EdgeRover from the WD site but that cant find the drive either.
If I try and access via the IP address it is shown as not secure.

I filed a report with support and followed their directions (precisely again) and suddenly I can access my 4 TB Home drive via Discovery, the new web app, and Acronis. I wish I had an explanation. The bad news is I am thus far unable to get my spouse’s OS 5 web app to see the drive, but will keep trying. Perhaps it is explainable by ineptitude.

My Cloud users should assume that most of what they know about MC does not apply to the MCH. Different OS, CPU and supported software.

https://support-en.wd.com/app/answers/detail/a_id/29665
Acronis True Image Rescue Media Cannot Find a My Cloud Home
Answer ID 29665

ISSUE:
Acronis True Image for Western Digital Rescue media does not detect a My Cloud Home on the network.

CAUSE:
My Cloud Home is currently not supported by Rescue Media or Acronis True Image for Western Digtial.

In response to “N” let me state categorically that, Yes it does.
I am happy I did not read your post about Acronis True Image for Western Digital not supporting My Cloud Home because I might not have succeeded in getting it working. My P/N is WDBCTL0040HWT, which is indeed My Cloud Home, and Acronis for W/D works just fine after I finally succeeded in getting my drive to be discovered.

I solved the “discovery problem” by doingjust as others and support suggested: I reboot everything multiple times after I reset the drive to factory default, and after I uninstalled ALL W/D software from my Win 10 computer. At that juncture, my drive was visible on finder with files in tact. I was then able to “discover” the drive using W/D dashboard. After that I could access it with the web app; I could reset the red warning light; and Acronis W/D could see the drive. I hope this helps others.

It is fine that you got it working, but that part number is the 4 TB My Cloud which is about 8 years old. The My Cloud Home which this thread and subforum is supposed to cover, is only about 4 years old is a completely different OS4, CPU and software support as the Knowledge base link above showed you. Please do not keep suggesting to MCH owners that their unit will work with Acronis when it is not supported. It may show up as a network drive spuriously under MCH, but it is not supported while there are many other free backup software that will do the job.

You can tell the difference just by looking at the pictures.
https://support-en.wd.com/app/answers/detail/a_id/7758

NoPex,

Thank you—your email is enlightening. It seems a shame WD felt compelled to inform me via email that I must change my O/S and, along with that change, swap out software, some of which I purchased separately. Perhaps I should have looked more deeply into the change before I made it, but that is not particularly good customer support—they possess our P/Ns as well as S/Ns for all devices that are registered and those are easy discriminators. NAS drives are mundane and hardly the stuff of “rocket science”.

It seems we old physics PhDs and NAS devices have become techno ruble—perhaps we can salvage some rare earths from my WD drive. Thank goodness for iDrive.

1 Like