WD Discovery 4.0.251 (6/18/2020)

WD Discovery 4.0.251 (6/18/2020)

  • Added Support for My Passport SSD drives.
  • Important security update and fixes.
  • Fixed Shared Folder Sorting in Date created descending order.
  • Resolved WD Utilities missing from Apps Tab.
  • Disabled Instagram Social Media import.
  • Miscellaneous bug fixes and technical improvements.

No autoupdate on macOS (see below)
My Cloud Desktop still on 2.1.0.375

I got the message above when trying to access WD Discovery, but when I select download it downloads an old version that wont install “Install WD Discovery 1.0.433.exe”.

Please advise where I can get the latest version.

Proceed with it. It should download the latest version.

I’ve downloaded it 4 times and still not the latest version???

Run this installer. It will then download and install the latest version.

Run which installer, is there an attachment or link?

As mentioned the link https://www.mycloud.com/#/apps_os4 just downloads the old app for me.


Seriously are you even trying ?

Run the downloaded installer. It should install the right version.

Are you being serious?

I’ve already told you I clicked the download button in the pop up and it downloads the old version.

Why would I waste all this time on here if it was working?

Please.
I have been trying to help you…
Did you run the ■■■■ installer? even if the version shown is not the same. It the version of the installer not of the software installed. It will download the latest version.

See here: https://support-en.wd.com/app/products/downloads/release-notes/note_id/29475

It reads:

The WD Discovery Installer for Windows and macOS will pull the latest version of WD Discovery and is available for download at support.wdc.com. The Installer executable version may be different than the WD Discovery version.

Neither the ‘click here to update’ (from the app) nor the ‘download latest version’ (via website) worked - the former gave me the usual; ‘installation failed’ and the latter simply reinstalled the current version.
I will reboot and try the manual install-over-current method if the reboot isn’t the magic that’s required.
(edit: win7 though, this might be the one where we finally have to upgrade our OS)

Update: with the ‘download latest version’ method, the new version is downloaded (I checked), the installer looks like it’s doing everything right, but for whatever reason does not install this new version. Weirdly if I run the exe from the temp downloaded folder it starts and that bit at least is the new version. Still have access to mapped Z: drive though so not a complete disaster but can’t get to other cloudshares (scratch that, I can get to those too).
Next attempt, uninstall and start clean.

Success!

Uninstalled, rebooted, clean installed using the installer (properly :grin: ) and it worked just fine. I know it’s win7 not macos but a major version change often needs the chop-and-replant method regardless of OS.

Who knows, this approach might even have fixed my less than tidy original install, we shall see at the next update :slight_smile: