WD Cloud just quit....unchanging yellow light. Please help ;)

I’ve been using the My Cloud drive successfully for quite a while. Last night, I was streaming a movie from it, changed the movie, and it disconnected…and I’ve not been able to bring it back to life since.

I’m not getting the blue light and there are no blinking lights. Rather, I’m greeted only with an unchanging yellow light.

I tried the 4 second reset and just tried the 40 second reset and it’s still the same.

I have it connected to my router, of course…and none of my computers can access is.

What else can I do?
Also, if the equipment is bad, is the data saved on the hard drive in a regular way so I can just remove the drive and plop it into another device to salvage it??

Thanks!!!

By ‘blinking lights’ do you mean on the ethernet port?

If so, then for some reason your router connection has failed; network port on MyCloud or router, or the cable. Try jiggling the connectors, replace the cable, try a different router port, try connecting directly to a computer.

The disk is a multi-partition linux ext3/ext4 format. The user data is on partition 4. You’ll need a linux computer, or a linux LiveCD, or an ext3/4 file utility on a PC. Search the forum for data recovery.

No, sorry…I said “unchanging” not blinking. My front led is only a solid yellow – there are no blinking lights (except of course the ethernet light which is green and blinking like it is supposed to do).

Oh the format is linux??? grrrr…so trying to put my drive on a pc is pointless unless I have linux installed? :frowning:

What about putting it into another My Cloud device? Can I just transplant?

Thanks. I admit I know next to nothing about linux as it’s been since I last used it. I’m disappointed the file system isn’t in ntfs or something.

If I get a new My Cloud, do you think I could just drop the old drive into the body to retrieve the files?

Unlikely. If you have had it some time, it’s likely to be Gen1. Buy a new device and it’s likely to be Gen2. Not compatible with Gen1 firmware…

Ext3/4 isn’t an obscure filing system, and recovery with a PC is pretty easy; read the link I posted.

Are you sure your device is dead? What diagnostics have you tried?

Thanks. I’m pretty sure it’s Gen 1. I’ve had it at least 4 years. It’s a 2TB drive.

Diagnostics? I’ve tried several things.

Observation: Drive suddenly quit being recognized on network. Ethernet led blinks green, but front led stays yellow and does not blink. It never turns blue.

I tried…

  1. Resetting router
  2. 4 second My Cloud reset, 40 second My Cloud reset
  3. Connecting directly to PC ethernet porn
  4. Disconnecting for a few hours (to see if it was just overheating)

I’m not sure what else I should be doing, really.

I just bought a Thermaltake BlacX Duet external drive mount thing https://www.amazon.com/Thermaltake-Drives-Docking-Station-ST0014U/dp/B002MUYOLW

I removed the My Cloud drive and am going to mount it in the BlacX and see if one of the PC programs will read the drive. My fingers are crossed.

I was involved in a long move this summer. Fortunately, I backed up the My Cloud in July — I only recently completed my move and have been using the My Cloud without fully backing it up (doh!). I have maybe 3 months of unbacked up work on it. Fortunately, I have alot that is backed up.

Lesson learned…I’ll be even better at backing up in the future.
thanks for the advice!!! :):):slight_smile:

1 Like

THANK YOU THANK YOU THANK YOU!!! :slight_smile:

My fingers are crossed, but even as I type, I am copying data from the drive to another drive. I should know in around 30 hours if this is working haha…Apparently it’s a slow process :slight_smile:

This seems to be working and I want you to know how much I appreciate your help!!

Hey Dan,

Did it work? I am facing a similar issue on WD My Cloud connected directly to iMac.

So did you remove your HD and mount via Docking Station and Transferred the Data to another WD My Cloud Gen 1 or a regular WD HD?

Let me know the deets!
Thank you.