WD Black, slower than expected

I have 2TB WD Black, 2013 version. At first, I used it for operating system, and found that when running a game, HoN, the hard drive almost always ran at 100% and caused lags sometimes; however, I had another PC that had WD Blue and lower specs, it ran fine. The drive seems to be slower than WD Blue as well. So I bought an SSD and moved OS to it. Even for photo viewing only, it is still slow. I ran a benchmark based on Userbenchmark.com and it said that my drive’s speed is only around 70% of what it should be on average. In addition, there is no app really running on it at the time I tested it. I ran benchmark 3 times, resulted similarly. I did defragment and check using WD Data life guard, there is no error. Do you think “write zero” might help? Or should I just send it to be fixed?

My PC specs:
Core i5 4590
RAM 4x4GB Kington 1600MHz
SSD: Intel 730 240GB
Mainboard: Gigabyte Gaming 3 Z97X

Running on Windows 10. I updated both Windows and drivers to the newest. Thanks in advance

Hi, I would “write zero” to the drive and see if somehow the partition got corrupter or there are some bad sectors that are causing this issue. If after doing that the benchmarks runs the same, I would recommend you to contact support and get the drive exchanged under warranty.

Okay, I will try that after backing up almost 2TB of data. Thanks!

“Write zero” fixed it, after 4 hours of running it. I should have known about it and done it a year and a half ago. Thanks for suggestion!

Hello, I’m glad that is working as intended now, remember to mark the post that helped you as a solution, this way any user that might be having the same issue will see how you were able to solve it.

Hello.

I’m having similar problem with two identical WD Blacks, one is running at 122/114 MB/s and second at 155/143 MB/s.
The benchmark took like twice as long!
Could you please tell me how to “write zero”?
EDIT2: Found out the WD LifeGuard, currently backing up my data and will write the zeroes afterwards…

Also, I can hear the slower drive while it’s running, while faster one is completely silent. Is that something that happens with these new drives or should I be concerned? (I remember some very old drivers doing these typical noises but that was ages ago)

EDIT1: Here’s a nice comparsion from userbenchmark.com test tool:

Thank you for your time!

So you find where to write zero already, right?

Yea, I found this guide:

Still backing up my data though…
Seeing as it took OP 4 hours I will probably let it run over night and reply tomorrow about how it ended, it’s getting late.

I also use 16KB allocation units after write zero as I don’t use it to store operating system but larger files like videos and steam games.

Thanks for pointing that out, I always used default as I didn’t how what it means.
Now that I Googled it, it makes no sense to use default 4kB since this is a drive to mainly hold recorded and exported videos.

Alright, so I did full rewrite with zeroes and formatted it with GPT using 64kB allocation units.

Results far exceeded my expectations:

Apparently it’s now faster than 96% of other user samples from userbenchmark.com!

That’s awesome news and one less worry for me.
Thank you guys, and may your drives serve you as long as possible.

1 Like

No problem. Btw, have you run benchmark before setting allocation unite size but after write zero? I wonder how much does it matters.

No, I didn’t, sorry.

Can you actually do that though? I mean, before I allocated it, there was no partition at all, so how is the benchmark supposed to read and write data to measure it? :slight_smile:

Oh, I should say before changing 4KB to 64KB allocation unit size, but I might try it later if I manage to move my files again.

Wait, after I put the data back, I found out that the speed dropped even lower. I’m going to try defragment, but does it happen similarly to you?

Edit: now the hard drive is ranked on 5th percentile.

Hi again.

I just did another bench and yes, the speed dropped!
BUT, I’m still having 160ish reads/writes, instead of the original 115ish (same data + few GBs extra)

So for me it was from 115 to 190 to 160. (MBps)
And how’s your speeds?

Is it supposed to slow down when the disk is filled more? Or is there something wrong with our drives?

Mine went from 120 to 160 and back to 120. I think it should slow down, but I’m not sure if it should be this much. Have many percentage of your hard drive is now occupied? Mine is around 85%

Edit: Do you have the same amount of files as before doing “write zero”?