WD Backup unable to detect My Passport Win10

Hi, is that anyone facing WD Backup is not working under window 10? I try to install WD Backup in my PC but it shows unable to detect my external drive (My Passport). Is that anyone can help or giving advice?

Are you saying that when you plug the Passport portable drive into a USB port that you do not get prompt on what to do with this device? Or, can you not find the My Passport device using, say, the Win Explorer?

I use my Passport as a stand alone external for temp storage of files that I copy/paste or drag/drop. I also set it up to do scheduled backups to files and folders on my PC. When I first did this, I opened the Passport and double clicked on the file “Install Discovery for Windows.exe” to install the utility. There is one for Mac.

Now, if your Passport is not recognized by the PC…I see this issue in the Forum, maybe the USB port is the issue or something else, although I cannot imagine what after all the postings.

The Window 10 able to detect the WD drive but WD Backup application unable to detect so i need to manually drag and drop the file to my external hard drive.
Is that because WD backup not support by Window 10?

Hew…WD backup IS supported by Win10. I have seen this forum comments about users not being able to find the device or the App not seeing or being able to restore the backups. Check the “WD Portable Drive Forum tab too.” I’ve been looking at this Passport backup process, and have looked at my files, primarily thru the Explorer method. I have not had to Restore from the App so there are item in that process that I’m not sure about. Looking thru Explorer at the various Folders on the ‘WD Backup.swstor’ backup folder on the device has uncovered all kind of interesting items.

– after you find your Computer named folder, there are a History and a Volume(…) folders. The History is a storage of of pointers and previous copies with _LAST and other cryptic extension names. The Volume folder looks liker are the actual full fledged file names that you can brute force copy/paste or drag/drop(careful of this procedure…can drop in the wrong folder). When viewing files under History, use the Name sort instead of the Date sort for more clustered viewing. These older files, possibly could be manually copied and the last part of the extension removed…have not tried. I’ve looked at the Volume() folder and it looks current.

– now looking closely at your comments, you say the ‘WD backup application was unable to detect’. Are you saying that you loaded the App from the device and that you have not yet set up your Backup plan? Or is it that you already initiated a Backup plan, but the App cannot find the drive that was identified/used (did a msg appear on the App Display? Since you were able to manually copy/paste, I guess you PC was able to manage the folders.

– now I’ve been reading about users that change to a new PC and they want to Restore files from an existing Backup configuration…there have been a few links; look under "Restoring Files for 2 URL’s links. There is one for case of Restore from a Different Computer.

https://support-en.wd.com/app/answers/detail/a_id/8636/related/1

–here is another forum link on accessing data from the device. Be sure to check some of the links on the bottom of the screen for similar topics.
https://support-en.wd.com/app/answers/detail/a_id/9509/session/L2F2LzEvdGltZS8xNTkzNzk3MjkzL2dlbi8xNTkzNzk3MjkzL3NpZC9mVURFV3JDVnZhdHRpbkZWTER4ZVNiNVNna3pVMnFpYlRoRFFkcV9NMkZnb21UcmRLOGdMJTdFNVp0VnBkbTlROTZTazh6SElmdlA0NEtkdXVET0R2S0IyTXNfekhxWjFKX1pHX0hUc0FQOHdrd0hJcWoyWjMlN0VUQWlnJTIxJTIx

Hi, attached is the problem that i’m facing. it only happen in window 10 whereas my other old window PC no problem.
After i install WD Backup, it unable to detect “backup drive”, it cause me need to manually drag and drop file through window explorer.

Hew…I don’t recognize your snapshot. Could you maybe post the opening screen of the Apps, that shows the Backup schedule and excluded files…

If your Explorer can expand the Passport Device Folders, that means your PC knows the name and USB port…don’t know why Passport itself cannot hook-up. Have you been using this PC/Passport combo in the past or is your PC a new one that now does not Schedule correctly? If PC is new, or Passport is brand new then there is some other issue. If however, everything is old, then I’m lost. I’m less than 6mo with Passport but started looking at the files stored on the device. I have never done a Restore, even of old backups.

Hi,
the problem is when i install WD backup into my PC, it stuck at this page. the WD backup unable to detect my external WD passport drive.
Thank you

Oh, so the WD Passport exe has not been loaded yet to the PC…and when you try to Load(double click) the .exe file you get that message . Now, when I did my Passport, I loaded the App then had to enter and develop a Schedule of time and files of backing up. I don’t know at what time I was asked for the Drive that I want to backup To. I’m guessing it’s at this point that you get the message, or no?

MMM, looks like something for the WD Support people…I’m surprised they did not read this Forum and comment back. I tried their support once using the Live Chat…they wanted the SN of the device (mine was not registered yet…took my info before proceeding…they want you in the system). You could try them first, or go thru an Email support. Not sure if you could insert that snapshot into the Chat. Post your follow-up back here.

Hi, the issue is the WD Backup unable to detect the drive. Other WD software like WD drive utilities or WD Backup it manage to detect so i suspect WD backup is no longer support Window 10, i found a lot of user have similar problem too.