WD 4TB passport not accessible but comes on and light flashes


#1

Hi - I am hoping there is somebody out there that can help me. My Dell computer was showing as low on space so I decided to transfer all my precious videos from my harddrive to my new WD 4TB passport bought in May but only used once to backup. I was happily cutting and pasting my videos when it suddenly couldn’t find the disk. I tried to “safely remove the disk” but nothing happened, although the white light on the drive was continually flashing. I therefore closed down all the programs and shut down the computer thinking it needed a break. When I went back to try again, I thought I would try with a different PC and it was not recognised, so I tried a 1TB passport that I also own and that showed fine, therefore the cable is fine and 1TB also showed on Dell PC. However, when I attach the 4TB disk, the light flashes and it makes the usual “ping” to say its connected, but nothing shows in My Folders. I have checked disk management and it says it is working properly, however it says it is RAW but nothing is showing black or unallocated. I have downloaded a program called Disk Genius and according to that search it is showing ElementsD: as damaged. I have paid £100 for this from Amazon so no longer valid to return, looks like I have lost all my precious videos so very very unhappy - can anyone kindly help me!
Thank you in advance!


#2

Unfortunately, it seems that data is not accessible and need to initialize if want to use drive from the start. It is recommended to try to use data recovery tools to recover important data from the drive or contact data recovery companies. You can refer below links for more details:


#3

There are chances that data recovery software can recognize your drive and recover your lost videos. I would recommend you to download the free data recovery software of Stellar and try your luck. Raw format hard drive means the drive has lost its file system and won’t allow access over it. In such case, one need to format his drive for reuse.