WD 4TB My Passport Portable Drive not accessible access denied HELP!

I purchased the external hard drive in May of 2019. I put my movies onto it and have been using it plugged into the back of my computer. I wanted to add a couple of movies so i plugged it into the same windows 10 pc i used previously and guess what? “Drive not accessible, access is denied.”

I am pretty frustrated. I plugged the drive back into my tv and it works fine. I play videos and i can scroll through the folders. I checked in windows 10 and it has a healthy partition and the drive letter is identifiable. I changed the drive letter (like that would do anything really). I tried to change permissions and it wont let me. I have never had luck with an external hard drive and I think third times a charm. If anyone can help me that would be appreciated.

Drive in question.

WD 4TB My Passport Portable Hard Drive with password protection and auto backup software Orange (WDBYFT0040BOR-WESN)

This morning I have identified it is a healthy partition. The drive continues to not work on my PC because it is not accessible. The drive works perfectly fine plugged into my smart TV. I can change the drive letter. No need to adjust permissions because permissions are already granted to my desktop computer. What do i do next? Doesn’t Western Digital have any customer service on here?

I have now plugged it into my chromebook of all things. Works fine. I can access all the files and open them no problem. Does Western Digital help anyone with this stuff? I have updated windows 10 to make sure it has all the updates. My windows 10 PC identifies the drive letter, healthy partition, and I am the owner of it. Continues to say ‘access is denied’. Works on my smart TV and chromebook of all things. I plug it into Windows 10 and bam ‘accessed is denied’ I also deleted the driver from the device manager,tried to update the driver, and also delete the driver again etc. I have drived every USB port in my desktop. You alive Western Digital?

I have downloaded the firmware updater from here: https://support-en.wd.com/app/products/product-detail/p/250

I didn’t need it. Says I am already up to date

I have run the Western Digital Data LifeGuard Diagnostics Extended Test and the “smart status” on all of my devices passed.

SOS!

Yo so if Western Digital needs anybody to help them with the “support” they offer they can email me. I demand 125K USD/ year though.

Now if any of you have been frustrated with this. You’ve read all of the details about my problem and you have something very similar then here is your answer. Thank the dude who did the video https://www.youtube.com/watch?v=HxDcooJFy-g