Video Streaming Issue - Freezing/Pausing

My video’s are constantly freezing/pausing when I try to watch on my phone or tablet. They are just normal AVI, MP4, MKV, etc files of movies. I’ve used several different video apps but doesn’t fix it. The device is sitting right next to the hard drive itself to so its not a distance issue. Can anyone please help? I’m using firmware 1.03.13. 

I have a 2TB wireless passport. I am using a Samsung Note 4 and a Samsung Note 10.1 2014 edition to stream videos from the passport but its just not consistant at all. 

Video streaming issues are notoriously hard to diagnose and resolve. Aside from the streaming speed, there are possibly transcoding issues at the source or target device due to resolution, format (Container, Codec, NTSC/PAL, etc.), caching and video buffering, decoding video, and then sometimes problems just seem to be compatibility issues.

The MPW can stream in two ways as well; Just stream files as any hard disk would, or stream media using the MPW Media Server, which is a DLNA Server.

If you are just streaming files, which means you are just treating the MPW as a dumb hard disk, theoretically only the transfer speed from the MPW to the target device and the caching occuring will effect whether playback is smooth or not. Well, from the perspective of the MPW anyway. There are still all the target device issues as well. If you are using this method:

1. The first thing I would try is to turn off "Streaming (DLNA)" in the My Cloud App [swipe left on your MyPassport, tap Gear to get to Settings, tap More, tap Media, turn off Streaming (DLNA). With that off, you know you, and any Apps you use, can only use simple file streaming.
2. Now tap the Menu icon (top left of screen in home page), tap Settings, and check the Cache Size setting. That is the cache size the My Cloud App uses. I have it set to 2GB.
3. Now go back to you My Passport file tree, tap into "Sample Media" if you still have it, tap into videos, and play the videos. How did they go? Any pauses?  

I tested this on my old iPhone 4 16GB. On first play I can see the video buffer stays ahead of the play position, and the whole video plays without pauses. I can pause the video and restart it, and the video still plays normally. However, if I play the same video again after it is finished, I can see that the My Cloud App can’t keep the video buffer as far ahead of the play position, which eventually catches up, and I get a long pause of the video while it reads or decodes more of the file. These pauses continue to the end of the video. I get mulitple pauses.
My tentative conclusion there is that the caching in the My Cloud App on my iPhone 4 isn’t as good as it should be, but the speed of transfer is fine for playing those videos. Increasing the cache to 4GB and then 8GB did help a little bit, but I still got pauses when replaying those short videos 50% of the time. On replay I could see the video buffer, or the download bar for the video, just stopped loading most times that I replayed the video, even though it had loaded properly on the first play. I have no idea why it does that. It could be my iPhone 4, iOS, or it could be the App. It could be that the cache isn’t feeding the file to the video decoder, or the the decoder itself is pausing for some unrelated reason.  The caching of the My Cloud App on your devices may be fine though.

By the way, if you are wondering how a 60MB or so video file can fill a 2, 4, or 8GB cache, it is possible that the cache is storing uncompressed video rather than the original encoded video file. Uncompressed video files are very large compared to their source files. But if the cache is storing uncompressed video, then on replay of the video the video buffer should fill instantly. Unless there is something wrong with the caching.

If you do the above test and see the same results, you either need to always watch a video from the start and watch it completely through, which probably isn’t practical, or you need to find an App that handles caching and/or video decoding much better. As you have Android device I can’t advise on that, but when you test Apps, look for cache settings and test playback as above

4. If the above test shows that the video buffer never fills enough to prevent video pauses, then maybe your transfer speed is too slow. If you have or can find an App that checks the speed of a file copy from the MPW to your devices, and that speed is fast enough to play the video, then you will need to look further at the decoder you are using. In other words, try more players, or try to find out what your devices are capable of playing smoothly. A simple test to see if your devices are capable of playing the videos would be to copy the files to your device, and play them from there. You could use the My Cloud "Download" capability to test that.  

Hint: If you get a copy of MediaInfo and look at the average and peak Bitrates of your video, that is the minimum transfer rate required to play the video without pauses.

All of the above probably hasn’t helped a lot, as it still leaves question about which part of the process is stalling the video. Well, I said video streaming issues were notoriously hard to diagnose and resolve. However there is a whole other section to cover.

If you turn on the “Streaming (DLNA)” in the My Cloud App you then have a DLNA Media Server to work with. Then you need an App that is both a DLNA Controller and DLNA Renderer. I’m not going into details of that, but using DLNA may help with all of the above potential problems, as long as your device hardware and operating system is capable of playing the videos. But DLNA can also make things worse sometimes than simply streaming a file.

Whew, a lot to read above.  Video streaming is not so complicated – you just need a large enough cache going in the iPhone/iPad MyCloud app (my iphome is set for 8GB, iPad at 10GB, after much experimentation, etc).  Also, your videos must be somewhat “standard”, meaning not too high a bit rate that it chokes the system.  Videos made from DVDs with Handbrake iPad default settings all work fine, but some made from blu-ray have an intense bit rate that causes some, but not all, to stall.    Device played on matters, too.  My videos play fine on iDevices can play fine, but my FIreHD choaks on them.

Agree that the MPW sample videos are good to test with, as they are a relatively high bit rate.  Bottom line here, is if you can play these videos, you should be able to play most any video that is consider normal. 

Now, here is another tip:  (Roderick, you may leave the room now) is to use 5G instead of 2.4G to stream your videos.  But, since the MPW is a 2.4 GB signal, how is this done?  It is done via the receiving of the video.  Your MPW needs to be on the home network, 2.4G and your phone, using the 5G network signal.  THe MPW (which is sending out at 2.4 G needs to be close to your router for max signal transfer.

A real world example.  I hvae a very fast home network, but even so, the 2,4G signal is just TOO SLOW for HD videos and is precisely why 5G was developed – for video streaming.  So, if I play the sample videos when using 2.4G, they can stall and stutter a lot.  If I connect a phone or pad at 5G,  ALL these problems are gone, and is why my MPW is on my home network when it is at home.  My MPW is on the home network BECAUSE it works best that way!

Too bad the MPW is not a dual-band device, especially in this day and age.

Mike, are you chiding me about me chiding you about your Home Network solution?

Okay, I’m just poking fun at you now. :wink: I do like your use of the word Chiding, as it shows restraint rarely seen on the internet, and a ceratain level of . . . maturity. No, I’m not calling you old!

Actually your solution while at home is a very good one, as the data moving from the MPW onto your network using 2.4GHz doesn’t interfere with the data moving from your network to your iDevice using 5GHz. Wireless 802.11n running at 2.4GHz can operate at a high speed, but as the MPW only uses 20MHz rather than 40MHz channel widths it isn’t the fastest. The lack of interfere between the two wireless connections, and the general lack of interference in he 5GHz band, will give a more reliable connection. Also with that configuration your network hardware will provide some more caching, and will generally assist in keeping the data flowing due the the nature of networking through a router.

I just checked the Bitrates of the sample videos and they vary between 13 and 17Mbps overall, and are all 17Mbps maximum Bitrate. That is not beyond the capabilities of even 2.4 GHz Wireless G which uses a 20MHz channel width, has physical layer bit rate of 54 Mbit/s, or about 22 Mbit/s average throughput. Wireless N on 2.4GHz and using a 20MHz channel width could double that throughput.

So even 2.4GHz Wireless G should be able to handle streaming those sample videos. There is a little bit more going on. Caching helps, and the power of the decoding device is critical, but there still seems to be something that prevents, for example, the sample videos from playing successfully on the second play (replay) on my iPhone.

Admittedly, if someone put a full copy of a Blu-ray disk on the MPW, a Wireless connection is going to struggle with that, as it can require up to 54Mbps throughput. DVD’s rips can require about 11Mbps. But most videos we carry around are more likely in the 5 to 10Mbps maximum, and many are below 3Mbps.

I suspect that there is an issue with the way the My Cloud App uses and controls its cache, and how it manages the video buffer.

However, if you know the capabilities of your playback device, in particular the bitrate of videos it can support and only try to watch video with that Bitrate or less, then any user should be able to use the MPW to stream videos successfully.

So do you have the “Streaming (DLNA)” setting turned off Mike, and are therefore just doing file streaming? Or do you use DLNA streaming?

Nope, not chiding you; just was giving you a heads up like a rattlesnake does so you don’t get too close again. :wink:   Agree, chid is a good word, and not too snarky.

Anyway, back on topic.  I will correct myself re: bit rate.  Before you appeared in this forum some of us, i.e. Tony, Joey, talked about why the sample videos were so cranky about streaming well, and one of them pointed out the MediaInfo video parameter labeled “Format profile” was high since it is “Main@L4.1”.  I checked some Handbrake videos I had made, and sure enough most were lower  (e.g. Avatar DVD is High@L3.1)    Not too many of my videos for iPad are higher than the Avatar,  Avatar mp4 runs well on iphone and pad, and stutters sometimes when streamed to Fire HD tablet.

Also, as you say, using two separate “highways” of 2.4G and 5G makes logical sense to me.  Good point.

All the theoretical specs loose their impact. as some is lost in the “overhead” loss of real world streaming.  It has been so long since I used the MPW off the network and in direct connect that I may be wrong in remembering, but I do think it worked pretty good at 2.4G for most stuff with minimal stutter.

By the way, the DLNA switch on my MPW is ON.

In any event, I have my MPW and Seagate wireless drive on my network to improve the streaming experience both in performance and convenience.  Works for me, so maybe for others, too.

Okay, I have been playing.

I just put the MPW onto my network, connected via 2.4GHz Wireless N. Then I copied files of various quantities and configurations from it to my local PC.

The worst stable transfer rate I got was a little over 5MB/s, while the best was about 8.5MB/s. They equate to 40Mbps and 68Mbps, both of which are quite reasonable.

Of course that was a wireless connection to a router, and then a wired connection to a PC. The sample videos play fine on the PC just using Windows Media Player, as expected, because the PC has the power to play them and Windows caches files properly.

  1. Then I downloaded one of the sample videos to my iPhone using the My Cloud App. It played fine over and over without any pauses. I noted that the video buffer filled immediately on starting playback of the video.
  2. Then I deleted the downloaded sample video, and went back to playing streaming from the MPW. Again it played fine in the My Cloud App, over and over without pauses, even though the file was no longer stored on the iPhone. I noted again that the video buffer filled immediately on starting playback of the video.
  3. I tested this by downloading a second sample video, playing it, deleting it, and streaming it again. Same result. The video buffer filled immediately on starting playback of the video, and there were no pauses on repeated playback.
  4. I tested the first video I had downloaded again. It still worked fine every time, and the video buffer filled immediately.
  5. I tried playing the third sample video before downloading it, and it still had pauses, even one in the first play. The video had lots of pauses, although after five or so the video buffer at least half filled when I started playback, and then kept ahead of the playback point. No pauses. For a while, then the problem returned. So then I downloaded that third video to my iPhone, and then deleted it from the download section of My Cloud without playing it. Then I went back to playing by streaming it from the MPW, and it worked every time. The video buffer filled immediately. No pauses after many plays.
  6. Then I cleared the cache on the MPW and tried streaming the three video again. The problem returned on every video.

My conclusion here is that caching is not working properly in the My Cloud App. Downloading to my iPhone put a full copy of the video file into the cache, even if it was immediately deleted. However just streaming the video did not put it into the cache, or only partly did, and inconsistently.

Mike, this might explain why a very large cache such as you use works. A really big cache just gets around the problem, whatever it is. You shouldn’t need an 8GB or 10GB cache on an iDevice for playback to work.

I think this answers the OPs question, and is sufficient to raise a Support Ticket.

So Regdawg, do you want to raise a Support Ticket and use this thread as input. I might not get a chance to follow this up for a while.

Roderick…I actually submitted a support ticket Thursday morning :smiley:. I’ll keep this thread updated with what they say. Now I don’t know if this makes a difference at all but just realized this. With DLNA off, as suggusted, at home, the streaming from the MPW to my tablet (Note 10.1) or my phone (Note 4) appears good. I got no lag at all streaming to the tablet and only a few lag moments when streaming to my phone, but nothing to complain about. Now at work, different story. I haven’t tried streaming to my tablet to work but on my phone, with the MPW right next to my phone, most movie files pause/freeze like crazy. In both instances (home and work), I’m connected straight to the MPW with no LAN involved. Not sure if that even makes a difference.

Is it possible there could be frequency interference at my job that could be causing the issue? Sort of like how certain things can cause issues with a wifi signal (cordless phones, microwave, etc.)?

Yes, it very well could be RF interference.  I concluded it so when I first was setting up the MPW by my computer station.  I moved away (downstairs at dining table) and set up MPW using iPad, and interference was not a factor and setup went perfectly. I also took MPW off of auto channel select and chose a clear wifi channel before going downstairs to finish setup.

My MPW currently is right next to my router in a different room than PC, and is wirelessly connected to router/network.  Works fine.

Important info coming up. . . .

I have completed my own experiments playing the mp4 Sample Videos from the MPW using different hardware to play them as well as an iPad (Gen3) using four different apps and this is my conclusion: Success depends upon the hardware used, and/or the iPad apps used. Under some conditions the videos played flawlessly and immediately (no decernable buffering) no pausing or stuttering; nothing other than playing well. 

The conditions:

For all tests, the MPW is connected wirelessly (@2,4G) to my router/network. All files played were coming from the MPW through the network.

Hardware used:

Win 7 laptop using Win Media Player. Played this way, I had the best results (as mentioned above).  Under this condition, I also played one of my most demanding videos – one made by Handbrake from a blu-ray source.  It started playing immediately, and when I moved to any part uf the file, it again played immediately.  No lags whatsoever.  Perfect playing.  When I played the three sample videos, again all perfect.

The other hardware used; a WDTV Live Plus wired to network. This condition also worked perfectly by both accessing the videos via Media Server and Network Shares.  The WDTV sees the MPW either way.

Tests with the iPad (connected to network using 5G band). Only variable was the app used – I used four different apps.  They are (in order of most successful):

INFUSE: It took longest to load and begin each video, but once video began playing it played perfectly.  Infuse sees only media servers; not shares.

WD My Cloud: First pass through video it may or may not have had a slight buffering moment; second pass playing video immediately, it buffered enough so that each video play perfectly.

AiCloud – an app specific to my Asus router that allows local and remote access to ny network shared devices and can play their media files.  It played almost as well as My Cloud, albeit with more a little buffering/pausing.

FileBrowser: Sees only network shares as well.  Performed the worst of all apps.  It started to play videos right away, and with minimal buffering, so there was immediate and frequent pausing until it got enough buffered.

BTW, all these apps play my Handbrake-made mp4/m4v videos fine from MPW.

Conclusion: Infuse appears to be the best of these video app players. It is one of my most recent apps.  It has a feature I do not want to use (although it is handy and others may like it).  It can display movie info from IMDB about the videos.  Problem is, it stores all this info on the iPad.  It can easily be turned off with the setting “Metadata fetching” and its cache of stored metadata is easily flushed, so not a major issue either way.  BTW, I purchased the Pro version for a few bucks.  If you use Infuse much, it is worth it.

Another important observation:

I ajso have an older model Seagate Satellite wireless drive (also on my network as a media server) that has trouble playing the MPW Sample Videos on its drives well as including my demanding blu-ray mp4 and some others from regular DVDs, I always have used Seagate’s app called Seagate Media to stream videos to mobile devices.  So, today I streamed them using INFUSE as I did with MPW and ALL videos did well!

Another conclusion: I am ditching using My Cloud app AND Seagate Media app for video streaming from my wireless drives and will use Infuse from now on!

When I get around to it, I will suggest to both WD and Seagate they figure out why Infuse can do a much better job of streaming video than their own apps can do!

regdawg wrote:


Is it possible there could be frequency interference at my job that could be causing the issue? Sort of like how certain things can cause issues with a wifi signal (cordless phones, microwave, etc.)?

Interference with the wireless network could certainly make the problem worse. I did my tests close to my wireless router. I may repeat them at some distance and see if anything improves. I think I have my MPW set to Auto channel selection. I prefer to do that as it moves from place to place and may come across other networks using different channels. Hopefully it is finding the “best” channel at each location.

I may have to rethink that. But I don’t want to be changing setting in a hotel somewhere after a long hard day. I just want to use the MPW. Hence, the Auto setting.

Perhaps you could share the test steps I used in comments on your Support Ticket. I think they clearly show that when the My Cloud caching works, there is no problem. But it doesn’t generally work well enough.

mike27oct wrote:

Important info coming up. . . .



When I get around to it, I will suggest to both WD and Seagate they figure out why Infuse can do a much better job of streaming video than their own apps can do!

Good work Mike.

One point and one question from me.

First, as the MPW is connected on your home network during all the tests, your router is probably providing a little extra buffering for the video, and may even be acting as an intermediary and requesting the next bit of data before the Apps have done so. Some routers do that. In fact some Infrastructure type network connections do that automatically. It is usually part of the Quality Of Service (QOS) functionality in a router. Routers with good QOS functionality recognise when media is being streamed through them and facilitate the process to ensure smooth playback. So that may have been assisting in your case. Hopefully that kind of functionality is now built into Apps, but maybe not in the My Cloud case.

Question. In your testing, did you have any situation where the video buffer in the player filled immediately and hence no pauses occurred? Or did the buffer just move ahead of the play point as the video played? 

What I mean by video buffer in this case is the line that runs across the progress bar ahead of the playback point. I notice in the My Cloud App that when this buffer wasn’t full and I manually paused the video, the buffer also paused. On many streaming video sites on the web, such as YouTube, the video buffer will continue to fill when the video is paused, so a user can build up a large buffer and avoid playback problems. Not so with My Cloud.

One extra. I noticed that on second playback of the sample videos with My Cloud you always got a good play with no pauses, while I almost always got a bad play. I assume from your description that the buffer didn’t fill immediately on your second play, but stayed ahead of the playback point all the way through the video?

Oh, by all means let WD know they should do better with their App, particularly the caching (image thumbnails and video) and streaming functionality!

Actually Infuse works with SMB shares fine – you just have to manually imput the URI’s – it’s somewhat faster using SMB than DLNA, too.

But, I’ve kinda given up on Infuse.  It doesn’t work well if you don’t have an internet connection – it limits the functionality even if all the metadata is in the files themselves.

This last upgrade also made it where it no longer reads the “Long” plot/overview metadata tag – instead only reading the short one – limited to 254 characters.

   Question. In your testing, did you have any situation where the video buffer in the player filled immediately and hence no pauses occurred? Or did the buffer just move ahead of the play point as the video played? 

It could have when streaming to PC or WDTV as video was instant, but no indication of so doing.  Using Infuse on iPad took a whle with a spinning wheel (likely to cover over any buffering indicator). I know what you mean about a progress bar showing buffering taking place, but not all apps showed this like My Cloud.

TonyPh12345 wrote:

Actually Infuse works with SMB shares fine – you just have to manually imput the URI’s – it’s somewhat faster using SMB than DLNA, too.


   Thank you for reminding me about this (and I clicked on the ( + ) in upper right to be sure I had on my SMB links, too.)


But, I’ve kinda given up on Infuse.  It doesn’t work well if you don’t have an internet connection – it limits the functionality even if all the metadata is in the files themselves.


    Weird.  maybe I can turn off my internet but keep network going so I can test this.  Maybe the files still play – just the metadata goes 'cause without internet it can’t check IMDB


This last upgrade also made it where it no longer reads the “Long” plot/overview metadata tag – instead only reading the short one – limited to 254 characters.



So here’s WD’s response to my questions. Basically told them exactly was experiencing…pausing/freezing videos during streaming. 

Thank you for contacting Western Digital Customer Service and Support. My name is [[Deleted - Trancer]]. We apologize for the delay in response to your inquiry, I will be more than glad to assist you. In regards to your support case, please perform a System Only on the device, as this normally fixes some glitches or other small errors caused by a failed firmware upgrade or faulty configuration settings.The device will go back to default settings without deleting any of the files currently stored on it. The administrator user and password on the device will reset to default "admin" and no password. To perform a System Only open the dashboard of the device and go to Admin > Restore Factory Settings > System Only.Once the process completes and the device reboots, make sure the firmware on the My Passport Wireless is up to date to the latest release 1.03.13. In case that the firmware is already up to date to version 1.03.13, it is possible that the firmware did not install correctly on the device. To make sure the firmware installs successfully, please perform an "Manual" update to force the firmware to be re-installed. Please reply with the results.Product update for My Passport Wireless you have any further questions, please reply to this email and we will be happy to assist you further. Sincerely, [[Deleted - Trancer]] Western Digital Service and Support

That wasn’t very helpful, was it?

Perhaps if you let them know that a lot of other people are having the same problem. We can’t all have had a bad firmware installation. We could all have installed firmware that isn’t very good though.

In fact, it would be pretty amazing if a bad firmware installation resulted in the MPW working at all, let alone working with all functionality, except good video streaming/caching/buffering.

Basically that is the same non-response that most hardware support people give, until an issue is escalated to someone who knows what they are talking about.

PC support:                                      “Is the power on?” “Reboot your computer”

Internet Service Provider support:   “Reboot your modem” “Disconnect the cable, then reconnect it”

Sometimes those things can help a local issue, but never a systemic problem that appears on multiple devices.

Are you going to continue to try to escalate this issue with WD?

Absolutely! I’m not taking that response as a fix. Any tech person would know to reset and restart. Thats the #1 first responder fix for a PC issue.

I’ll keep everyone posted…

Well. good luck with your issue and with WD Support.

I hardly have any videos that will not stream smoothly via wirelessly.  My network is basically, “uptight and right”. Although, in the few cases of those that have any stalling and other types of issues, in the experiments I did last week disclosed that the APP used to stream (although it likely is a “good one”, e.g., My Cloud and Seagate Media apps) other apps can work better for the most pesky videos and improve, or even eliminate, streaming problems.

I mentioned that the app, Infuse, rose to the top as the best of my four apps tested.  It is because it buffers videos the longest, and continues to keep the buffer full once video is rolling along.  Over the weekend, (and since my MPW is on the network and I did not want to take it off,) I used my older Seagate Satellite as stand-alone and off the network.  Using its 2.4G wireless signal to iPad and phone, I successfully played the difficult parts of my videos kept on the Satellite drive by using Infuse app as the player, and all went well for all the videos.  These are videos on the MPW that play fine using My Cloud; this includes the MPW Sample Videos (that don’t play well using My Cloud but do well using Infuse}.  Playing these videos on both drives using Infuse did great.

So, try Infuse, because if it can’t play them, likely nothing can.  You likely need the paid-for version to play any file not on your iThing.  Infuse Pro costs just a few bucks.

Based on Prymsnap’s result over here, perhaps we should all redownload the firmware and install it manually.

His was a wireless issue though, not streaming, but it is interesting that a manual firmware update made a difference. I think I will be doing all future updates that way.

Actually, that is what I did for the lastest version anyway.

WD Support will suggest you do the manual update next Regdawg, so get in first and tell them you have just done it!

I think infuse is only for apple