Upgrade Twonky to 8.0.3


#1

Hi

Does anyone know how to upgrade Twonky on the myCloud to version 8.0.3 from 7.2.9

Cheers

Rick


Is it possible to update the Twonky server
#2

Find the location of twonky on your NAS, then wget the new version suited for your NAS into the same folder.


#3

Is that possible on V4, 64K page size firmware?  And isn’t Twonky commercial, licenced s/w, and therefore restricted access?

I’d certainly be interested in running 8.0.3, if it’s possible on 4 firmware.


#4

We need something like this…    http://mybookworld.wikidot.com/forum/t-459592/complete-guide-to-upgrade-to-twonky-7-version-my-book-live-o

Maybe someone can have a crack at it :slight_smile:


#5

Hi, 2 weeks ago i purchased a new EX4100 and searched also for a guide to upgrade the installed twonky 7.2.9-13 to twonky 8.3. But there was no post to find in the web. So i tried it myself and succeed.
The upgrade process is not difficult, but a little bit tricky.
Some Linux experience would be an advantage.

The operating system of the new MyCloud devices is very closed. All critical files are stored in hidden storage areas and are not directly accessible. But the good news are: WD provides the entire firmware package as open source. So you can update existing modules or even add new modules.

You must create your own custom Firmware with the new twonky Version inside!
But note: You have to purchase a twonky license key before you go on to work on this. Otherwise you are not able to activate twonky after Installation of your custom Firmware.

Before you begin:
ATTENTION by all steps. Only one mistake can destroy your NAS!
Please note that no guarantee is given on my part. All subsequent steps are at your own risk. Even a small bug can make your NAS useless.

You need a installed Ubuntu 16.04 on a virtual machine like virtualBox (this is freeware from Oracle), configured with min. 14GB virtual harddisk. If you use Ubuntu 64bit you have to install some missing 32bit librarys (so i recommend the usage of Ubuntu 32bit).
You have to download the original Firmware source for your WD EX4100 from the WD download page (for example http://downloads.wdc.com/gpl/WDMyCloud_EX4100_GPL_v2.30.165_20170321.tar.gz)
For the EX device you have to download the twonky update build for Marvell Armada Processors (http://www.twonkyforum.com/downloads/8.3/twonky-armada-8.3.zip).
Copy the EX4100 source Archive and the twonky 8.3 Archive to the Ubuntu machine’s Download folder. You can use the Public share of the EX4100 for this Transfer steps.
Note: Copy the twonky Archive at first in a new Folder called twonky!
Expand the archives.
Now you have to replace the original twonky Version with the new one.
Go to the Firmware Folder inside of the EX4100 files. Go two Directorys deeper to the module Folder and search for the twonky Folder.
Rename the twonky Folder to twonky_x (we need some files from the Folder in later steps!)
Now copy the expanded twonky Folder with the new twonky Version into this Directory. Go inside the new Directory and delete the cgi-bin Folder and the files twonky.sh and twonkyserver-default.ini. Now go to the old twonky_x Folder, copy the cgi-bin Folder, the twonky.sh and twonkyserver-default.ini and all other additional files, which are NOT part of the new twonky Folder and paste them into your new twonky folder.
When this is done, you can delete the old twonky_x Folder -
but ATTENTION: do NOT delete or move any other file or Folder inside of the Firmware package - otherwise you can destroy your NAS!

Now it is time to build the custom Firmware.

Inside the expanded EX4100 source Folder you can find a description called My_Cloud_EX4100_Release_Notes_GPL…, to guid you through the build-process of the Firmware package.
Perform step by step of the guide-content, but ignore and skip step 3 (you don’t need step 3)
If you get some Errors because of missing Linux program parts, you must install them with the “sudo apt-get install” Linux command.
If you can process all guided steps without Errors, you get your own custom Firmware inside of the merge Folder (named WD-NAS-Firmware) with the new twonky Version inside.
Copy the file WD-NAS-Firmware to your local Windows machine into a local folder by using the way over the Public share of your EX4100.
Now you can install the Firmware by using the EX4100 WEB-Frontend. Deactivate auto-Firmware update to avoid overwriting your custom Firmware in the future.
After the finished Firmware update activate Media streaming on the EX4100 WEB-Frontend Settings page.
Now open a new browser tab and go to twonkys web address (for example http://MyCloudIP:9000). Type in your purchased twonky license key and klick save (or enter). Refresh the web page and make your twonky Settings.

This is it.
I wish you good luck!

This guide can also be used for the DL4100 - but you must download the right Firmware and twonky sources because the DL devices are based on a different processor brand!
The devices EX2100 and DL2100 and all MyCloud devices using FW 2.xx.xx can be updated the same way if a GPL source code package for the current firmware is available.

Edit on 2017-05-20:
Before you use your custom edited Firmware, look at this:


Upgrade My Cloud to Twonky 8
WD My Cloud & Twonky Server
Twonky upgrade
Twonky Server - Upgrade auf v8.3 auf WD My Cloud Mirror möglich/gewollt/geplant?
How to run a user boot script at MyCloud Gen2 (2.11.xx) devices
#6

Yesterday I upgraded my MyCloud EX4100 FW Version 2.30.165 to twonky 8.4.1.
Now I’v got back full access to all iTunes playlists.
So it is possible to create playlists on iTunes and use them on every place in my home via DLNA.


#7

@Buchi1000
Hi,
I made my firmware using your recommendations. Unfortunately after uploading it to my WD Cloud my blue led just blinking for many hours, seems I have lost access to it. Any chance to troubleshoot of reformat it back.
Maybe there is way just to put “original” firmware and try it again?
I have HDD removed and connected to the PC - any chance to access the data?

thx in advance

I’m using My Cloud 3TB Gen2


#8

Did you use the EX4100 sources…?

You will need to search for threads on ‘unbricking’ or ‘debricking’, which explain how to reinstall the correct firmware.


#9

I’m using WDBCTL0030HWT My cloud version 2 and I have used this package WD_MyCloud_GPL_v2.30.165_20170321.tar.gz from https://support.wdc.com/downloads.aspx?p=269&lang=pl

I’m a little confused why it happened as there was no errors during the process. You actually cannot compile new firmware if you miss any step like ramdisk etc. so let’s see/

Question: after firmware update via web GUI how long is the process, minutes right? or whole repartitioning is happening?
this is like normal firmware upgrade so should be quick process, am i right?


#10

@QQryQ
To build and install a custom firmware is a very riscfull process. Only one little fault can brick your NAS. So it is strongly recommended, to backup the data before installing any new firmware. No matter. whether original firmware or custom firmware should be installed.
In the meantime I have doubts that the provided source packages actually works well. I built a custom Firmware without any changing of contents. After installing this firmware i had the same issue of faults of some functions. Unfortunately, WD does not offer any assistance at all.
I think you can access your data with a Linux / Ubuntu operating system drived PC or VM machine, but I have no experience with it to provide instructions for your device.
In the past i had to unbrick my “WD my book live” and i fixed it successfully. but the new WD devices have a completly different construction of firmware.
However, I think the data can be successfully found and copied from the disk.
To connect your drives to a Ubuntu OS you can use a hard disc connection adapter. So you don’t have to install the drive into a computer case.
During the unbricking process, the data areas of the disk should remain in place if, after the restore, the shares are created exactly as they were before. But I can not guarantee this, of course.
So i wish you good luck on unbricking your device!


#11

I have manage to install Twonky 8.4.1 by dirty way :slight_smile: without any integration to the inside of the box or changing official firmware.
I have followed topic about APP installation (on my single bay 3TB MyCloud) installing app button was hidden.

I have installed one of many apps available, then logged via ssh and reused this app start scripts to actually run Twonky 8.4.1 as its structure is not prepared to be installed as other APPs are.
The only thing worth mentioning is that Twonky is using some predefined paths where storing its configuration but there is a switch “-appdata” which allows you to store everything within same folder where you have write access and won;t be deleted after MyCloud restart what was the issue before.

everything working as a charm for few weeks.
thx for all the hints


#12

@QQryQ
This is a very interesting way to bypass the firmware.
How could you find the storage path, where the startscript is located?
What Software Installation did you use for your trick?


#13

I have installed plex app just to try other DLNA server. as I don;t like it I have reused it’s start.sh script to start Twonky instead of Plex.
Location of the public folder(where are your shares and Apps) are here /mnt/HD/HD_a2/Nas_Prog/
inside plexmediaserver I have hashed(#) all lines and added just one line

/mnt/HD/HD_a2/Nas_Prog/plexmediaserver/twonky/twonkystarter -appdata /mnt/HD/HD_a2/Nas_Prog/plexmediaserver/twonky/appdata &

Full folder location to Twonky and making this location also destination of all config files (not to lose anything after restart).

after these steps Twonky needs to be configured using :9000 port but this is easy. Licence will be needed after 30 days.

PS.
How to install APP topic - WD MyCloud Gen2 - Enable apps install tab + Apps!

Twonky download location - Twonky WWW


#14

Why not remove that plexmediaserver/ from the path, and put the new Twonky in its own folder in Nas_Prog? i.e.

/mnt/HD/HD_a2/Nas_Prog/twonky/

It’s also worth noting that this is for the Gen2/v2 firmware MyCloud.


#15

@QQryQ
Thank you very much, this is a really smart way to trick the firmware. I’ve really tried a lot. But I would not have come to that idea.


#16

Hello twonky users.
Based on the idea of @QQryQ and the tips of @cpt_paranoia I have now changed my WD EX4100 also to Twonky 8.4.1.
Actually an extremely simple thing.
Because I already have a Plex Server installed for external access to my music, it’s even easier.
If you have not installed Plex, just install it directly using the firmware feature - available at Apps - App Store.
After installation DO NOT activate the Plex Server!
If the original Twonky server is activated, DISABLE IT ALSO!

On the first drive (normally mounted under / mnt / HD / HD_a2) is the directory Nas_Prog.
In this folder create a subfolder called twonky, then copy the twonky installation ZIP file into the folder twonky and unpack it with the command “unzip twonky_file.zip”.
In the folder twonky, there is a subfolder named cgi-bin after unpacking. It stores the components needed to create thumbnails.
The cgi-bin folder must be deleted with “rm -r -f cgi-bin” because the creation of thumbnails only works with the original firmware components.
The cgi-bin folder is replaced with the original NAS firmware files.
For the sake of simplicity, I have compiled a ZIP file for all those interested, which contains all the modifications.
The custom twonkyserver-default.ini is also included in the ZIP to change the default port 9000 to 9001. This prevents an address conflict with the Twonky server being installed with the firmware.

Now only the integration into the boot process of the NAS is missing.
The necessary files can also be found in the ZIP file.
A ZIP is for operation with Plex Server. The other file is for operation without Plex Server.
Save the ZIP file to the public share and then copy it with “cp /shares/Public/MyCloud_xxx.zip /mnt/HD/HD_a2/Nas_Prog”.
Switch to the folder with “cd /mnt/HD/HD_a2/Nas_Prog” and then unpack the file with “unzip MyCloud_xxx.zip”.
Finally, it must be checked whether all important files have the executable file mode.
The files
… /Nas_Prog/twonky/twonky (the twonkyserver start / stop script)
… /Nas_Prog/twonky/cgi-bin/* (all files in the folder - for the thumbnail creation)
… /Nas_Prog/plexmediaserver/start.sh and stop.sh (If the Plex server is used and get an update, these two files have to be replaced by the modified files again)
must be executable.
Therefore, you have to change the mode of the files to be safe with the command “chmod 777 filename (or *)” to executable files.

If I have forgotten nothing, now the server should be activated.
Activation takes place via the configuration web page of the NAS under Apps - Plex Media Server.
The Twonky server should now be reachable and configurable via the IP address of the NAS Port 9001 (http://NAS-IP:9001).
MyCloud_PlexNo.zip.txt (81.2 KB)
MyCloud_PlexYes.zip.txt (81.2 KB)


Upgrade My Cloud to Twonky 8
Twonky Server - Upgrade auf v8.3 auf WD My Cloud Mirror möglich/gewollt/geplant?
#17

thx @Buchi1000 very good manual.

I have made thumbnails working following the steps from Twonky FAQ page and downloaded build from HERE
actually you just need to extract one file ffmpeg and put it to cgi-bin folder (depends of you architecture CPU)
Twonky will handle the rest.


#18

Just an FYI in case you didn’t know. The single bay/single drive My Cloud units (the subject of this subforum) do not officially support Plex. Furthermore there is no way to officially install Plex through the Apps tab on the second generation v2.x single bay My Cloud units. The first gen v4.x single bay My Cloud Dashboard does not even have an Apps tab.

There are various methods discussed elsewhere in this subforum on the single bay My Cloud to unofficially install Plex on both the first gen v4.x, and second gen v2.x single bay My Cloud devices.


#19

@Bennor: Thank you for your information.
Of course, my posts only concern the WD EX2xxx and WD EX4xxx devices with Gen.2 firmware version 2.30.165. Whether my solution is good for other devices, of course, everyone has to find out for themselves.