Unrecognized Hard drives


#1

I have had several hard drives attached to my WD TV, some of them are not on the list as being able to be recognized but they have all worked just fine. The largest was a 2TB. I just tried a new 4TB USB2 “Ultra Speed” hard drive and it won’t recognize it.  Is there a way to partition the drive or set the WD TV so that it will recognize it. I hate to have to return this drive!


#2

The list for compatible isn’t exclusive; it’s just a list of devices tested and known to work at the time they were tested.

I’m guessing that 4TB unit actually contains two drives?   If so, I’m guessing further that it’s implementing some sort of RAID configuration to get that capacity.   I haven’t heard anyone do that successfully yet, but who knows…

There’s nothing settable in the WDTV to get a drive to work or not; it might be partitionable, but you’re entering the ranks of “Test Pilot” when you go that route… :wink:


#3

If I remember correctly, the WD TV’s will only recognize up to 2 TB’s of a direct attached drive.


#4

Why the 2TB limit?? is there any plans to expand this in the future?


#5

It’s just a limitation of the Linux system we use.  Also, the only larger drives right now are RAID drives, which the WD TV can’t read, anyway.