Unbrick mycloud 1 bay gen 2

Typically message means that one may have to restart their Linux OS PC so that the Linux OS will properly see and uses the newly created partitions on that hard drive.

Other troubleshooting suggestions. Use GParted within the Linux GUI to remove all partitions on the hard drive. Then use GParted to create one single partition. Then when following the unbrick steps use “parted” to remove all existing partitions first, then follow the steps to create the required partitions for the My Cloud OS structure. Also as a troubleshooting step, remove any other hard drive attached to the PC other than the My Cloud drive to avoid any possible issues. Check the drive for SMART errors or physical errors.

Not sure it’s been asked but what hard drive are you trying to use to perform the unbrick procedure on? In other words; what make/model hard drive will be put into the My Cloud enclosure? Wonder if the issues you are having are specific to only that drive. Don’t recall anyone having such issues repeatedly while unbricking using Fox_exe’s directons using either the main 2nd gen unbrick method or the alternate method.

Hi @Bennor- I am using the WD NAS drive which comes in My Cloud.

i have checked it doesn’t found any errors.

let me perform the steps suggested by you now.

i just noticed that after making partitions in Gparted all partitions are showing as unknown, do i need to format them before i assemble in WDMC:

@Jorawar, something wrong. Partition 3 must be formatted in Ext3 (or ext4) format and contains “boot” folder with uImage and uRamdisk files inside.

When following the alternate direction steps, have you performed the following step after quitting mkpart where indicated in the alternate directions steps? Example using your /dev/sdb layout:

mkfs.ext4 /dev/sdb3

The mkfs.ext4 step will format /dev/sdb3 as EXT4. From there you can copy, as the directions state, the appropriate files to folders you create on that EXT4 partition.

Per your screen capture it appears you have formatted the wrong partition for EXT4. Your screen capture shows partition 2 (/dev/sdb2) rather than partition 3 (/dev/sdb3) being EXT4.

@Bennor @Fox_exe - I followed below Link and i am able to unbrick my disk:

i was following Fox’s method but it doesn’t work, so just concern when we create the partitions do we need to format the other partition to some specific format?

SDB2
SDB4
SDB5
SDB6
SDB7

because as per Fox’s method we are only making SDB1 as “mkswap” and SDB3 as “ext4”

might be the it is causing the issue as other partition are “UNKNOWN”

should i format the partition to specific format before putting it to WDMC and Boot UP?

@Bennor @Fox_exe-

I am able to unbrick with above link, but getting below issues:

1 Not able to Make Static IP
2 Not able to Change Drive Name
3 Not able to Change admin user name.
4 Not able to access the drive over WD My Cloud app or web portal.

as soon as i reboot, it turns back to default.

@Fox_exe- Please confirm, with your method do i need to format the below partition before booting up with WDMC?

SDB2
SDB4
SDB5
SDB6
SDB7

After performing the unbrick procedure, if you can access the My Cloud Dashboard but there are still errors or issues. One troubleshooting step is to perform a System Only factory restore via the My Cloud Dashboard > Settings > Utilities. If after a System Only factory restore the issues persist, try performing a Quick Restore.

Note a System Only restore does not delete user data. But a Quick Restore will delete all user data.

i tried doing Quick Reset, it end up with bricking the drive again.

quick reset stuck at 98%and Full Reset stuck at 31%.

Please confirm, with your method do i need to format the below partition before booting up with WDMC?

SDB2
SDB4
SDB5
SDB6
SDB7

While I do not have a second gen single bay/single drive My Cloud, on a first gen one does not need to format most of those partitions. On a first gen the SDB1 and SDB2 are linked together to create MD0. SDB3 is set as a swap partition. SDB4 on the first gen is the main user data partition. Which is why on a first gen one formats SDB4 as EXT4.

On a first gen one does not need to format; SDB1, SDB2, SDB5, SDB6, SDB7, SDB8. One is pushing the rootfs.img file to MD0 (SDB1 and SDB2). On is pushing the kernel.img file to SDB5 and SDB6. One is pushing the config.img file to SDB7 and SDB8.

However, one generally performs a different method to unbrick a second gen v2.x single bay My Cloud. It is quite possible something similar ultimately happens. That certain img files get pushed to certain partitions.

No.
These partitions will be formatted by WD Firmware installer later.

Not sure, what i am doing wrong then…

It is going to be a really stupid question. But are you sure you have a gen 2 single bay/single drive My Cloud? Check the P/N number on the bottom of the My Cloud enclosure, a second gen’s P/N should be something like this and end in a “-10”: P/N: WDBCTLxxxxxxx- 10

@Bennor- Yes Mate it’s Gen 2

WDBCTL0020HWT-10

Hello guys
I have a 2nd gen device(PN ends with -10) .
Somehow the device was dropped on the floor and the hdd is damaged mechanically.
I tried to put a different hdd(2Tb) but, no matter the image i’ve downloaded, the led is still blinking red.
in the past, i had some problems with the device and i’ve solved these problems with this guide:

Now, (stupid me), i can’t find the WD Recovery + My miniOS and the link isn’t working anymore.
Does anyone still has these files and can make them available to download?
thanks.
Cristian

Sorry to jump in on this…when formatting other volumes can this be done using gparted within Ubuntu?

How were you able to get the firmware loaded? Mine stays stuck at a spinning wheel with 0%?!

so, I am also having spinning wheel and no percentage shown, but when i displayed debug console on my browser while sending bin file i get HTTP error 413 - Request Entity Too Large. Cant get around this at the moment, maybe someone has figured it out?

Edit:
After using image My_Cloud_GLCR_2.31.204.bin the firmware flashed successfully, had to do 4sec reset, ten multiple try configuring device and upgrading to latest os5 firmware. Now the problem is i cannot login to cloud account from device, so it is unavailable from mobile app etc.

You likely are experiencing the indexing issue that drags down the single bay/single drive second gen My Cloud making it inaccessible. Depending on how much data is on the drive (if any) it may take several days or more for the indexing to finish.

There is a different subforum for OS5 issues. This subforum deals with OS3 issues.

OS5 My Cloud
https://community.wd.com/c/os5/my-cloud-os5/257

Some WD Support Knowledge Base articles on the OS5 indexing issue.

My Cloud OS 5 Cloud Access Content Indexing FAQ
https://support-en.wd.com/app/answers/detail/a_id/30021

Best Practice for My Cloud OS 5 Cloud Access and Indexing
https://support-en.wd.com/app/answers/detail/a_id/30014

Thanks for info! Unfortunatelly it was not the indexing.
the solution for my problem was:
settings->utilities,
restore default settings: system only.
then i set up the device once again and during this setup i could login to cloud account.
for those that in the future may experience similar issue: you can do configuration backup before it, and after you can do import of the settings.