Unable to write to my drive anymore


I’ve had my My Cloud 2TB drive for about 18 months now, haven’t wrote anything to it in a while but have just attempted to but for some reason i can’t, i can’t create folder or delete anything from the drive.

My settings have been left unchanged since i last wrote anything to the drive, but now when i go into the devices on my network (Windows 10), double click on the drive where its listed under ‘storage’ but it just opens up the WD web page, i right lick then select open but nothing happens, i’ve tried using the WD Access program too but it fails to upload any file i choose.

Any idea at all what this problem is? I feel like i’m about to pull my hair out of bin the thing lol

Thanks in advance.


Has your Windows 10 installed any updates recently?

Or has your MyCloud updated its firmwasre?

I’ve tried this bud, no joy.

Both the WD drive and Windows have had updates in November, what update through Windows am i looking at in particular? Baring in mind that i haven’t uploaded anything to the drive for a good 6-9 months so if its to do with a Windows update then i’d have no idea where to start looking.