Unable to connect to Netflix on most movies

I have 3 WD Live Plus boxes and all three have stopped streaming on 90% of the netflix movies I try, the progress bar freezes at about 25% and eventually errors out “We’re unable to connect you to Netflix…” but there is still a few movies that work fine which is really confusing and it’s always the same movies that either work or do not.

My Xbox and PC both have no problems with any Netflix titles and all 3 WD boxes started acting up approx a week or 2 ago. They worked flawlessly since I got them 6-8months ago, I have tried everything and have no idea what the issue is.

It’s not my router (every other device on it works fine), the date time is correct on my router and WD boxes, most recent firmware installed, reset boxes to factory defaults, removed and reactivated boxes on netflix…

Was the problem there before or after you installed the current firmware?


I use the previous firmware, v1.05.04_B because of the bad reports about the current firmware.  I have no problems like this with Netflix. You could back down one of the Live Plus units with the previous firmware and see  ifthe situation improves. I would check the step below, first.


You could also have low bandwidth/speed issues and Netflix just “gives up” on any video with much complexity.  Run a bandwith test at any of those kinds of websites.  Be sure to select a location nearest to you.   You definitely want minimum of 5-10mbps download speed.  Anything around 1.5mbps is too low.

Check speed here:  http://www.speedtest.net/ 

edited minutes later: 

Just down from your new message is this thread that’s been going on and it sounds like the problems you are having:


Been running the most current firmware for a long time with no issues, bandwidth is great 4.99Mbs and every other device runs Netflix perfectly it’s just the 3 WD Live Plus boxes.  Read the other post and it looks like replacing the boxes fixed the issue but the odds of all 3 of my boxes failing at the same time seems odd, also when a small selection of movies do work fine makes it all the more confusing.

Just changed my DSL Modem/Router and it solved the problem.  No idea what went wrong with the other one considering everything else worked fine just certain Netflix movies were being affected.

Good job troubleshooting.  It sure is logical that it had to be something common to the three units.  Strange that it was the router; then again, perhaps not so strange.  Hope the fix sticks!