Unable to access Dashboard - very annoying

Evening all

I have been trying to access dashboard for a few week now to no avail. Getting quite annoyed and frustrated with this now.

I type in http://mybooklive and it automatically changes to http://mybooklive/ui and all i get is a blank white screen.

I have tried using the IP address and i get the same response.

I have recently downloaded WD2go and WD photos for my phone and I need to gain activation codes from my dashboard to enable access. its annoying that due to reformatting my phone that i now have no access.

I have tried 2 laptops and a desktop pc all with the same response. All running Windows 7 with all updates installed.

I hve access to the drive through my pc’s with no missing files, but just no access to dashboard.

Can anyone offer any assistance

Thank you

If you don’t have SSH enabled, then you’re going to have to manualy debrick it or RMA it.

I’d recommend RMA’ing it, because debricking it manually will void your warranty.