Twonky Media Server and LG tv dont work together?

Hi all, I just bought the WD MyBook Live 2TB NAS.  The only reason why I bought it was for media streaming to my LG Smart TV.  I have the LG 47LW5600 tv.  When I go to DLNA in the TV input section 4 DLNA servers show up.  Two are Win7 computers, 1 is the MyBook Twonky, and one is my Cisco Router.  When I select MyBook Twonky, it says “connecting” for a split second then I get an error on my tv that says failed to connect, please check connections.  When I start up my PS3 and go to video and then select Twonky, it seems to connect but then it says “There are no titles”.  But I do have two video files on there, I forced Twonky to rescan and rebuild the database and they show up in the web UI under videos it shows “2”.  When I get on one of my windows 7 computers and start up Windows Media Player I go to libraries and select Twonky and I can play the movies right there, just like its supposed to.  What is the deal with Twonky.  I seem to read a lot of problems in here in relation to twonky.  Sounds like this machine is a piece of garbage.  Anybody else actually get theirs to work properly with LG tv’s?  Should I send it back and get a Buffalo NAS station?  They seem to work and they also have built in bit torrent program.  Is there an alternate media server I can load on this piece of garbage that works better than twonky?  BTW I’m on firmware version MyBookLive 02.11.09-053 : Core F/W.  I cant seem to get it to update to 2.11.12-060.  Is that one any better?

It is working correctly on my LG 55LX6500.  I don’t know why you’d be getting Connect errors…  I don’t know if it’d be related, but why can you not update the firmware?

When I go into the web UI for the mybook and go to the firmware section, it says it’s already up to date.  When I go to the western digital webpage it says that 2.11.09 053 is the newest firmware, but on this forum it seems there’s a newer one, I can’t find it anywhere to download it to install it.

Did you leave your MyBook on DHCP or did you give it a static IP?

And it’s not just my TV, my PS3 wont work either. is the latest available, and is the version I have; WD cancelled the last update due to issues.  My MBL has a static IP.  Try logging into the Twonky web page and disabling the “Restart on NIC changes” option.  It’s a long shot, but it is also the only change I’ve ever made to Twonky…

thanks for your suggestions.

When you say log into the twonky web page, you’re talking about accessing the web UI of the mybook live via web browser (such as http:///UI), correct?  Or is  there some other way to access twonky?

When I log into the web interface of the mybook live, then click on the heading “media” where the twonky settings are at, I dont see an option to disable “Restart on NIC changes”.  All I see are a “rescan” and “rebuild” button for the database then the options to block or unblock certain media players on my home network.

I did a lot of tinkering around with it last night and the only thing that worked was to do a full factory reset and just let it go via DHCP.  when I did that, my tv was able to connect to it and browse the folders.  Everytime I tried to give it a static IP, the tv and PS3 would no longer be able to connect to it after that.  They would see it on my home network, but could not establish a connection.  After that, I did run into other problems; such as, about 5 mins into the movie, my tv would give an error that the file wasnt valid and it would crash the video playback.  My PS3 wouldnt even play back some videos, they were shown as corrupt data.  But i know they’re not corrupt and I know they’re valid files because they play back fine on my computers and they play back fine on USB drives plugged directly into the tv and PS3.  After these errors came up, I had to rebuild the twonky database and they played fine…for a while.  Once I added a new file to the Mybook then i got those same errors again and I’d have to rebuild the database every single time I added a new file to it.  It’s been more trouble than its worth.

I wanted a central file repository where I could dump movie files and access them at any time from my TV or PS3 for convenience.  This thing is so wonky that it’s easier to just copy one movie at a time to a 4-8GB mem stick and play it from that.

Do you know of any other media server applications that I could install on the MyBook Live that are better?  Because twonky [Deleted], they should have named it wonky.  there’s literally thousands of complaints about twonky all over this forum and on other forums.

The Twonky UI is at the same IP address, but add :9000 to the URL.


There are instructions in this forum (by other folks) that tell how to install Twonky Version 7.x

… they’ve made a LOT of improvements to that version, but you’d have to buy a license  (I think it’s like $10 USD)  Unfortunately, WD isn’t licensed to run any Twonky version other than the one they contracted to a 3rd party to provide.

… but you can try it free for 30 days or something like that to see if it fixes your issues…

Just FYI, I had similar “weirdness” on mine until I disabled that option I refer to earlier…   My DLNA music player (a WDTV Live Hub) would play music fine for anywhere from 3 minutes to 2 hours, and then just quit.

Once I disabled that option, it’s totally rock-solid.

Thanks!  I will certainly check it out further when I get home.

I have WD Live 3gb and it took me a minute to get it working but with the help of some of the members and the tutorials everything works great. You do have to buy a license, do the firmware upgrade, enable twonky for ssh, and then read the tutorials especially the one from philburton.

@moman61 I could not find any posts from user “philburton”, is that his user name? If not, do you have a link you could reply with for the tutorial you’re referring to?