Twonky database keeps getting corrupted

I haven’t found any other threads describing this problem, but hopefully someone here can help.

We had an old WDMyCloud for several years, running as a DLNA server. On OS3, the DLNA module was a built-in implementation of Twonky Server, but it worked perfectly for the entire life of the device.

When OS3 was retired, we upgraded to MyCloudEX2Ultra running OS5, which is where the problems have started. I have installed the Twonky plug-in and configured it, even going so far as to install FFmpeg to get thumbnails working (My Cloud OS 5: Twonky Video Thumbnails Not Displayed)

It worked fine for a while, but suddenly the database stopped registering on my devices. Loading the videos tab on the Twonky dashboard would cause the page to freeze. I tried everything, but eventually the only solution was to rebuild the Twonky database, using this Knowledge Base page: My Cloud OS 5: Twonky Server Configuration and Settings

This is now happening every few weeks. I’d rather not have to keep wiping out the database like this every time. It seems excessive, but nothing else I have tried works. Especially annoying, given that the old device worked flawlessly for several years.

Has anyone else experienced anything similar? Any ideas to stop this from happening?

Hi @TwonkyProblem,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: