Time machine thinks my drive is not formatted properly. (It is.)

I have searched for posts with my specific issue but have not found any, here, or on Google. I hope someone here has some helpful information for me. I have posted this issue on the Apple forums. Thus far I haven’t found what the problem is.

I recently updated my Mid-2012 MacBook Pro directly to Catalina 10.15.5, skipping any earlier versions of Catalina.

I have a 4TB WD My Passport for Mac that I connect via USB primarily for Time Machine.

I first used the drive only for Time Machine and it worked fine for a couple days. I then decided to use some of the space for external file storage and copied several GB of files to it from another drive. Time Machine continued to work fine all day. Then the next morning I had this notification:

“The backup disk is not in Mac OS Extended (Journaled) format, which is required.”

I couldn’t think of any way that could happen, but believed its story. I could not unmount the disk or eject it. I could not even reformat it using Disk Utility. Nothing I tried to get it working helped.

I removed the disc, connected it to a Windows computer and reformatted it. I plugged it back into the Mac and reformatted it to Mac OS Extended format (Journaled) GUID, set up Time Machine and away it went, working perfectly for the remainder of the day.

The next morning I woke to find the same notification again. I found somewhere online that Time Machine may not work properly if there were any other files stored on the same drive with the Time Machine folder. So this time I erased the drive, partitioned it into two 2TB partitions, then formatted them both as Mac OS Extended format (Journaled) GUID. I started Time Machine on one partition and copied other files into the second partition. Time Machine took off and worked fine for the remainder of the day…until this morning when I saw the same notification again! “Time Machine failed because the drive is not formatted as Mac OS Extended format (Journaled) GUID.”

When I look at the disk information in Disk Utility, it plainly says that the drive is formatted as Mac OS Extended format (Journaled). I found via the terminal that it is indeed set up as GUID.

Why is this happening every morning? This disk has always been formatted correctly. What could possibly make Time Machine think it is not?

Why would Time Machine work perfectly all day, taking several snapshots of my computer, then fail every morning? The last successful backup is in late afternoon or evening, then every morning it fails with that false belief that the disk is not formatted correctly.

I do not have any password protected security on the My Passport drive that might keep the drive from working when the computer is asleep. At least there is none that I’m aware of. I never have to log into the drive. The computer stays on 24/7.

I welcome any input that might help me get to the bottom of this.

Thanks.

You may reformat the WD My Passport for Mac in APFS.

Thank you for your reply. I might consider reformatting the drive in APFS except for the following:

  1. The error message that Time Machine gives me says “Mac OS Extended format (Journaled) is required.”

  2. I’ve read elsewhere that 2.5" 5400 rpm portable drives don’t work well with APFS. I don’t know if this is true.

I have the exact same problem! On June 23 I upgraded my iMac to Catalina 10.15.5, going directly from macOS Mojave. My Time Machine uses a 4TB WD My Book. Ever since I upgraded to Catalina the Time Machine intermittently fails, so each day I get the message:

"The backup disk is not in Mac Os Extended (Journaled) format, which is required."

For several days I rebooted the Mac and was able to get it to work for a while, but it eventually failed each day. I tried repairing the drive through Disk Utility, but it failed. Disk utility clearly shows it is formatted in Mac Os Extended (Journaled). I’ve uploaded the screen shot of the Disk Utility Repair message. Any ideas? Thank you.

Last night I tried something new. After trying everything else that I’ve thought to try, I considered that maybe my issue could be with Time Machine not waking the computer up at night when it wasn’t being used. I keep my Mac plugged into power 24/7 via my Thunderbolt display.

Last night I set the power settings to never turn off the hard drive and I set privacy settings not to require a password to log in (automatic login was still checked).

This morning, Time Machine was behaving normally and has not given the disk format error. It’s late afternoon now and there have been no issues yet. I have returned Privacy Settings back to requiring a password to login, but am leaving the power settings to never turn off the drive. I’ll check tomorrow morning to see if Time Machine behaved itself overnight. If it does, I’ll assume the problem has to do somehow with not waking up the drive for Time Machine. That is, until it proves to me that I was wrong in my assumption.

Thanks for the information. I will change my Energy Saver settings by unchecking the box “Put hard drive to sleep when possible”. I will also disable “Enable Power Nap” and see what happens.

I thought maybe the new WD Drive Utility Software I installed had something to do with the problem. I turned off its Sleep Timer in the WD utility in hopes that keeping the WD drive awake would keep Time Machine working through the night. Nope, it didn’t work. I installed the new WD Drive Utility after I upgraded to Catalina because WD Unlocker software does no work with Catalina. I could not unlock my emergency portable WD drive that I keep in my fire safe, so I had to download the Drive Utility to unlock it with my password. The WD Drive Utility also automatically detected the other WD drive I use for Time Machine, so that’s why I turned off the sleep timer.

I read somewhere (do not remember where) that the WD Drive Utility can cause issues with Time Machine, but I cannot find the article at this time.

I will also change my Energy Saver setting to enable the “Prevent computer from sleeping automatically when the display is off.”

Update: As I mentioned, I returned my privacy settings back to require a login after a period of time. I left the settings in place that kept the hard drive from going to sleep or turning off. This morning when I logged in, Time Machine was still working as it should and has been all day.

I’ll see if it continues tonight. If it is still working properly tomorrow morning, I will assume that the problem stems from the hard drive setting being set to allow the drive to turn off. Thus far, on the days that I have not allowed the drive to turn off, Time Machine has worked properly, with or without the privacy settings requiring a login.

Another morning has come with no problems with the WD MYPassport for Mac. The problem that I was having with Time Machine throwing disk format errors every day seems to have stopped when I changed the settings so that the disks are not turned off at night.

My MacBook Pro is a mid-2012 non-retina. I have upgraded the ram to 16gb, which was done several years ago and would have nothing to do with the recent problem. I have installed a new battery, again an update that has nothing to do with the Passport problem. But I also updated the 5400rpm hard drive to a 1TB SSD. There is no need to turn that drive off at night so with that in mind I decided to change the drive power setting just to see if it helped.

I’m not sure if the setting to turn off drives at night affects external drives on MacBook Pro with Catalina. I’ve not found any definitive info on that. But if it does and the Passport is going to sleep, then not being awakened and powered up quickly enough by USB when Time Machine comes along, that could be contributing to the issue. I don’t know if what I just described in this paragraph is actually happening. It is just a scenario that I think might be at the root of the problem with WD MYPassport and Time Machine in which Time Machine seems to wake up every morning thinking the Passport has magically changed its format overnight.

At least for now, though, I believe I’ve found a workaround for the format problem.

It’s great things are working out for you. Time Machine worked overnight for me as well. I’m going to continue to leave both my Mac hard drive and the WD drive (Time Machine) awake at all times, but will change the setting in the Mac Energy Saver back to ‘Enable Power Nap’. If it still works overnight, then tomorrow I will change the setting on my WD Drive Utility to allow the WD drive to sleep, but continue to keep the iMac hard drive awake. So I’m going to re-enable one setting each day to see what happens. Thanks for the help on this!

You’re welcome. I hope your Passport problem is gone, too. Power Nap is not available on the non-retina Mid-2012 MBP and I don’t use WD Drive Utility so I can’t comment on those. Best of luck, though.