SN850X eventlog error 50, 51

Windows 11 Pro 22H2 Build 22621.1992
SN850X 2TB 620331WD on X570S Aorus Master

pre-story / skip reading
I bought this SSD on Nov 2022 and put it in my rig together with a SN850 (system drive), and a SN550(storage drive), to load some Steam games on it. Suddenly Steam was showing up an disk error, could not write data to drive / check drive. So i tried to close Steam, but didnt worked, because Steam was also installed on this drive. Had to power cycle the PC (regular shutdown) and the SN850X went back online. This thing happend 2-3 times a day, so i requested support from my hardware dealer. After 4 weeks i got a replacement for the drive with a different serial number.

the core problem
So i plugged in the replacement drive, same procedure, now with an firmware update suggested from WD dashboard software. The drive worked fine about 3-4 weeks and after playing a longer period of time (4 hours) i could not create any savegame, then the game crashed and the drive went offline in Windows file manager. So i checked the S.M.A.R.T values and the test failed instantly. Rebooting the PC, starting another S.M.A.R.T test, everything is fine. Extended S.M.A.R.T Test, everything is fine.

what i heard so far
is that SN850X has problems with GSync and 22H2 due to a fault nvme driver. Both things would apply to me, so can someone provide a technical solution for this?

what i done so far
I reattached the drive to the m2 slot, screwed in the bracket, checked to thermal pad connection to the motherboard passive cooling system, checked the temperatures (idle 65°C, load 85°C)

Hi @Sima86,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Of course it too high temp and SSD go to throttle
Try to optimize cooling in the case or add better cooler for SSD

Ive found the culprit.

The SSD was mounted with a not suitable screw.
As a result i got a very small gap between SSD and thermal pad.
But instead of throttling down, the SSD just vanished out of the device manager.

SSD is now running fine at 50-65°C without any crash.
I also tested a 30min continuous write, reaching 78°C without crash.

Can WD please fix this “bug” and activate throttling in case of a thermal scenario?