Safepoint issue .... or not?

Perhaps the easiest way, if one doesn’t want to go through SSH, is to perform a Create and Save System Report via the WD My Cloud Dashboard > > > Create and Save System Report > Create and Save.

After the zip file is saved one can extract the file contents and view several of the log files.

so i gather that this is about the same as what i did before upgrading to 3-113 … i did a system restore from the dashboard. after that i brought back my saved settings which i had exported before doing the restore.

just did that and the zip is about 60 mb. i’ll unzip it tomorrow and have something to do over the weekend with those logs.

while on this topic … i’ve been scrolling google for some info on the log files and how to clear them and start fresh.

i stumbled on a page written by someone, where this person instructs on a way to ‘turn off’ the drive’s thumbnailer feature and indexing feature. it claims that those features slow the drive down, so turning them off improves performance.

i would be interested in turning off features of the drive that are not going to impact me much, if that will optimize it speed-wise and reduce the amount of work it does in the background … if you have any suggestions i’m open to checking them out.

perhaps via ssh i can go in and clear things out like logs and the recycle bin … which i do not see anywhere within a finder window or in file explorer, or on the dashboard.

The single bay My Cloud units do not have a “recycle bin”. Further there typically is no reason to clear out the logs as they provide a history of events that you may need to look at or review at some later date.

The two services people tend to disable to fix issues like failure to sleep and some lagging of the My Cloud after adding a lot of media content is wdmcserverd and wdphotodbmergerd. Note however that disabling these two services can affect certain aspects of the My Cloud operation including the ability to search the My Cloud using the WD My Cloud software/mobile apps and thumbnail creation on media files.

By using SSH you potentially void your My Cloud warrantee. Further incorrect or issuing the wrong command via SSH can potentially brick or renter the My Cloud unusable or cause it to perform erratically. Use SSH at your own risk!!! And above all; never, ever issue the Linux apt-get command to update the My Cloud Linux files. Doing so will cause problems with the My Cloud due to the use of non standard Linux modules and non standard page file systems used by certain My Cloud versions.

Generally one can issue the following two commands through SSH to stop those two services. However they will restart the next time the My Cloud is power cycled, restarted or rebooted.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

There are several methods to disable those two services permanently. The first is to add the two lines of code above to the /etc/rc2.d/S98user-start file. The other is to issue the following two commands.

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

One can do a forum search for ‘sleep’ and a search for how to speed up the My Cloud to find various other commands to enter via SSH to disable or reconfigure the service settings of the My Cloud. there is no one set sequence of commands to improve performance or fix the sleep issue, what works for one person’s My Cloud may not work for another due to variations in usage and My Cloud configurations.

thanks for that.

ill try to skim thru the log files to see what the drive is doing.

in your opinion, what root tweaks do you feel are best to improve performance, reduce interaction issues with the nas ?

i use it for storage, backup, documents, photos, music, video.
most of the time i interact with the nas via my WD TV where i view videos, listen to music and on a nightly basis i use chronosync (mac) to backup my thunderbird profile as well as other files/settings from my computer.

Quite simply because of the hardware used on the My Cloud backplane to enable the NAS for the internal My Cloud SATA hard drive there isn’t all that much you can do to improve the “speed” or “performance” of the My Cloud. Turning off most of the features (media server, remote access, etc.) and use it as a simple basic NAS device will cripple the unit for some/most users.

Fact is that unless you stop using (and turn off) media serving and several other services, the moment one copies a LOT of media files to the My Cloud the unit will get very slow/sluggish while it scans and catalogs the files being copied to the My Cloud hard drive. Turning off media serving before copying then re-enabling it post copy doesn’t really help since once enabled it will rescan the entire hard drive for media once again slowing down the My Cloud.

There are several tweaks one can perform, but again they may impact certain features of the My Cloud. They include issuing the following commands to try and deal with among other things the failure to sleep for longer than 7 to 10 minutes and occasional My Cloud sluggishness. Still doesn’t sleep much (about 30% of the time) but better than not using the commands. Do a forum search for “sleep” or “slow” and you’ll find lots of threads with lots of suggestions.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /

Just a few other threads to get one started:
https://community.wd.com/t/performance-benchmark-results/151741

https://community.wd.com/t/mycloud-does-not-go-to-sleep-standby-perhaps-the-solution/158591

https://community.wd.com/t/my-cloud-never-sleeps/150904

https://community.wd.com/t/optimizing-os3-and-getting-some-sleep/96829

https://community.wd.com/t/my-cloud-slept-for-3-days-5-hours-after-killing-openvpn/96605

https://community.wd.com/t/before-you-pack-up-your-wd-and-return-it-lets-talk-about-copying-speeds/91887

thank you for the info again Bennor … perhaps it’s best to just leave it alone. as i progress towards more storage needs maybe i’ll look at enclosures/other brands to sort out which have what I want.

i got a message back from WD asking to send them the log files but @ 60 mb worth, they should tell me at least which files are important to them.

i figured i might as well just bite the bullet - if you will - and just redo the safepoint. first i made sure to do a system restore because i tried a new safepoint creation last week and it failed.

it’s been going on now for 48+ hrs (right now it is at 98%)… i am being cautious not to use the nas for anything while it does it’s thing. kept the dashboard up in a window so i can keep track of progress. i am wondering if the nas is relaying the copy operation around the network then to the my book … because with a direct usb 3.0 connection i don’t think it should take a ‘decade’ to copy about 2.6TB, even if there are thousands of small files.

late last night at about 98% copy the progress bar disappeared in thr dashboard and some message saying the safepoint was invalid or an error copying had occured (not a notification). it was saying i could hit update to try again. did that.

this morning i wake to a yellow notification bell in the dashboard … it is giving me error 1100 again.

now im pretty ticked off at this point, i invested 3 whole days in trying to reconstitute the safepoint and i cannot even mount the my book share from finder, getting an error connecting to it. but the my cloud is mounted fine in finder.

in general the past several months have been a struggle for me with wd products, the biggest headache ive had to deal with is my wd tv constantly telling me that the media source (my cloud) has been disconnected and i have to pick another media source and this happens over and over again.

my router is always on and my cloud and wd tv are both ethernet tethered to the router and everything is plugged into a ups which has not gone offline in the past year.

i really am disappointed now and im contemplating ditching this setup for synology or building my own home cloud with non-wd products.

should not have to deal with this mess.

That’s what I thought, but it turns out that, although it supports data transfer at USB 3.0 rates, it cannot sustain that transfer rate. I measured about 3MB/s, IIRC. So I don’t bother connecting a USB drive to the MyCloud, or using Safepoint. I do my backups with a drive connected to my PC, running FreeFileSync. Once the initial backup is done, deltas don’t take long. I do them as part of my PC shutdown process; I run the FFS backup script when I’ve finished working, and, when it’s finished backup, it shuts the PC down.

It’s a shame, because automatic backup by Safepoint would be the easiest and most sensible way of working (barring the fact that the backup HDD is in the same physical location as the primary, so is vulnerable to common fire/flood/theft loss), but I’ve read too many problem reports of Safepoint to rely on it. A backup tool has to be trusted; if you don’t trust it, don’t use it.

i’m going to look into another robust backup tool. I currently have Chronosync for mac which has been pretty reliable and the options/settings i can configure give a lot of flexibility. but that is PC-based, so doing this across a wifi network would be painful and slow, because i have several small files that go with backing up an itunes configuration or other stuff that is stored on the nas. it’s not the large 5-6GB files that cause a bottle neck, it’s the small files and several hundred directories that are maintained by the programs i use (itunes, thunderbird, etc.). when i found out how messy the firefox profile gets, i completely abandoned backing up my firefox profile because that would be insanity.

i got a .info file just a few mins ago that’s stored on the my book within the backup location … can someone interpret this for me and tell me if i have an error or if the safepoint was created sucessfully (finally) ?

the file timestamp was 7:31 am this morning, after I had to deal with the errors and re-update to keep the safepoint going.

maybe the safepoint was created correctly or not, i cannot tell for sure because i’ve gotten dashboard notices that safepoints were created sucessfully when nothing really happened (‘fake’ notification).

action = update
action_lock = 0
action_source_id =
action_state = OK
dataset_name =
dataset_size_processed = 0
dataset_state = OK
dataset_total_size = 0
dataset_ts_end = 1464780703
dataset_ts_start = 1464780702
dataset_type = backup
description = backup_nas1
handle = 237720987493451774647706867518666666350
n_files = 314327
name = backup_nas1
priority = normal
size_processed = 2517862711735
source_class = 4.1
source_device_name = WDMyCloud
source_id = WD-WCC4E1UKRJPH
source_ip_addr = 192.168.1.160
source_product = Apollo
state = OK
total_size = 2517862711735
ts_end = 1464780704
ts_start = 1464775341
version = 01.06.00

I think that I am going to disable safepoint all together and instead try to use Chronosync to mirror the NAS --> My Book. so long as my drive paths are constant and do not change, then I will just manage my nightly’s from Chronosync with a schedule.

Would I be better off plugging the My Book into my router’s USB connection instead of rely on the NAS USB connection ?

It’s not practical for me to connect the My Book to a PC because I only use laptops, so I keep the drives near the router in one place and connect to them via wifi mostly from PC/Tablet/Phone.

You might… Depends on the speed of the router USB port.

Interestingly, my Technicolor router provides a file server and media server function for USB drives connected to it; pretty much what the MyCloud does (except the remote access). But I got the MyCloud before this router…

The main downside to using software like Chronosync is the need to rely on a computer to host the software. Remove that computer from the network and the backup/sync no longer gets performed.

One of the good things about Safepoint is it doesn’t rely on any other computer when the USB drive is connected to the My Cloud’s USB port.

If one uses a router that is capable of file sharing (Samba for example) through a USB port on the Router then one could configure Safepoint to backup to the USB hard drive attached to the router.

it’s a USB 3.0, but like you said, it’s not sustained speed. what’s important to me is that I can get a decent transfer speed in the pipeline. waiting 50+ hours to complete 2.6TB transfer is a bit much I think.

i am wondering if the file system of the My Book has any role in this safepoint business ?

for example, the NAS is EXT4, files and folders with permissions/etc. if the My Book FS does not support a verbatim file copy from EXT4, perhaps this is one of the problems ?

Since I access the My Book via a share furnished by the NAS, I don’t think that my Windows or OS 10 care about what FS the NAS and My Book are.

I understand.

to me what’s more important is to have a reliable backup process rather than one that hiccups frequently or doesn’t backup at all (but says that it does).

it’s all being driven by data on my computer anyway - so whenever i need to update the NAS with PC data I do that from the PC with Chronosync. the remainder of the data on the NAS is stationary and doesn’t change. only a very small percentage of the NAS capacity is changed on a daily basis and that is all I need to be backed up on the My Book.

When I am away from home with my PC there is no need to backup the NAS because I do not add or change files on it.

When my pc is home and sleeping, I can configure Chronosync to wake OS 10 and perform the mirror.

I am going to give safepoint 1 more try and watch it carefully over the next few days to make sure it’s backing up properly on the My Book.

A suggestion or two:
Make sure no files on the My Cloud are in use by computers on the local network when the Safepoint is active
Make sure WD Sync or Smartware (or some other backup/sync program) isn’t writing files to the My Cloud while the Safepoint is in progress.
Avoid using the My Cloud at all while the Safepoint is in progress, this includes avoid streaming and remote access to the My Cloud.

the reason for my frustration is because i went out of the way to make sure the drive was not in use with any other ops/devices and i did not even access it from my pc.

spending time too often to fix issues rather than enjoy the content i have on the nas is not something i look forward to

update:

despite the warning notification i got yesterday it appears that the safepoint was created on the My Book and I am going to take some time to test random files in the backup in order to make sure they were copied fully …

in the My Cloud, i set auto-update to on for an overnight backup, but i am perplexed by what actually happened. The time stamps of some directories which I changed on the NAS are as of this morning (on the My Book), however the contents within them are old, time stamps for the files have not changed and new files which i created on the NAS yesterday are not present on the My Book as of today.

there is also a .info file that is dumped in the WDSAFE folder on the My Book, this file is from yesterday when the safepoint was created … I do not see one or any log file for the auto-update.

did not see any notifications in the dashboard either.

I need to find the specific log file on the NAS that lists the activity associated with safepoint updates, which file is that and where can I find it ?

File/Folder on NAS:

SAME File/Folder in My Book:

day 2 now … auto update did not update anything and time stamps of files and folders in the backup are as of yesterday morning.

i did update files on the my cloud last night.

it looks like im just going to grin and bear it for now until ive got my stuff lined up to transition to a synology diskstation. its just a shame i spent this money on wd my clouds and a my book to have the setup i thought was possible but obviously not.

i need robust, reliable and automatic backup of my files. not getting that with wd so far …