Remove ATA password outside DX4000

I have a set of 4 WD RED 4Tb hard drives which were locked from dashboard with the ATA password (which is known). For some reasons I got a DX09x error at boot and so I wanted to restart a full recovery from scratch. However I have issues as all the drives are locked with the ATA password. I tried installing it on a modern HP Elite workstation but for some reason the password is not recognized as correct (maybe keyboard issue with language at BIOS?). On older PCs the BIOS just does not allow me to get rid of the ATA password. Is there any utility which from Windows or DOS can manage the ATA password so that I can safely disable it? Any other hint?

thanks

No idea, but what is that unlock drives thing in the recovery steps
I thought it was to do what you want?

The ATA password was set when the hard drives DX4000 was functioning properly from dashboard. Then I suddenly got a “startup failed 0xD9” error following a boot which means everything is gone. I was not worried as I did not have any data, I was just through an install process. However the password was already set and now it looks almost impossible to get rid of it. I tried with the USB password recovery without success (0XD9 error again) , also getting rid on the password on other workstations did not work. I fear the DX4000 is adding something else to your own password. Main issue is that now I have 4 unusable 4Tb red drives.

Is this the usb recovery you are talking about ? Have you trried slaving a drive and diskpart >clean ?

If the above is what you tried, perhaps you need to adjust the whitelist.xml
someone just posted wildcard entries to make this easier
if that still fails try a different thumb
I am pondering if it is not booting from the thumb putting you back at 0x9

Correct, it didn’t work - After “recovery started” I obtained the same 0xD9 error I get after the standard boot without USB. Diskpart does not work as without the ATA password the workstation BIOS does not map the drive. Actually the drive can be seen from other utilities which probably work at lower level like HDAT2 (DOS). However also from this “low level” DOS utility I can’t manage to unlock the drive with the password I use. For the time being my only guess is that DX4000 adds something to the ATA password you use on the DX4000.

Like I said, perhaps the white list? I guess you Google’d and saw some linux ideas

Did the LCD say any of this or just go to 0x9

https://www.manualslib.com/manual/700029/Western-Digital-Sentinel-Dx4000.html?page=57#manual

I correctly get INITIALIZING OK. LOADING RECOVERY and then 0X9 - I fear this utility works only in case the disk set is still somehow operational which was not the case.

My power supply died so I do not have mine to look at. But I would guess if the box was running you would not need this function of the recovery iso to remove it? You could do it from the dashboard?

I am just throwing out stuff as I have not treaded in your waters. Sad

Let us know if you make any progress

Believe it or not I managed to recover the situation after having set the ATA password from dashboard with another working set of DX4000 drives. Then I re-installed the 4 WD drives which gave the 0X9 error and for some unkown reason everything was recognized and now it is again up and running. Set-up of ATA password from the DX4000 has to be done with lot of care: if your unit fails and you do not have another DX where you can set the same password very likely you will loose all your data as I am pretty sure the password is in some way encoded by the DX BIOS and the disk cannot be unlocked on other systems even if you know the password.

You put good drives in the non working box and set the password, then put the 4 “bad” drives back in and it booted or booted with 0x9 and you could recover?

Correct - it booted without issues like before showing the 0X9 error, really strange but it worked. Looks like for some reason the ATA password in the DX BIOS was lost (or I inadvertently modified it). Really strange

it must have lost the password if it booted the drives without one?

maybe, really difficult to say as I was not tracking each operation I did