Redirect to oracle page-have current java

I  am being sent to the Oracle Java page.  I am always current with java and all its components in both IE11 and firefox.

I have only current latest Java installed in my system and in the browsers yet can not get at my 4 shares via wd2go or cloud.

I enter my network password and briefly see the 4shares and an IP administrator page then right to oracle.

I searched site to find another issue back in january 14 but couldnt reply to it, therefore, I would like some clue as to how to fix this so i can access my wd duo personal cloud 4tb.  I have never had any issues for local access and do not use the remote web often, if ever. i did when i first set it up,but just get to oracle now and no way out ,it seems.

I just did the full oracle java update and removed old outdated stuff at that time as well. i tried a reinstall and it wouldnt do it , said i have most current.  i did not uninstall it all to reinstall it all over .do not want to do that unless totally necessary.

Hello, have you tried opening using Google Chrome? Another option is to use the WD Desktop app. 

Installing and using the WD My Cloud Desktop App

1 Like

NO, I did not try to use chrome, simply because on this computer I do not have it installed. my other room’s computer does and my 4 linux mint 17 boxes have chromium but not invested any  more time, yet to this problem

I use pepperflash in 3 of the linux builds. no idea, never , yet, tried to access using the laptop or other desktop.   I was trying to set up another streaming server set up on one of the networks i have here.  I was having troubles with the tv getting to stuff in the mybooklive shares. am trying serviio, cyberlink’s server for media, and KooRaRoo which is fairly good and fast, I got rid of my nero home essential dlna due to problems of its own.

but, thanks, i will try the other computer and chrome, it is there and up to date.

I will also look into the desktop apps though i do not think they do what i am looking for the wd2go to do. I have all the WD smartware installed and do use the desktop apps, netview and WD Link routinely, but for the usb connected 3tb extra storage i have in the mybooklive home personal cloud 4tb media. i do not use any back up or safepoints, can not spare the space they take up.

will try your suggestions, and appreciate the time /response


I did not originally realize that the ‘cloud desktop app’ was a separate thing. I had not installed it, just did.

Howver, i do not have any trouble accessing my Mybooklive duo settings, shares directly from any of my computers, Linux either. It has always been great and readily available repository for my videos, movies, whatever even the usb connected extra 2tb works well  , slowly, but not a snail and availble throughout the local networks.

My issue has just been recent with the Oracle Java redirect when trying to go through wd2go on line. I have ,as stated, all current and updated OS, drivers and that includes flash, oracle java. just did it on each appropriate went through the whole process and even cleared up any outdated installs. no idea why, still , i can not get past the oracle page, did not go through any of the hypertext links there, yet. wanted to check out here for others with similar issues, first to make sure it was not a bad redirect or hijack. at least that was cleared up.

thanks again,


redirect to java, still. I even tried to use the site to ‘update’ my java, and it will not. error message indicates i have the same or newer version and that it that.

I have linux Mint 17 and I really get blocked there. Still can get to the IP-Administrator Local log it. and blocked because the certificate isnt up to date or not to that date yet.

I tried everything from modifying my certificates in firefox but no matter what i tried i got the series of errors citing my security as blocking the java app.  I believe i use a java substitute or something like that in Mint. pepperjava is one thing but not sure what is going on with the firefox. i went to the firewall -ufw- to make rules to allow the access to my own device. but the problem is more than just that…in linux (x64) MATE.

I had issues with the chromium browser as well and got frustrated so left linux to try again with windows. I stopped before i began to create more troubles than i began with or opened up the computer/lan to the whole internet. not really expienced with making too many cross internet rules and changes within the router and firewall.  I have a dd-wrt interface in the router but not sure if that will resolve the trouble anyway. 

that is where i got to… and still can not get at my own device that is across the room via internet. if i cant get to it from here, how i can get into it from a motel, hotel, road is a problem.

By the way, the Cloud App works very well. but I can not keep firefox away from that redirect to Oracle.  shouldnt but does. I get different issues in Mint17 but bottom line is still a problem.

johnniedoo wrote:


I have linux Mint 17

Well THAT’S your problem.   WD 2go isn’t supported under any linux OS.

I realize i wrote a couple of volumes,but i only tried linux as a last resort.

by the way,linux can access my Mybooklive duo personal cloud no trouble on the local network. connects itself and opens up dashboard and  all my shares…its  just that nothing can get past the local sign in for wd2go,get sent to oracle. no matter what  i do , so far anyway.

that is my trouble. all else about my WD duo is great. linux and windows. just wd2go from the internet, ftp or samba can can access it from my desktop with the my cloud app,but i havent tried that from outside of my local wired network so that test isnt really much help

thanks for replying anyway


I have tried every suggestion, reinstalled java on each of my machines in question, even used the redirected page java to try to install.

I have used chrome with a newly installed java, and still get redirected to that Oracle page

I , in other words, am unable to utilize wd2go. i get stuck with that stupid oracle java redirect page and can go no farther.

I have no issues getting into the device other ways, just not through wd2go. and that is a good feature.

I have been to the mybook desktop and activated ftp and internet, enabled everything.  I will not increase the verbiage here by enumerating every single step, but i tried everything suggested here and in any post that came up in any search, here and google

any suggestion would be appreciated



Update the firmware in the MyBook Live Duo. Latest firmware fixes this issue,

1 Like

<Myron wrote:

Update the firmware in the MyBook Live Duo. Latest firmware fixes this issue,>


Thank You

I do follow the updates as they come up, but, I have pretty much forgotten about the wd2go access from computer. there were other ways to get into the shares. so i did not have any trouble accessing my sfuff, just not via the wd2go. that was a problem that did not go away.

I appreciate that you took the time to post this though.  I had given up a bunch of months ago and figured it was a lost cause


will mark as solution as soon as i try this update out, need to check if i have already updated–i usually get a pop up as they come out and do them immediately but did not check the wd2go issue nor read the update log either.blind up dated it


Yep. I did notice the fault quite a while ago and nudged WD about the issue. Seems it took a while to sort out. Wd2go access did work until a particuler Java VM update, which broke the access to the MBLD. I guess it took so long because WD wanted to make sure it was done right.