Goes to Oracle JDK page directly and automatically when trying to sign into Network Drive Password

I cannot log into wd2g and access my drives.  It accepts the passwords, and then briefly shows the word “shares,” but then the website redirects to the Oracle JDK page (without any error message or otherwise telling me what is going on.

I found an older thread that listed this exact same error a couple of years ago.  It suggested doublechecking the java version.

I’ve verified I have the most recent java edition and that no old versions are installed.

Help!  I cannot access my drive with this bug.



Have you tried using another Internet Browser?

Or use the newer My cloud app. 

I’ve had the same problem for months.  I called tech support and was told (1) MS .net framework must be updated to 4.5.1 or higher, and (2) most current version of Java.  As I knew, I had most current versions of both installed on my win 7 machine.  Still same issue.

Using WD My Cloud desktop app is not a solution.  It won’t mount the share as a drive, as wd2go will (or used to).

Switiching browsers is a ham-fisted workaround.  IE is obviously used by most so should be functional.

There is another KB article that suggests lowering Java security to medium, which I did and which makes no difference.

“Using WD My Cloud desktop app is not a solution.  It won’t mount the share as a drive, as wd2go will (or used to).”

This can be done very easily using just the standard Windows procedure, of course, only if you are willing to.

Of course I’m willing to!  So what is the produre?  Thanks in advance.


Too many out there, a simple search will provide you hundreds of options, some in youtube as well.

Here is one:


I appreciate the assistance, but maybe my issue wasn’t clear.  I’m not technical, just a consumer user. My MyBookLive isn’t on this network (it is sitting at home on my home network, I’m now at work on my work network).  wd2go pulled it in.  But mycloud doesn’t (it just opens a window that I can drag/drop to).

I have the same problem.  On my laptop or tablet, when I login to my device on wd2go.com, it automatically redirects to


This renders the cloud function usless as I cannot access my drive.


What JAVA version you have installed on your computer.

Make sure that you have the latest JAVA version installed on your computer as this might help.

Same issue here (see my post above).  I am running most current version of Java (7 update 67), and most current version of .NET framework. (4.5.1) and doesn’t change a thing.  No Java problems on any other websites, and I confirmed it is installed and running correctly.  I also ran down the Java help page on confirming running correctly.  It appears WD’s best solution is knowledge base article 11387, which basically says (for Windows users) update and set Java security to “medium”.  Did this and no change: continues to redirect to Java.com.  Article 11387 acknowledges this is a known problem, so I would appreciate WD getting on a real solution.  WD Desktop app is certainly nice for accessing my files when I’m on a different network, but is useless to mount my MyBookLive as a drive remotely.

use the newer “my cloud app”. It has no Java dependencies. wd2go is the old software.

  • Personal cloud access with the My Cloud app requires a My Cloud, My Book Live, My Book Live Duo or My Net N900 Central with the most recent firmware.

On the PC running windows 7, Java version 7 67.  The problem occurs using IE and firefox on the PC. The same problem occurs when using a Sony Android table and a Sony Xperia Z android phone.

It indicate to me a problem with the wd2go app.