Raspbian - setup

Hello all,

on Windows machines i can reach my WD mycloud drive on the netwerk, but i don’t have a clue how to mount this drive into my  raspbian.

can anyone help me at who it did work ? 

PS , i’m not a specialist in linux :x 

I tried to use //wdmycloud/ in a mount command i found at  this forum, but didn’t not work. The reason i didn’t use ip adress is because i use a dhcp which changes ip all the time…

thx advanced ,

Change to root: sudo su;

Create the mount directory: mkdir -p /mnt/wdmycloud;

Add in /etc/fstab: //wdmycloud/Public /mnt/wdmycloud cifs noauto,username=user,password=pass 0 0

Mount it: mount -a;

To auto mount at boot, remove the “noauto,” option in the /etc/fstab.

To hide the user/pass in /etc/fstab:-

Create the secret file: echo -e “username=user\npassword=pass” > /root/.wdmycloud;

Change the /etc/fstab to: //wdmycloud/Public /mnt/wdmycloud cifs noauto,credentials=/root/.wdmycloud 0 0

Hope it helps…

1 Like

thx for your response,

i did like you mentioned,

created dir as sudo,

added that line with my user account 

and as last mount -a 

here by i didn’t get any error.

when i changed to the new created dir i named it my cloud = /mnt/mycloud 

i don’t see any files in that folder while on mycloud should be three maps ? 

Did i do something wrong ?


Type: mount … do you see wdmycloud in the list?

You can try do a manual mount (unmount the previous 1st, umount /mnt/wdmycloud):

mount -t cifs -ousername=user,password=password //wdmycloud/Public /mnt/wdmycloud

Try to mount some other PC’s share see if you can see the contents.

i got this 

root@stevenraspberry:/mnt# mount
/dev/root on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=216132k,nr_inodes=54033,mode=755)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=44880k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=89740k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
/dev/mmcblk0p5 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=ascii,shortname=mixed,errors=remount-ro)

I also tried  manual mount with this

root@stevenraspberry:/mnt# mount -t cifs -o username=somename,password=somepassword //wdmycloud/Public /mnt/mycloud/
mount error: could not resolve address for wdmycloud: Unknown error

i don’t know know :frowning:

thx in advance

Both device in the same subnet? Can you ping the hostname and ip of wdmycloud from raspbian vice versa?

If only can ping ip, I would suggest using ip instead. Don’t worry the ip won’t change that often unless u clear dhcp in the router or set to very low leased timings. My router still assigning same ip to all my devices even after moving places a few times.

If neither works, you need to troubleshoot raspbian as you mentioned earlier windows machines can reach mycloud.

all of my devices are even on the same subnet, i only use one modem/router and further there are switches.

pi@stevenraspberry ~ $ ping wdmycloud
ping: unknown host wdmycloud
pi@stevenraspberry ~ $ ping //wdmycloud
ping: unknown host //wdmycloud
pi@stevenraspberry ~ $ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=1.36 ms
— ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 0.592/0.872/1.366/0.350 ms
pi@stevenraspberry ~ $

pi@stevenraspberry ~ $ sudo mount -t cifs -o username=myuser,password=mypass // /mnt/mycloud/
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


However i dit this 

sudo /etc/init.d/rpcbind start

sudo mount -t nfs /mnt/mycloud/

umount /mnt/mycloud

then i can find my folders from mycloud in /mnt/mycloud (public files)

i don’t immediately figure out how to personal login … But its a start.

Smbclient not installed on your device? Install samba. But I would rather use nfs between linux.

i installed samba and winbind with
Follow these Steps

  1. Install Samba
    $sudo apt-get install samba

  2. Install Winbind
    $sudo apt-get install winbind

  3. In /etc/samba/smb.conf, Edit the workgroup variable to match your home network workgroup (as defined in windows):
    workgroup = WORKGROUP

  4. sudo nano /etc/nsswitch.conf
    i’ve changed the line
    hosts: files dns
    hosts: files dns mdns wins

now i can ping wdmycloud 

and mount with

sudo mount -t nfs wdmycloud:/nfs/Public /mnt/mycloud/

Huh? You installed samba but still mount as nfs? But great you sorted it out.

i took nfs, because i thought network file system is good for everything … used as a network :) 

luckily, i took me days  to discover, searched whole www , but here and there brought me the solution … 

thx for your help !