PS3 Not recognising twonky server (MBL)

Hi everyone! I have just bought a new MBL 2TB and I have been transfering files all day.

I have tried getting the twonky server running so that I can stream files on my PS3 but I have had no luck so far.

What I have done:

I have enabled the twonky servers in the settings and I have set the media serving on “All” under all my shares.
I have also checked and the twonky server recognises that i have videos, pictures and music on the server. (i went to serverip:9000/webbrowse and saw my files there)

I have tried everything but still i cant get the server to appear under videos, pictures or music in the PS3. I even tried manually searching for multimedia servers without any luck.

The MyBook Live is conected vie ethernet to the router, and the PS3 is connected wirelessly to the router.

Is there any way to fix this without restoring/formatting the HD??

Thanks in advance,


I have done a full factory restore and it continues to work with all my devices but my two PS3 consoles!

Any help appreciated!


Try creating a new “share” and see if it sudenly works…thats what fixed it for me

Did you ever get this solved?

I have the exact same setup and the exact same problem.