Problems after FW upgrade: WDMYCLOUD

Add me to the list!

I get 12-14Mb/s Internal USB transfer, 3Mb/s 1Gbit Ethernet transfer speeds. I disabled all scanning services.

Something went horribly wrong with their latest update. Is there a way to rollback?

@ lloydcruz 

I have tested my server with a camera, which has a 32GB SDHC card, an 8GB flash disk and an external 250GB hard disk each connected to the USB port. All work perfectly but I notice that if you remove a device without first ejecting it from the UI it leaves the mount point in place and it also occupies its device, usually /dev/sdb. If you subsequently plug in another USB storage medium it will be given thenext available ID, e.g. /dev/sdc, /dev/sdd etc. A reboot takes care of it all.

@lloydcruz & Gemini

I don’t understand why we are all getting different symptoms. I have no issues at all with the timestamps. My time zone is GMT +1 and I am using the default NTP servers at and If you set yours like this, does it display our CEST time (GMT +1) correctly? Maybe someone could try this (a reboot may be required to ensure the time server is contacted).

so there is no solution so far? we are basically screwed?

Yep, we’re screwed if no-one can be bothered to try things to help themselves/others/WD Support.

I’m adopting the “I’m all right Jack” approach since I have less problems (apparently) than everyone else and WD support are being very helpful. I’m not a MAC or Windows user, either.


Time is set up properly on My Cloud the time differential only shows up in Notifications. Times of events on UI are correct.

Customer Support has been on my machine by remote access so they’ve seen the setup and they confirm it is a known issue.

Have done numerous reboots and restores. Initially notification and UI times are in sync. Then when I change the My Cloud to Eastern Time (GMT-5:00) the difference immediately shows up in Notifications.

I’ve just heard back from WD having opened my third support case. I asked them to restore old firmware.

“Please accept our apologies for the inconvenience you are experiencing. A Firmware rollback is not possible, since the device doesn’t allow it.” They are suggesting a paperclip reset and if necessary system restore. Been there, done that but will go through the exercise again. Will see where we go from here.

Unfortunately I’m of the opinion that that as long as the 4.00.00-607 firmware is on the machine the issues will remain.


Thanks for the reply. The plot thickens. I just set my time zone to GMT -5 and rebooted. I got a notification of the reboot with a time showing 6 hours behind my time, which is correct as I am GMT+1. I don’t understand how identical programs, or firmware as WD likes to call it, can produce different results. I’m a retired Unix systems support guy and it’s got me… I’d certainly try different NTP servers. I’d also try issuing the date command on the command line on the box via ssh. I’ve tried it on my machine - when I change the time zone in the UI the time updates within 1 or 2 seconds and the change is also reflected if I then use the date command. It does suggest (to me) some sort of corruption somewhere on your machine but I can’t see it being likely that several people would have the exact same corruption…

I’m inclined to agree with your final statement in your case, and also in the cases of those who have the same symptom.

Definetly not a problem on my computer. Anywhere else on the Dashboard UI times display correctly.

On a whim I tried out My Cloud’s email Notification. When My Cloud generated a Notification the email copy indicated the correct time while the copy on UI Dashboard was still 3 hours ahead.

Surely WD have a plan to be able to rollback the firmware if the new firmware breaks everything.

It’s been 3 weeks now, and I can’t stream music. I get 177KB/Second speeds copying. It takes 10 to 15 minutes to login to the cloud.

It constantly shows 0% in QuickView.

I can’t access the cloud remotely.

I’m trying to backup the data that’s stored on it, but it’s going to take days.

What is Western Digital’s solution to fix this problem?


Can you log in remotely via SSH? Will the system mount a USB drive? If it’s a network issue your box has it may be quicker to copy your data to a disk attached to the My Cloud’s USB port. If you can access the server vis SSH you can run some checks yourself, if you are familiar with Linux. (If not, I advise extreme caution)

Trying to copy to the USB drive connected to it. 136 KB/second.

Everything was working fine until the firmware upgrade was complete. Now it’s useless.

I can’t do anything that I bought it for. 3 weeks since the firmware was released, seems everyone is having issues, and no fix.

I’m just wasting hours of time on this. I’ve tried everything to fix it.

I might take it back to the store and see if I can swap it with one with an older firmware installed.

I’ve had it since about 8 months now, but surely if it doesn’t work, they would have to swap it, or refund me.

I can’t even backup whats on it, it’s so slow, and keeps stopping.

What does WD say? I realise they can’t log in if you have no cloud access, but what have they suggested? Have they requested the logs? Also. have you tried to diagnose it yourself, i.e. check what it’s doing, how much memory it’s currently using, check the logs, etc.? Is it continually scanning, btw? I have found it to be slow while it’s scanning, so I’ve disabled it and I enable it only after I’ve made changes to my media. Also, have you excluded all your data from the media scan? If not, it will spend ages scanning your data when you simply add a file.

For 2.3 TB of data it took 6 days and 7 hours for the scanning. Now i will disable everything, including remote access and will see if it functions well as simple NAS.

They requested the logs. But it took about 2 days to produce them. They told me the firmware needs reinstalling. So I did that, and no change.

I just can’t spend anymore time on this.

I was copying 1.5 Tb of data to the USB3 drive directly connected to WD My Cloud 4TB (latest firmware).

It took almost 100 hours to complete everything. Drive was disconnecting and the speed was 3Mb/s - 12Mb/s. Even when I disabled all the scanning and indexing.

Now I just want my money back.  I scheduled a tech appointment but the line cut off and I never received the call again!

What is it? This is becoming a nightmare! What supposed to help organize my digital life is now sucking my time and energy. 

How do I return it ASAP? 

I had the same problem.  I called tech support, they had me do a “system only” restore (doesn’t impact data, but wipes out your users).    

I still can’t transfer data to mycloud, but interestingly I can transfer data off the cloud.  So I backed up everything to another external harddrive.   Since the issue wasn’t fixed they are sending a new piece of hardware.  I’m pretty sure they know they have a problem with the new firmware release and something is not compatible with the “older” hardware out there.

My system worked great until this point.   So hopefully the new hardware will work.

good luck

Hello All. Ok  heres the deal I bought my cloud about 5 months ago maybe less. I take it out of the box set it up let it do all of the updates. Then I start backing up all my data to the drive approximately 250 gb mostly small files so my transfer speeds weren’t that great some times 16mbs/ all the way down to 1 kbs it never ran consisteantly constantly kept falling of the net work iphone app would connect sometimes and some times not. I was beyond frustrated so I decided to transfer all my files that took almost 2 weeks to transfer to the drive back off so I could smash the cloud with a hammer… Not really.

I decided I was going to do a full restore on the drive (i had tried the simple system restore to-no-avail) Well it took me another two weeks to recover my data then I did the Full Restore it took about 12 hours or more to do. I got everything set up users shares ect I started to transfer my files back (movies) I have 85gb it took one hour! I set up my phone apps they work flawless thumnail generation fast the difference in the operation of this drive is night and day. I had almost all the same problems everybody else had tried almost everything that was sugested nothing worked. This drive works better than it did out of the box my firmware is v04.00.00-607. 

So my thinkng is this: The linux operating system combined with the automatic firmware up grade out of the box set some kind of confict with  linux and the firmware. So if you buy a new my cloud set it up do the firmware upgrades then before you transfer any files to the drive do a Full restore so that the operating linux system can do what ever it needs to do to incorporate the new firmware. I just think theres a confilct.

Hope this helps other frustrated wd my cloud users. If this solves your problem click on solved. 

hi guys,

i just got my wd mycloud fixed by WD. looks like everything is working fine for now. people from WD advised me to just let the device sit for sometime and let it finish indexing my files. if you really have an issue with your mycloud, create a support case and WD will take care of you. i saw how they fixed it. if you don’t care about your warranty i can show you how. ill just finish reading the guidelines so i know if i’m gonna violate anything for sharing something.


I’m pleased that you have finally got somewhere with your device.

Thanks for your advice to raise a support case. Unfortunately, that’s exactly what I’m about to do! Mine has been working fine up till now (on the latest firmware) but I have been try to back up large amounts of data using the USB port, thinking it would be quicker than the network. Across the network (Gigabit) I get 6.7 MB/s, copying about 7,500 files totalling 10GB in about 14min 30 seconds. Connected via the USB 3.0 port on the MyCloud I almost get USB 1.1 performance, taking 22 minutes at a rate of 7.9MB.s to copy the same data. Slower than the network! My PC copies the same data at 52.8MB/s in 3 minutes 9 seconds from the same external USB disk that was used on the MyCloud.

Sometimes now, while copying, it will simply stop, continuing after a minute or two later without reporting any errors. Also it slows to a crawl, amd then fails to copy every file stating “Permission denied,” asking me to cancel, retry or skip. Retrying eventually returns to offer me the same options and results in a directory full of files which are all 0 bytes in size. Not an ideal backup solution.

For what it’s worth I waited until scanning had completed, turned off DNLA and turned off the scanning in the Twonky web interface. Sadly, the WD software overrides this and it scans immediately it is written to - even just one non-media file written to an area which is not included in the scan! Crazy.

Logging in to the UI is now slow. It takes about about a minute for the login page to show and another 30 seconds to process my uid and password. :confounded:

There are no related errors in the dmesg log or in /var/log/messages. This all happened when I was copying and it looks like the database crashed, and I got this:

I left it overnight to rebuild but it hasn’t been the same since.