Problems after FW upgrade: WDMYCLOUD

I can try a factory reset. But I’m having trouble backing up what’s on the cloud. It keeps losing connection, says it can’t find the file. Even though I can open it.


what they did with mine is pretty simple. it was really simple even i can do it. they requested me to download my devices previous FW and asked me to insttall winscp. they remotely controlled my pc and did a FW rollback. the rollback was really simple. i just don’t want to post it right here as the procedure might not work on everyones mycloud. so i suggest you follow their instructions and have a little patience.

I was reluctant to change firmware on my in case I voided warranty. So I contacted WD Customer Support and asked either they change my FW or RMA me a unit. Was told not that it was NOT possible to roll back the FW so I’m waiting for my new My Cloud. Have since been told by WD that Customer Support agent was wrong. 


Thanks for the info.

I updated my support case yesterday but no-one at WD has acknowledged it. Things here have gone from bad to useless. It looks like it will take about 24 hours to copy 90GB of data from a USB 3.0 disk connected directly to the MyCloud. It was producing network errors, file errors and all sorts of rubbish on the UI. During the copy it has said that some files were unavailable and I’ve had to skip them (retrying failed).  At times it has disappeared from the network; it has failed to maintain its own clock; it has produced errors when I tried to check the firmware status; it has said there was 0KB free space on the disk when a df command showed it was only about 10% full; finally, and mainly, it is incredibly slow to copy and spends most of its time asleep (meaning I can’t access it, which is how it is now).

I’m pretty sure the database is corrupt (the content scan just has a dash) and it would appear that the OS is too. I’m reluctant to power it off as it is obvious from the disk clattering away that it is as busy as **bleep** doing something.

I also tried to request support from the UI’s Support link, where I tried to attach a diagnostic report but I think it failed. I got returned to the login page, and as I never received a confirmation email I guess that it couldn’t even do that… Attempts to log in over SSH fail too, with Putty reporting timeout errors.

So my MyCloud is as good as useless. Should I post all my screenprints of the errors to try and shame WD into action?


I got an email from WD Support requesting diag reports almost immediately after making my last post. However it’s busy at the moment (disk clattering) and doesn’t respond to much on the UI. I advised WD I would send a report as soon as it decides it has time to provide one. At the moment, when I request one it just dims the screen for a while and then asks me to log in again…

After persisting with the WD firmware and being under the delusion that WD would fix it, I have finally given up and I now run it with a basic level of Debian, with no WD software running at all. I followed Fox_exe’s instructions here.

To anyone interested, I use the My Cloud as a replacement for Dropbox and I have 2 PCs here. Some days I need to upload ~200 photos and sometimes need to edit them prior to uploading to the web. The scanning process that ran got its knickers in a twist, crashing the database and initiating a rescan. During this time it dropped off the network, sometimes for several hours.

To those who point out that I have invalidated the warranty I say “Which is better? A device with warranty that doesn’t work properly, or one without warranty that does?”