Power loss, lost raid 1, cannot create new array

Had a prolonged power outtage over a weekend and the mycloudmirror went down. Upon restart, the raid 1 setup was gone. NO CONFIGURED VOLUMES Both drives still report healthy. System checks all ok.

The SETUP RAID MODE button does nothing, clicking it and nothing happens.
Ive verified there are no popup blockers active, tried edge, chrome and firefox. I have reset the unit with the paperclip.

I tried to reload the latest firmware, but when i go to the page, the buttom to manually load firmware greys out in less than a second.

I have a very unhappy unit and Im out of idea what to do.

You may have to perform a factory reset within the unit’s Dashboard in order to correct firmware, driver and controller-related issues that may have resulted from the power loss. Afterwards you may need to rebuild the RAID volume from scratch, which will erase the unit.

tried both a system reset and full reset, same thing happens

Support should be able to resolve this for you.