Possible solution for fixing the bricked fixed IP

I’ve been reading how people have been bricking their devices by entering a bad fixed IP on their devices and subsequently not being able to access the device at all. 

Now since I haven’t tried this, I have no idea if it would work, but if anyone that has a bricked Cloud due to a bad fixed IP and cannot reset, lets give this a try.


1 PC or Mac with ethernet connection (cannot be wifi)

1 bricked Cloud 

As I’ve discovered, which is a nice feature of the cloud, is the ability to connect it directly to a PC/mac and it will autoconfigure itself without needing crossover ethernet cable.

  1. So connect the pc with the WD cloud

  2. what we want to do in step  3 is to discover the wrong IP and subnet that you have entered. If you know the numbers go to step 4. 

2a. on the PC, go to the type in area for search program and type in cmd to get to a command prompt

2b. on a Mac, go to Application, Utilities and select Terminal.app

  1. type arp -a (this will possibly show all the devices ip that is connected to your computer).

Now if your computer doesn’t match the subnet of the WD cloud, arp might not return any information, but you can play around with a fixed ip on your computer without any danger to your computer. When you are done, just reset your computer to DHCP.  

Try different subnets which is usually variations of or even because you typed it in wrong. If you can get a response from the WD Cloud to give up the numbers then you halfway there.

3b. It is a possibility that your router may log the ip and subnet mask as it is attached. So try logging into your router to see the logs on what activities and attempts have been made. If you are lucky and do get the ip and subnet masks, then you might be able to web/ui or ssh into the bricked device.

  1. you got the IP and subnet? great!! so lets change your IP and subnet on your computer to a fixed IP that is one digit different from your WD Cloud.

so lets say your WD Cloud is set to subnet we can set your PC to with a subnet of

  1. now bring up the web browser and type in and hopefully that might bring up the WD Cloud UI… and if it does… change it back to DHCP 

optionally just try wdmycloud.local on your web browser…

Logic behind this is that you want to be in the same subnet mask (this is the second set of numbers when you enter the fixed IP address) as your WD Cloud. Different subnets is usually the reason that you cannot see each other or the router being unable to recognize your device. The other problems are incorrect gateways, incorrect DNS etc. But if you can get on the same subnet, and you know the IP, then you can activate the web/UI and reset the fixed IP to DHCP.

Good luck… if this does work… come back and tell me so… if it doesn’t work… come back and tell me so… :stuck_out_tongue:



I haven’t tried it but I hope it does help.  Lets see what other users can share.

Ok. I’m trying this out, but I need help. I set my mcloud to the following:


subnet; (pretty sure)

I didn’t set the gateway or anything, after I set the static ip, it was totally bricked with the flashing yellow light no matter how many times I reset it witht he reset button on the back of the device 4second hold or 40 second. This is supposed to reset the unit back to using dhcp, but no dice for me. So I’m assuming it still thinks it has the ip 

I connected my mycloud to my computer and ran the arp -a command and got the following:

? ( at (incomplete) on en0 ifscope [ethernet]
? ( at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]
? ( at 1:0:5e:0:0:1 on en0 ifscope permanent [ethernet]
? ( at 1:0:5e:0:0:fb on en0 ifscope permanent [ethernet]

How can I tell which one of these  is the mycloud, and what do I do next? Do I change my computer’s ip to something at 192.168.1.??? and subnet mask then try each one of the above ip addresses in my browser? Bevcause i did that, and no luck :frowning:

Well the ips should be in the same neighborhood also, so try

setting this ip in your pc

then try in your browser,

and you can trying ping in you cmd panel or terminal and try arp again

now that second one looks fishy because we cannot or should not use 255 but anyways

lets try this ip in your pc then use in your browser… 

again ping the and try arp again

and this ip in your pc

and in your browser and again ping and arp

last one in your pc and in your browser and ping and arp

after each ping and arp, try the numbers as indicated above in your browser. 

Ping sometimes echoes and allows the device to respond…

oh what color lights are you getting from the network connection?

Green light (gigabit) on the back, but still flashing yellow light on the front

did you try all the ips that I listed 2 post above?

Yeah. So this doesn’t seem to be working, unless I’m doing it wrong. I did try all the ip’s you suggested (and setting my computer’s ip to nearby neighbors). Some of these ip’s can be pinged successfully using network utility, but none of them get me to the dashboard when I try to access the ip’s through my web browser (just get a “not connected to the network” error or it just hangs trying to access that ip. I also couldn’t set my computer’s ip to start with 224, as that range is out of the allowed value. So I couldn’t ping or I see how this might work, but it doesn’t seem to be. Can anyone else out there who’s more familiar give this a shot? I feel like the mycloud is one of these ip’s I listed above, but it’s not serving up the login dashboard at all no matter what I set my computer’s ip as. 

Thank you for trying Vort11 but right now you are the only one on stage. The whole world is holding their breath wondering if this might work :stuck_out_tongue:

Perhaps one more thing to try is actually taking off the ethernet cable before setting the ip on the computer. Then plugging in the ethernet cable after the ip is set.

This might force the cloud device to think it is connecting to a new network.

You are doing fine… keep up the good work…

oh… do try 

ip: and browse


edit: I’m looking on my own router and I have a connected Devices Summary of all the devices connected on each of my lan ports. If the above fails, re-attach your cloud back to your router and look for a similar report. 

sorry. Just wanted to say I did try 

ip: and browse


I still think that’s the mycloud since I set it to that ip before it decided to brick itself. So perhaps it’s still identifying its ip address on the network. Is there any way to make sure I have the subnet correct? I remember this is what I typed in originally, but can I verify?

unfortunately trying to get the subnet mask is difficult.

remember to unplug and re-plug the device. I am hoping that would jolt it.

and finally re-attach and check the router 

1 Like

Ralphael wrote:

unfortunately trying to get the subnet mask is difficult.


remember to unplug and re-plug the device. I am hoping that would jolt it.


and finally re-attach and check the router 

Going to wokr on this again tomorrow.I’ll try unplugging and replugging the device each time. I talked with engineering/tech support on the phone today. They were understanding, but didn’t believe that this is a firmware bug because they had helped people through similar situations by doing a manual reset with no  issue. I told them that this is being discussed by many here on the forum as an issue that only appears after setting a static ip. My unit is working perfectly up until this point, so it’s really not some sort of hardware issue. It’s clearly a software bug. So sad.

alright… I’m signing off too… good luck tomorrow… 

So I tried my best with this, but either I’m doing it wrong or it just doesn’t work. I tried every possible listed IP, but I get nothing. When i run the arp -a command, of all the ip’s and MAC addresses listed, none of them even matched the mac address listed on the bottom of my my cloud. So I don’t even think the my cloud is pulling an IP address. It’s just completely messed up. I’ll have to RMA this because I don’t want to open it up and install unix to reformat it.

Thank you for giving it a try Vort11.

You are not doing it wrong at all. Arp will only recognize and identify IPs on the same network and if your cloud is on a totally different network it won’t even answer. 

Since I haven’t tried this except arp’ing my own network, I had no idea whether or not this would work.

Sorry to hear that your device is bricked. 

Just out of curiosity, why don’t you try holding the reset button before you plug in your device and keep holding while the device is booting up for about 30 seconds into the boot up, then releasing? Keep the network cord plugged in and straight into your computer.

Just a last resort before RMA’ing it. 

Yeah. Tried it again. No luck, same outcome. Command doesn’t return any ip’s in the designate useful range. It’s a **bleep** that has subpar software, unfortunately.

Alright Vort11, thanks again for giving it a shot.

Good luck on your RMA and post up when you get one back.