Plex folders on Mycloud Home disappeared from view

Equipment: MyCloud Home; Windows Surface (Win10).
Plex was pre-installed - bought about 1 yr ago.
I used to see the Plex folders in Explorer and could drag files back and forth, but now gone from this view - I see nothing, even through on the NAS. OK, I thought, I’ll create a new library and put the files somewhere else that I can see in Explorer so I can manage content externally from Plex.
However, as another observation, in the Win10 plex web app - when select add library, there isn’t the “Add folders” part on the left menu (per the Plex support article) - just seeing select type and advanced, so I can’t seem to create a new library as well if I cant select the folders.
Does this mean I now have to pay Plex for the privilage to add folders? Has something happened with license - was this for only 1 year on the NAS?
Ideal is just to get the former Explorer view of the folders back, otherwise this has just become effectively a database I can’t change anymore!
Any ideas?

3 Likes

My libraries are now empty!!?? The folders (“Z:\Plex\Shared Music”, etc) contain files. I have done a manual scan via the web interface. Nothing!

Update: Inside the Plex Server settings (not the My Cloud Home’s filesystem!), I deleted a folder and then re-added it. This then started the folder scanning properly. Before doing this it would briefly scan and finish without finding anything. Fixed that part.

However, DLNA still broken. Disabling and re-enabling DLNA server didn’t work.

So, I disabled Plex completely in the My Cloud Home’s “Do More” area, and then re-enabled it. After setting it up again, it’s all working!

1 Like

Update - I re-signed into the Windows WD app and the folder (Z drive) is back in Explorer. So can now drag media back and forth again.
However, still don’t have “browse” option in set up a new library in the Plex desktop like in the tutorial in the help centre - must be something to do with way set up on WD product? So I manage libraries external to Plex app. Does anyone have comment on this - just the way Plex is licensed/set up in WD products?

The version of Plex on the WD MCH is limited to the default folders in the Plex folder.

And now my Plex library folders are empty again???

It is an old thread but I just encountered issue like this, yesterday. My solution is that I disabled Plex on my cloud home (MCH). Then I downloaded plex media server from plex website and installed it on my laptop. After that, I re-enabled plex on MCH and click on Configure. It then redirected to plex website. In plex website, I followed the instruction and click until it was done. The default name of MCH server on plex (plex is connected to MCH and accessed into it to retrieve video, music, images) is ‘my cloud home’ or somethings like that.
Then go back to my cloud home website, in File & Folder, add new folder, and named it like “Movies” or anything. Then switch to plex website, try to refresh it. You will see folder Movies under my cloud home. Plex now is synced with MCH, every movies you add into File&Folder/Movies will appear in Plex.

It is not certain how a laptop PMS can change file permission on the My Cloud Home Plex installation through the Plex website.

Disappearing Plex folders has been a recurring problem over the years. It appears to be a file permission problem that prevents users from using Plex to claim the media folders on the My Cloud Home.

One possible solution may be to reset file permission on the My Cloud Home with ‘Clear Device Settings’. This will take more than ‘a few minutes’ if the MCH has more than a few thousands of files.
Imgur

https://www.reddit.com/r/PleX/comments/184fwsj/my_cloud_home_plex_folder_just_not_appearing/
1 Like

I forgot to mention that after configuring, you have to click to the plus icon next to ‘my cloud home’, then add movies/tv show/music. After that, set the folder in which Plex can get movies/tv show/music from. In my case, I added movies, then set the folder which is the Movies folder in my cloud home. After that, Plex will be synchronized with my cloud home’s Movie folder.
PS: Folder Plex will not appear inside my cloud home’s File & Folder anymore. It is not an error. I think WD and Plex has changed the way of synchronizing. The most importance thing is that you have to install Plex Media Server in your laptop/PC before configuring Plex.

What you are describing is running the PMS on a laptop and using the MCH as the network storage for the media without running PMS on MCH itself.

  • The laptop is required to be power on continuously as is the MCH
  • You can check this by disconnecting the laptop and see if MCH can still serve Plex clients

Nothing wrong with this except there is really little reason to use the MCH if the laptop can just have a cheap high capacity USB HDD storage attached so that the laptop can function as a NAS with PMS and other file server functionality and home users do this all the time.

I tried to power off my laptop and opened Plex on my Android TV and it still worked.

The version of Plex on the WD My Cloud Home is limited to using only the default folders within the Plex folder.

According to the Plex support on the Plex tv forum, PMS (Plex Media Server) can be installed on multiple devices but they act independently and one should not have an effect on another.

It is also possible that PMS from a Windows laptop install can reset the files and folder permission on the My Cloud Home Plex folders and bypass the file errors that has blocked the MCH PMS from opening these files.

There are too few owners who have reported the effect of using two PMS to know what is happening.

@NoPlex Nice Information :blush:

1 Like