Pictures transferred from iPad to WD MyCloud all 0 bytes


I have a WD MyCloud Mirror 4TB with firmware 2.10.310 and my wife’s iPad was choc full of baby pictures and movies.

I’ve installed the WD My Cloud app on her iPad and used the three dots menu to “Add photo” and select the 801 items from her Camera Roll to copy to a sub folder in the Public folder of the WD MY Cloud. We left the iPad transfer the files over a few hours and all of them were transferred (we have a Netgear DGND3700 N600 Wireless-N Dual Band Modem Gigabit Router).

However a closer look showed me that while all videos were transferred successfully, most of the pictures (712 to be precise) appear as 0 bytes files.

Is that normal? Is there a better way to transfer files from an iPad to the WD My Cloud?

Would love to get some help,


Here is your solution! I actually wrote it up yesterday after responding too many times to this problem, so I could just send this link.

Hopefully, all the files are still on the iPad. If so, then just delete what got transferred and start over. If files with 0 bytes are there on My Cloud, the app will think the files are already there (and OK)…

Another tip, put iPad closer to router so transfer takes less time, and use 5G wireless if you have it set up. You can just tell app toe select ALL of camera roll and off they go. You can also set up auto-backup, so explore in app settings these options beforehand.

Her is your solution: (lucky you)


Thanks for the fast response! I just checked it but in my case, I did make sure the auto-lock was set to never before starting the transfer as I could foresee this might impact the transfer once the iPad locks/goes to sleep.

Could there be another explanation for the 0 bytes files?

I am impressed that you thought beforehand about Auto-Lock being a problem. Most folks haven’t done so, hence my post about it.

Could there be another explanation for the 0 bytes files?
Probably is an explanation for everything, but in the case of this 0 bytes mystery, neither you nor I know what it is – yet! I’m thinking about it, though, and hope to solve it soon.

Meanwhile, keep that first incomplete upload on the Mirror until another try gets all uploaded again with no issues.

Create a new folder to upload into for the next attempt., and hopefully it was just a glich the first time. All of Camera Roll should upload into an empty folder.

Since you have a dual-band router, use 5G if you have it set up, and place iPad nearby the router. Close unused apps on iPad to free up memory and aid processing time.
When I did this first time on wife’s iPhone, over 2000 photos and videos were uploaded in around 30 minutes via 5G.
(BTW, I never use the old 2.4G signal for anything that requires speed like streaming videos and a process like this upload.)

Let’s hope it works better this time.

One more though before I post this: If you checked the Mirror right after the uploading finished, it may not have completed cataloging them fully into its database. So, check folder again before re-doing upload, as all may be OK now.


I created another folder and tried again, the transfer went better but was still not perfect with many files missing. I got “storage almost full” error messages several times as my wife’s iPad was really full.

Created some space removing useless apps and TV shows that we could redownload later and then followed your instructions, and then it worked. Took me five times overall with different trial and errors and discovering some of your tips by myself on the way.

Might be a good idea to add the above caveat (creating a bit of space before starting to transfer files) in your guidelines as most people will most likely do that when their storage is pretty much full.

Thanks for your help.


Hi Chris,

I much appreciate your getting back to me about this. Yep, one cannot let their iThings get too full so that it drains the storage memory dry. You may know there are areas in the devices in Settings that show how much storage is used and how much is left, and also how much storage each app takes up.

I am going to definitely use your tip to add to a new post, along with all other problems users are discovering with the My Cloud backup of Camera Roll So, keep an eye out for a new post some day soon; working title is something like “Camera Roll Backups with My Cloud App (FAQs)”

This week I heard of a new issue, twice. Complaints arose of incomplete uploads when people return home and expect to upload on their Wi-Fi. The first complaint caused me to see if I could replicate the problem, and I did. I found that if the MC app is “on” (or even if it is minimized), uploads would not occur. Apparently, uploads only occur from a fresh startup of the app. It is not constantly scanning for new uploads (which is good). Instead, upon each start of the app, auto-backup looks for new Camera Roll items that need uploading and does it.

The second complainer said his iPhone had not auto-backed up in two weeks! He proceeded to dis the WD app for why it could not do this. I wrote back and told him it is because he likely never turns off the MC app. I told him the procedure to follow.

So, best practice with this app is that before commencing (or expecting) an upload, be sure app is completely off or turn it off, then turn it on (or back on), and things will work fine.

Too many people leave too many apps on they are not using, and this runs down their battery. They need to turn off un-used apps