Password to access drive on same network?

I just set up my new 3 TB Mycloud drive and i am pretty much brand new to the world of NAS storage. It is user friendly but I do have a few questions I was hoping a more experienced user could answer.

  1. I understand that from phones and tablets, you need to download the app to view/upload/download files. The app is password protected. However, when I open up any of my computers on the same network, I notice the My Cloud drive is accessible to anyone. I have someone living with us who uses our wifi. They also have a laptop and I am assuming that they have access to all my files on the My Cloud hard drive. Although this person is trustworthy, I don’t want just anyone going through my stuff. Is there a way to set up a password to access the My Cloud drive on the same network?

  2. I have uploaded a lot of FLAC audio files. I try to access these from my iPhone but it asks me to use an app that can play these files. I would like to use VOX, which is an app I downloaded that is specifically designed to play lossless files. Despite having VOX downloaded, the WD app doesn’t recognize this as an app that will play these files (although it does do this). I had to download VLC player which works fine but I really would like to use VOX. Is there any way I can have the FLAC files directed to play on the VOX app?


You probably want to download and read the User Manual, and read up on Users, passwords, Shares and assigning access to Shares. Only the Public Share cannot have access limited. Add a password to each User account, apply access restrictions to Shares, and don’t put anything in the Public Share. You will need to use your MyCloud User credentials when accessing your Shares.

If you enable the DLNA media server, be aware that it does not respect access controls, so anyone with access to your network will have access to all your media via DLNA.

You might look to see if your router supports a ‘Guest’ mode that only allows internet access, but no access to the rest of the local network.

As for Vox, it sounds like it hasn’t registered its capabilities with the operating system properly, whereas VLC has. You might try reinstalling Vox, then reinstalling the MyCloud app.

You can use any decent file manager to access the MyCloud; you don’t have to use the app, except for remote access.

Thanks, I’ll check out the manual and remove my stuff from the public folder

OK, I must ber an ■■■■■. I’ve tried everything and I can still access all the folders on laptops. This would mean that anyone with access to our wifi password will be able to access everything on the My Cloud. I can’t figure it out.

My wife has her iPhone pictures saved on her folder in Mycloud. This can be accessed by anyone. I add a password but this doesn’t seem to do anything.

Any step by step? The online help doesn’t really go through it that well

I’ve tried everything and I can still access all the folders on laptops.

Okay, maybe some more detail would be useful. Please try to answer all the questions, to give us a better idea of what you have done, and what is happening, and whether it is a fault with your device, or with the configuration you have applied.

Have you created Users, and given them passwords?
Have you got those Users to put their files in the associated User Share?
Have you modified the Share access permissions using the Dashboard (NOT File Explorer/Finder)?

What access method are you using that allows you to access any folder? File Explorer? Finder? MyCloud app? Other?
Do you need to give your User credentials when accessing folders via a file manager?

My wife has her iPhone pictures saved on her folder in Mycloud. This can be accessed by anyone.

Where, exactly, has your wife stored her pictures?
Who is ‘anyone’? What account are you using to test this; yourself (admin)?
I assume that you have the admin user account; have you denied yourself access to your wife’s folder? If not, as admin, you will generally be allowed access to all files on a computer system; that’s what admin privileges allow.

This would mean that anyone with access to our wifi password will be able to access everything on the My Cloud.

When you say ‘everything’, do you mean files of ALL types, or just media files (pictures, music & videos)? Can you see text files, PDFs, or other documents?
As per my first reply, do you have Media Serving enabled on the Shares?
Are you accessing the DLNA Media Server, rather than the File Server? As I said, DLNA ignores access permissions. If you don’t want people to see media files, turn off Media Serving on the share.

Have you investigated Guest mode on your router?

Have you; accessed the My Cloud Dashboard, navigated to the Shares page, selected a Share and then set Public Access to ON?

The My Cloud Dashboard Help explains how to configure a Share for Private at: Help > Home > Managing Your Personal Cloud > Shares > Changing Access to a Share.

Once a Share has been configured for private access one would then configure User permission (Full Access, Read Only, No Access) to that Share.

Sorry, I was away for a few days.

Ok, here we go:

So, my wife saved all of her picture from her iPhone in a folder she titled “Rosie”(her name). It is not in the Public folder but a separate folder. I want to set up that folder as private access. I have FLAC music files that I have already saved in the Public folder and I don’t care if anyone has access to them so I’m not bothered about moving them.

The folder Rosie has Public Access ON.

Here is the issue. I went to a random old computer that nobody really uses and turned it on. I went to the Macintosh HD icon (it’s a Mac) and was able to see the WD Mycloud drive there. I clicked on it and was able to access the Public folder and the Rosie folder. This is without putting in any passwords or anything else. How do I prevent anyone with our wifi password from accessing the folder titled Rosie?

I understand I can restrict user privileges but it appears that now, even non-users can just open up the folders.

Turn it off, then…

A password is not needed to assess the Rosie Share BECAUSE you have it configured for Public Access. Solution? Change Public Access to Off and then set each User’s permission level to the Rosie Share.

You may also want to take a few minutes to reach through the My Cloud User Manual ( and or the My Cloud Dashboard Help to gain an understanding of how the various features and settings of the My Cloud work, including how to set Shares to Private and configure User access to those Private Shares.

I’ve done that before but then the drive becomes invisible to users on the computer/laptop that I do use regularly. I was hoping I could just add a password to the folder.

This is what I’ve done:

I took off public access so no one can see the folder. I’ve downloaded the app on my laptop and will access the WD drive through the app (password required). If I try to access the drive without the app, the Rosie folder is not visible. So, this is the best solution.


You CAN in effect add a password to the Share. When you use the Dashboard to configure a Share for Private you can then select each User and configure their access (Full Access, Read Only Access, No Access) to that Private Share. From that point on when one attempts to use Windows File Explorer or Mac Finder to access the Private Share or if they setup a mapped Share, they will be prompted to enter their Dashboard created User name and password. Again, this is all explained in the My Cloud User Manual and in the My Cloud Dashboard Help.

However, its important to remember that DLNA does not abide by the Private Share setting and any Private Share that has Media Serving enabled (set to On) will still have its media accessible to any DLNA client. Solution? Disable Media Serving on a Private Share.

Isn’t that what you were trying to achieve; to require a password to access a Share?

Once you have created Users, turned off Public access to their Shares, set up User access to the Shares, you will need to provide User credentials to access the Shares a User is entitled to see.

On Windows, all network server accesses must be performed using the same credentials; these must be those of the MyCloud User, even for Public shares.

If you have mapped any Shares as Windows network drives, unmap them, and then re-map, selecting the ‘connect as different user’ option; enter your MyCloud User credentials.