Passport drive not backing up

#1

My passport drive has stopped backing up, my PC can see it, and I can still copy files to it manually, but the automatic back up doesn’t start and manually forcing a back up to start does nothing, I can see a few topics before about the same issue but can’t see one where it has been resolved

1 Like
#2

Hello pete567,

Did you try to uninstall and reinstall the latest version of WD Backup from Support site in this concern?

If yes, you can refer below article to check the list of files not backed up using WD Backup.

#3

Hi

Yes, tried re install from software on passport drive, and also re install from software from WD website

Still same, nothing happens when click back up icon

Regards

1 Like
#4

I am having a similar problem. I’m using Windows 10, and I’ve updated to the latest WD backup, WD_Backup_1.9.6941.25593, but double-click on the shortcut on my desktop, almost nothing happens.

I say ‘almost’ because a new background process WDBackupService appears in Task Manager, and it takes up to 11% of the CPU for about three seconds before spooling down to 0.1%.

If I go to the icon in the Show Hidden Icons tray, “Backup Now” produces no visible response, and “Settings” doesn’t call anything up either. “Help” does load the Help screen into Google Chrome.

I had two listings for My Book (E:), one under This PC and another separate. I renamed the second one “My Book 2” as suggested in another thread, but the name change doesn’t seem to have entirely propagated. It hasn’t solved the problem, either.

Right now I don’t know if the software is working. I don’t know if the software is NOT working. The light on my WD MyBook is blinking and I have no way to tell if anything’s happening or not.

#5

Hi, I’ve still had no luck, can use drive to read/write to, but backup still does nothing, if anyone does find a solution it would be appreciated. Regards