OS5 crontab problem

I’m trying to establish a rsync backup from my WD Mycloud EX2 Ultra running OS5 and a Synology.

I configured passwordless ssh and a manual rsync works perfectly.

Now I want to configure a cron job.

I edited




without luck. It will not survive a reboot.

I even did

mkdir /tmp/ubifs_flash

mount -t ubifs /dev/ubi0_0 /tmp/ubifs_flash

and edited


without luck also.

Any hint how to setup a cronjob?

I’m also trying to do something similar. Have you worked it out?

Trying to do the same… sigh…

Did you find any solution? I’ve been trying to run the rsync server on a My Cloud EX2 Ultra from boot but all the configurations are gone after every reboot. Is there any way to make it persistent? I’ve been looking everywhere.

You’ll have better luck with some of the older threads such as this one:

1 Like

@NoPlex I’ve tried but most of the information in those threads (if not all) does not help anymore because it seems that in OS v5, there is no way to make changes persistent (or at least I did not find any way so far).

Thanks for the reply, btw. I’m desperate haha

@Martok I don’t even know where to start with that information :sweat_smile:

This was very helpful! I’ll look into it later today to do some testing.

Thank you!

I tried a more elaborated approach (calling simply a script inside one of the shares) but I like your approach more. Both worked but I have another issue now (with both approaches): now, when I try to connect from HyperBackup, it’s popping up this message “Authentication failed. Please check your authentication credentials”. For some reason, when I was manually creating each file, this did not happen. I don’t think I did anything different, to be honest.

Yep haha :sweat_smile:

But now I’m trying it to do it like in the old way (creating the files manually in etc), just to test things out, and I’m having the same authentication issue, so it has to be something else.

PS: I’m restoring the whole system back to defaults, in case something is messed up.

Yeah, I’ve rebooted many times because I’ve tried many things to try to make it work. But nothing did the trick.

I’m pretty sure it has to be something that I changed accidentally that I don’t even remember doing. I hope that after resetting the NAS, I will get fixed. I will report back once I fix it.

I’ve did a full restore to defaults on the My Cloud and I still have the same issue. I’ve also tried connecting from a windows rsync client and I also have the same issue.

I have created a log file to check what could be going wrong. This is what I got

2023/08/19 23:39:50 [6114] rsyncd version 3.1.3 starting, listening on port 873
2023/08/19 23:41:02 [8663] connect from MyNASName.MyDomainName (My.NAS.IP)
2023/08/19 23:41:02 [8671] connect from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:02 [8671] module-list request from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:02 [8675] connect from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:02 [8683] connect from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:02 [8683] module-list request from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:03 [8955] connect from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:03 [8956] connect from MyNASName.MyDomainName (My.NAS.IP))
2023/08/19 23:41:03 [8956] auth failed on module shares from MyNASName.MyDomainName (My.NAS.IP)) for root: no matching rule

And when I connect from the windows machine I have these messages

2023/08/19 23:45:43 [14013] connect from MyWinPCName.MyDomainName (My.Win.PC.IP)
2023/08/19 23:45:43 [14013] auth failed on module shares from MyWinPCName.MyDomainName (My.Win.PC.IP) for root: no matching rule

I really don’t know what did I do the first time to make it work :face_with_raised_eyebrow:

I’ve been hours trying every combination I could think of but I’ve made zero progress. This is the latest version of the script:

echo "Starting rsync with custom configuration..."

cat <<EOF > /etc/rsyncd.secrets

chmod 600 /etc/rsyncd.secrets

cat <<EOF > /etc/rsyncd.conf
lock file = /shares/BKP/rsync/rsync.lock
log file = /shares/BKP/rsync/rsync.log

path = /shares
uid = admin
gid = share
read only = no
strict modes = yes
list = yes
auth users = all
secrets file = /etc/rsyncd.secrets
# hosts allow =

chmod 644 /etc/rsyncd.conf

rsync --daemon --config=/etc/rsyncd.conf

But still… same result. I’m extremely frustrated of not knowing what the hell is going on.

PS: Btw, I use a fixed local IP for my synology NAS, so it does not change.

Since I had no success at all, I decided to try something more drastic: I installed DSM 6 using this and it worked. Then I configured rsync in DMS and now it’s working flawlessly :grin:

The only purpose this NAS serves right now is as a backup from a Synology NAS. I don’t need it for anything else.

Western Digital removed WebDAV from the device on OS5 and they don’t allow the user to downgrade to OS 3 (which had WebDAV), so I did not have many other options if I wanted to use HyperBackup.

I really don’t understand why WD would remove WebDAV. That was a very stupid move.

@Martok WebDAV was a useful feature to have. Removing it was clearly a mistake and I’m not changing my mind about that :joy: It gave me the flexibility I needed.

Regarding the Rsync fix, I spent nearly a week on the matter and I run out of time. I needed to find a different path and I did. It’s very unfortunate that you found that now because it looks like it could have worked.

Believe me. I spent more hours than I can count trying to find a solution in this forum. I just didn’t came across that post.

Thanks for the help in any case. I really appreciate it :pray:

Since it is just an additional backup, I don’t need it to do much. I’ve done some extensive testing for the basic stuff that I need and there were no issues. Fingers crossed.

If it started to be very buggy, I will consider going back to WD OS. But, in all honesty, I don’t know where to start and I’m very concern that I could brick the device easily.

PS: Btw, I’ve done several backup testings using both RSYNC and WebDAV (the custom DSM has both options) and WebDAV is faster, which is also a plus.

That’s awesome!

If I find a convincing way to go to OS 5, I will try that :+1:

@Martok Apparently, this is what I need. What do you think?