No storage present

i just bought wd tv live hub 1 tb and been using for 1week more or less and then suddenly when i start it it says,no storage present,i do a restart noting,then i do a factoty reset and it finds my workgroup,but next day in the evning same thing again,i really dont know what to do,i mailed the support and didnt get any answer,plz help

windows vista 32

using wd powerline kit

What firmware are you running on, and it says No Storage Present when you go where exactly. Try giving a tad more information so we know how things are set and maybe find a solution. 

im using the latest firmware and no storage comes up when im choosing sync from a network share

i have tried to roll back firmware but still the same problem

So what happens if you go to the Drive Manager in the SETUP menu?  Does THAT detect your internal drive?

yes in the disk manager i can see my internal hardrive

i have the same problem "there is no media in the current folder " there should be 20+ films in there

ive only have it 2 days tried 3 firmware roll backs  resetting nothing working  theWD hub doesnt detected its hard drive

and its not seen on my Pc network is there a fault with WD live Hubs ???

I’ve had this happen to me on the hub. My videos were in a folder labeled MOVIES on the internal drive. One day I got the “no media in current folder message”. Using the files option revealed that there were now two MOVIES folders on the internal drive. I don’t know how this happened but I moved my files to network beckup. I tired rebooting it didn’t work. I reloaded the firmware and put the vidoe back on the HUB and now it works fine but I’m keeping a wary eye on it! I think the directory structure got corrupted but I don’t know how.

thats not like my problem at all,my files are all there when it works ot not at all,

I have the same problem. At first I thought it was a hard disk failure, since I received a message about a disconnected internal hard drive. Anyway, I did a reset and then I got it back (the library and all my media) but after a while I lost it again. When I tried to get into the Disk Manager I found that the data was in the hard disk (that didn’t failed) but it did not indicated any photos/music/videos. I performed a new reset and I got it back one more time, but after a while the situation presented one more time.

Today I connected an external hard drive and a usb flash drive and at first the library was compiled and I had a chance to see that everything was fine, but after some info transfer between the connected drives the library was gone one more time (internal, external and usb flash drive). I checked in the Disk Manager and I could see that the 3 drives contained information, but it didn’t identify that info with music/photos/videos.

Now I can think that the problem isn’t located in the internal drive, my guess is in the firmware. The problem started after the update 2.08.13, then I rolled back to 2.07.17 but the problem persists, basically when I do a file transfer (network or usb attached to the hub).

Anyone have experienced the same situation?

not sure if mine the same but i cant not fine the drive at all now  i dont get a message about dis-connected  drive

ive tried about 4 firmware not work what so ever got the Hub 4 days ago now its stuck in my Tv doing nothing

and its pissing me off … i have contacted WD so just wait and see what they say!

Have you reseated your device? There is a reset button in the bottom.

got mine sorted :slight_smile:

Try going to setup then system then Media library the click clear media library

I’ve had a gutful.

At the start of the week the box was failing to find movies in my movies folder I shared. Then It couldnt find the folder.

Now its something wrong with my computer, I didn’t say my prayers or give enough to charity, I dunno why it doesnt like it.

It finds my laptop, but the folder on that I’ve shared, doesnt appear.

Normally I would write this off, but after spending £180 on it and yet to watch a film, not happy so far.

Then while trying to get the laptop to work, my computer shared folder appeared, at random. I was stunned. Then it vanished just as quick. I’ve rebooted, reset all devices, router, hub. IT REFUSES to find my shared folder, which every computer in the house can find.

RubenC wrote:The problem started after the update 2.08.13, then I rolled back to 2.07.17 but the problem persists, basically when I do a file transfer (network or usb attached to the hub).


Anyone have experienced the same situation?

I have. It’s got to be the firmware, cause mine worked fine for 10 month and after update to 2.08.13 not anymore. :cry:

ok i just update the firmware and now my network share is back,but its impossible to watch anything cause all movies stutter