New Release - WD SmartWare Version 2.2.0 for Windows (8/26/2013)

WD is happy to announce the release of WD SmartWare for Windows 2.2.0

  • You may post your experiences in this thread.

After installing Windows release 2.2.0 on my WIndows 8 desktop I can not map to mybook live anymore. I can still map to it via my Windows 7 Laptop and my MacBook Pro. Has anyone had any issues with this install on Windows 8?

Hi johnluk,

I’ve already posted a message that concerns this problem with WD SmartWare 2.1.0 and 2.2.0 newly…I’ve proposed a solution here.

I requested support from WD 3 days ago but I have no response yet…


Following installation of the new release, I got a message saying I am not a “subscriber” and indicating I must subscribe.

I assumed I had downloaded the wrong software for my MyBook, so I sought to uninstall and download again.  I’m getting mixed messages in trying to analyze the issue.  In attempting to install, I received a message saying the unit already is installed.  When I tried to do a backup, however, I received a message saying the unit is “not connected.”  It is physically connected.  The blue light is blinking.  There is no blue line above it.  USB is connected.  But the unit is not operating. 

Two questions:

One:  When the latest update is loaded, is it normal that subscription to a service to operate the unit is required?

Two:  Is there a step by step set of instructions to analyze the issue(s) and resolve them?

Today i went to back up to my WD My book live. I got a notice that said an update was available. I downloaded the update, as i am using windows 7, followed all the instructions. At the end of the update i re-booted my computer, then logged in to My book live via the smartware tab on my computer only to find that i cannot back up anything unless i subscribe to and pay for a drop box service which i have no interest in whatsoever! Jesus, i only want to back up my files, and the back up tab is not lit!!! What on earth is going on Western Digital?? Your updates create more problems than they fix! Can someone please help me get this sorted. i have already tried downloading the WD SmartWare Version 2.2.0 for Windows (8/26/2013) again, and re installing it, still without any success. As you might be able to tell, i am getting very fed up with this now! Some assistance would be greatly appreciated.

After installing the 2.2.0 SmartWare on MyBook using Win 7/64bit OS I didn’t realize that it had checked every file as well as I think listed deleted files for backup. The backup couldn’t complete and indicated a dozen or so files that either were in use (windows, skype, Antivirus etc) or no longer existed on my computer. Repeated attempts to remove these files from the backup list by unchecking them were unsuccessful. The “view files” list identified the problem files but how does one either remove or bypass them from the backup list to obtain a complete clean backup?

Also these files can be highlighted but no action can be taken on them apparently.

When will 2.2.1 be coming out as well as addressing these issues in the new user’s manual?


Hi, I’ve got to say I have had no end of probelms with WD Smartware since I bought it and installed the previous update.  HOWEVER, this latest update has left me with a totally frozen computer EVERY time I plug in the USB cable.  I have followed the installation instructions 5 times now, deleted Smartware several times, and I’ve even tried to use the quick formatter to erase and start over totally, BUT guess what …it doesn’t even allow me to do that,  it simple gives me this message “unexpected error occured” and then everything stops, my windows explorer freezes and my desktop disappears, then I unplug my device and my desktop reappears.   The worst of it is, that when I was able to view contents of the drive on one occassion when windows explorer didn’t freeze (after this latest update), it appears that ALL my business data and backups are gone.  All I can see is Extras, WD Unlocker.exe, Quick formatter.exe, and WD Smartware folder with just top level folders.  Nothing else.

Please note, I have not had problems with any of my other installations and I’m on Vista which has (fingers crossed) never caused me any problems with any other application - EXCEPt WD Smartware.  I am getting ready to throw this piece of junk out and never buy WD products again.

Help! if anyone actually knows a solution to this I would be very grateful to hear, but it looks like from the other posts that it is a common problem - so why WD are you still in business???


very, very  frustrated

this release is worse than the previous one.  when I moved to win 8 and updated to the previouse release it would create the initial backup and then do continous backups for up to 4 days and then quit.  on 2.2 it created the initial backup and then never backs up a file again. the light flashes after I close a file like its backing it up but there is never another version of the file saved. been fighting this for 2 months and nothing WD tells me to do works.

I have tried version 2.2 and just not working for me, Smarware just not backing up new files.

I have switched back the orignal version that came witht the drive, I believed it is 1.6.4 and it is working perfectl. As soon I have a new files, it got copied to the backup drive. I am using Windows 8.

I have the same problem as slaulau - new files do not get backed up. I am using Windows 8 and WD SmartWare 2.2.0. The program says the backup is complete, but if try to retrieve the new file, it is not listed. This is not very reliable.

WD - any updates? Or, is it better to go back to the original version?  

I have a similar problem. I have not checked the new files. My problem is that since I resized my source disk, so everything has to be back up again. The new backup is 50~100G smaller than the previous backup (around 500G in total). I checked the folders at least one folder with jpg files didn’t get backed up.

I did various experiments to see what is going on. I duplicated the jpg file, the duplicated file can not get backed up (not showing in the source folder within WD Smartware). But if i re-save the jpg file using photoshop, the file showed up and presumablly can get backed up correctly. A patch is highly desirable. If not, i think i will have to go back to ver. 1.6. (Ver 2.0.1 has the same problem.)

New Passport. New install of V2.2.0. Set for continuous backup. First backup installed properly. A few days later plugged Passport back in. Started Smartware. New additions and changes to files won’t update! Smartware displays “Copying Files” every few swconds followed by “Backup Accomplished Successfully” but new and changed files are ignored.

Anyone else having this problem? Or is it me?

Suggestions welcomed.


I have setup my 2TB My book Live in May 2013. I have installed WD smartware on my laptop (Windows 7 home premium, 64 bit) and it was working ok. Since last 15 days, when I launch WD smartware, I see smartware logo and them momentarily message appears “Configuration system failed to initiate” and them disapprear. I have uninstalled smartware and reinstalled latest version of WD smartware. I have recently updated firmware also on my WD my book live. Still I am getting same message. Please guide me how to get this fixed and launch WD smartware. Thank you. 

I updated to Smartware 2.2.0 on my 4TB MyBook and found out by accident that new files were not being backed up. Prior to the update continuous backup was working fine. After the update, no backups. New files are ignored. Worse, the software says that the backup was successfully completed. This really is the worst case - no backup, no warning, and a wrong message saying the backup was successful. That’s about as bad as backup software can be.

I’m using a brand new desktop running Windows 8.

Interestingly, I can see the new files in the File History folder on the My Book, but they are not in the backup folder, and they cannot be retrieved using the Smartware software. Also, there is no version history for those files.

Spoke to WD support, they had me reformat the drive (destroying my existing backup - great). After reformatting, the backup procedure worked once, and then new files were again ignored.

Uninstalled 2.2.0 and reinstalled 1.6.4 (fortunately had the presence of mind to copy the files before reformatting the drive). Now with 1.6.4 everything is working fine again and new files are backed up instantly.

It sure seems to me like this is a software problem with the update. Come on WD - how about addressing it.

I have the exact same problem that Bhavesh0809 describes. I bought the 2TB MyBookLive last week - it set up like a dream, and the software installed on my laptop perfectly. My Cloud works really well, as does local DNLA streaming - brilliant product, I thought.

Then I configured my laptop backup using WD Smartware 2.2.0, and it backed up everything that I asked it to. I’ve updated files since, and it writes new versions, and keeps the previous 5 version, per my config.  Excellent.

BUT, if I create any new folders, or add new files, they don’t get backed up. I have Set Backup Frequency to Continuous Backup, and I have a progress bar in the software client that flicks between Copying Files and Backup Accomplished. I can see all the new folders and files in the selection window, and all are marked with a checkmark - the new folders are all subfolders of existing folders and as such have been checkmarked by default… but non of those new files or folders are getting transferred to MyBookLive.

Getting so frustrated with this now - been messing with it for days, and have even done a factory reset on the drive, despite having already backed up 300gb of data which took over 24 hours.

HELP please

I just received a reply from WD support telling me to remove Smartware and .NET framework, and to re-install.  I don’t see that as a “fix”… it would suggest that I have a problem with my local installation, however it’s evident from this board that there are many people experiencing the issue with 2.2.0, and that the software itself is at fault.

My .NET Framework is bang up to date - it gets used by other systems on my laptop, and i’ve already removed and re-installed Smartware more than once.

In the interest of actually getting some use out of my new WD drive, I’ve download a free version of an alternative backup/synchro package, and it works a dream - and it’s far better to use.  

Hi there, would you mind tell me what free version of an alternative backup/synchro package you are using now. I would be happy to use it instead of this problem smartware software. Thank you.

I would appreciate knowing what alternate backup software you are using as well.


I too have been experiencing similar problems as many have posted here  - some files that have been changed since a previous backup do not get backed up when they should be (note I haven’t yet found a situation where a brand new file isn’t backed up … my problems are with changed files).

I am using Windows 8 and WD SmartWare 2.2.0 (PRO) with my brand new My Cloud 3 TB. After conducting a backup (scheduled or continious, I tried both with the same problematical result) the program reports that the backup completed successfully, but if I try to retrieve certain files that HAVE BEEN updated since a previous backup … the newer version of the file is not on the backup. There doesn’t seem to be any rhyme or reason for when files are not backed-up that should be — and since the program does not appear to have any way of reporting what was and what wasn’t backed up there’s no indication that anything is wrong (or right for that matter) — so in otherwords I can NOT rely on this backup program to peform as expected/advertised.

Given all of the numerous postings by others who have uninstalled and reinstalled (I did that too), etc. — to no avail — I’m giving up on this software, and am now using a third party software instead (not free). 

So although I’m happy with the hardware (My Cloud 3 TB), I’m can’t say the same for the ‘free’ software that came bundled with it.

Just my 2 cents worth.

I am having the same problem as many others.  The first backup after buying my drive worked wonderfully.  Any new files I’ve added to my pc since DO NOT GET BACKED UP.  That is in spite of the fact that “Backup accomplished successfully” each time.

WD, do you QA your software before release?  This is the most basic functionality for a backup software package.  What gives?