New Release - WD Smartware Version 2.1.0 for Windows (7/1/13)

WD is pleased to announce its next release of WD Smartware for Windows.

  • You may post your experiences in this thread.
2 Likes

Great - solved the problem with  “have to activate the WD Smartware Pro” every time it started :smiley:

2.1.0 doesn’t seem able to view backups already in progress by 1.6.5.3, which makes it useless to me. I have a 1T drive with some 0.8T of backups ongoing. I don’t want to abandon those backups because they have already proved useful to me for restoring earlier copies of corrupted documents. Windows is not,as you may be aware, the best of operating systems.

The only way out of this mess that I can see is to buy another Passport drive and install 2.1.0, but every time I want to get at an earlier backup, I will have to roll back to 1.6.5.3, swap the drives, access the file(s), swap the drives again, update to 2.1.0, and continue until such time as I need to access the 1.6.5.3 backups again.

Unless you have some alternative suggestion?

Why was the decision taken to make earlier backups inaccessible? Why is there no upgrade path or converter for earlier backup files?

And yet there are still issues with retaining unlimited copies of any file that does NOT have a file type extension on My Passport.  This occurs with my installation on Windows 8 Home.

eg. a text file called “wd_test” in “My Documents” folder not to mention email repositories, such as INBOX, SENT, etc.

Tho’ I am not sure that it is backing up “My Documents” any more - I have edited a couple of files with no backup after several minutes.  Occured alost straight away with vsn. 2.0.1

I have tried to work around this, pending a solution, by deleting hundreds of file copies from the “WD Smartware.swstor” folder via File Explorer.  So far I have removed any such file with a creation date between 01 March and 31 May, where there are more than the requested retention number (set to 8).

I raised an email support issue with minimal progress so far, other than emails and phone calls from a doubtful person called [Deleted] who wanted access to my PC.

Hmmm. I rolled back from 2.1.0 to 1.6.5.3, and when I went to restore a file, discovered that 1.6.5.3 couldn’t recognise the files that had been backed up until I tried 2.1.0…

This didn’t happen when I tested a prior update - rolling back gave me everything I had before.

So now I’m screwed, whatever happens. Neither version will recognise the files that have already been backed up. Smartware only sees the block as “Additional Files” under both versions…

The link for Windows seems to be broken?

Just got my new 2TB WD backup system.  I have an older Vista PC.  I loaded the SmartWare app from the CD.  and when completer, it appears in my programs.  No icon, but in apps.  When I download the update, it goes for a while, then I get the following pop up:  “There is a problem with this Windows Installer Package.  A program run as part of the setup did not finish as expected.  Contact your support personnel or package vendor.” 

Anyone else get this?

I updated to this release on my laptop, and Smartware will not launch.  The error window pops up and closes very quickly, so it’s hard to see the whole message.  It involves “Smartware.Retrieve.Retrieve” and “throws an exception”.  The old software version, 2.0.1, worked fine.  I did uninstall and reinstall, but results are the same.  OS is Win 7 64-bit.

I also updated the software on my desktop, and there are no problems.  OS is also Win 7 64-bit.

Please advise.

I just got a fresh RMA my book live, and so as long as the drive had no data, I updated smartware to 2.1.  I was on 1.5.1.6 prior, I think.  One vista home machine, one XP machine.

Had to re-select files and folders, and had to recheck all the appropriate folders, but I’m ok with that.

For some reason, there is a Smartware.stor folder in both the public share, and also in the mybooklive share.  I think it started copying files into the public folder for some reason, before it created the smartware share folder.

i have two PCs backing up about 200GB worth of stuff, so I’m just going to let it run and check it all later.  On a few partitions the backup became disabled again, and I had to enable, but I think that was due to me updating a few file and folder selections in the backup planl

Hi

I’m running 2.1.0 on Win 7 on a My Book Live Duo.

I notice that smartware will not back up my MS Outlook pst file (after the first time that the backup runs).  It backs up the MAPISVC file whenver it changes and creates a .MKBP file but when I restore the .MKBP file is deleted and i’m left with an out of date pst file.

Any suggestions as to why this should be ?? Used to work fine with WD Anywhere.

Peter

my problem is that this software is won’t let me do a backup unless I use dropbox. this is unaccepatble. I want to be able to have my 3 computers backed up on my live box  directly and i do not want anything to do with dropbox. When is this going to be fixed.

Smartware V 2.1.0 for Windows,Windows 7 User/My Book Live WD Product

Issues, I too have realized my backups for my Laptop were not happening since May, decided just to install update as one of the installation notes said it fixed backups not performing.

As many have posted, now I only have the option of the Drop Box. The details in the user manual for setting up the target location do not exist in the version I installed called 2.1.0. After installing Smartware (which you guys need to live up to the name, sorry but you guys asked for it with this release), the Quick View disappeared  from my ICON tray and when using Programs then selecting WD Smartware; Quick View is now listed under Smartware but when selected it does not launch Quick View, I have not checked yet to see if it is listed in programs in the control panel but no longer in my programs menu. I would hope you are working fast to fix this issue as you have launch a product that does not work! Send out an email to your customers telling them what is going on instead of just letting us spend hours trouble shooting software that doesn’t work.

I purchased My Book Live 10 months ago for the purposes in priority order;

automated back ups,

keeping a central network location for files, music,

and additional drive storage space.

I just updated to this version today on my 2 laptops (1: Gateway XP, 1: Toshiba Vista)  I have a PassportSE that I have been using for about 2 years, pretty flawlessly I might add.   Now it is NOT backing up files, UNLESS the unit is plugged it at the time the file is changed or created.  I cannot leave my drive plugged in because both of my laptops try to boot from it and then hang up.  It previously had no problem scanning the hardrive for new and/or changed files.  The bar does say that the backup was completed successfully, but if you compare the number of files and the size of the backup, you will see the difference. 

Please help me.

A follow up to my earlier post.  I just timed the new software.  The bar shows “backup accomplished successfully” for 15 seconds, then it shows the backup status bar with the __ of __ copied.  This repeats every 15 seconds that the unit it plugged in. 

I just updated to the 2.1.0 today and my unit is a PassPort SE, WDBACX7500ABK, S/N [Deleted]. My laptop is a Toshiba running Vista.   I have another one on my Gateway XP laptop, doing the same thing. 

It used to scan my harddrive and compare files. When it found one that had changed, it backed it up on the SE.  And the SE didn’t have to stay plugged into the laptop.  Now it doesn’t compare the files and only seems to backup  a file if it changes while the SE is plugged into the laptop.  That is not how it is  supposed to work.

Please fix this, or tell me what I’m doing wrong.

I have the same problem. I thought it was just for one particular user setting but I now realise it is not backing up, it just says it is and does nothing. Any solution from WD yet?

Hi guys,

@ veryolddog

From the Home tab you should be able to select the source and the target for the backup. In order for Smartware to recognize the My Book Live, both must be part of the same local network. For more information you can see page 5 of the manual.

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705057.pdf#page=9

@ SIS425

After updating Smartware it can take a couple of minutes for it to scan and recognize the available target drives. If Smartware is not recognizing your USB or NAS hard drive, try uninstalling it and do a clean installation of the latest version. 

@ Garfdallas/ megamicron

Try uninstalling Smartware, restart the PC and then reinstall it. Another way for you to verify if the files are being backed up, is to explore the “smartware.swstor” folder manually, this is the folder that Smartware creates to backup the files, it has the same folder structure that you have for the files on your PC.

After a conversation with a tech, I uninstalled all of the WD software I had, restarted my computer, went to WDC.COM and downloaded the software update, installed it and waited for it to get to the part where it wants to know where to back up and then plugged my PassPort back in.  Then, once the software ‘recognized’ the unit, I specified it, and followed the rest of the set up process.  I finished by selecting “enable backup” and walked away from my machine for about 45 minutes and let it “do it’s thing”. 

The secret seems to be that it will only backup if it sees the machine COMPLETELY idle for a while and it only does a backup while the machine is COMPLETELY idle.  This version is User-sensitive and doesn’t want to interfer with the user while he is using it.  The previous version wasn’t quite so sensitive and it seemed to backup a file or folder whenever it noticed a change in it’s status.    I think I preferred the previous version, as it was more user-friendly in my opinion.  But at least it is working, I just have to remember to take a coffee break and let it ‘do it’s thing’!!

I upgraded to this release today (8/4) and had the exact same result. (error message about Smartware.Retrieve.Retrieve throwing an exception)

Also on my 64 bit Windows 7 laptop.

I’ve logged an incident and am awaiting a reply.

 - keenman

Another experience another post. I just got my Smartware installed and running via assistance. It was wonderful. Now using the Smartware I experienced an odd issue. In setting up my backup, I am now able to see MBL, I then went to the settings page to set up mbl drive particularly to set the sleep function. When I selected set up drive, it opened up MBL dashboard login in my browser, I did not get the UI that is referrenced in the user manual. So how do I set MBL up in Smartware UI?

This is what the manual shows as the UI when selecting Setup Drive on page 18

 This is what I got

Bill_S wrote:

WD is pleased to announce its next release of WD Smartware for Windows.

 

  • You may post your experiences in this thread.

   
  
  
  
  
  
  
  
  
  
  
  

 

   
  
  

How do I feel about this software, well let me tell you, I have bought this product 3 times with Digital River, one was refunded the minute I pressed the button.

The other 2 I have the transaction IDs waited 5 days for my licence nothing arrived, I sent WD support an email they said I had to get in touch with Digital River I then called them again and was told it was being dealt with and I would recieve my codes in 48 hours, 28 days later I still have no licences, my trial time is now over I can no longer access my Dropbox as i need the PRO version to operate it.

Now I will not buy another WD product if I have to buy software through Digital River they are a total waste of time and a bunch of theives.

I have 3 brand new Passports 1tb and a My Book 2tb because of all the messing about I am going to take them back to the store where I bought them, as they are no good to me without the software, which I seem not to be able to get.

WD please find another way for people to purchase, as people are not going to go through what I have. Now they have cost you a customer, the return of 4 drives worth about $500 and all for the price of one small peice of software.

So thats my experience, I am one unhappy man.

Sorry this had to be my first post but what else can I do.