New Release - WD Smartware Version 1.6.5 for Windows (3/5/13)

WD is pleased to announce the release of its WD Smartware update for Windows.

  • You may post your experiences in this thread.

I began having problems with my Passport drive late yesterday when Windows XP Pro SP3 (+ all patches) reported being unable to write to the drive. I noticed that the drive’s LED was on continuously whereas before it had been flickering.

When I ran Smartware it reported that the Passport had no recognisable partition. Errors continued to be reported frequently by Windows. Within a few minutes Smartware reported that an update to 1.6.5 was available, so I installed that and followed instructions to reboot.

On rebooting the Passport drive was not visible in the list of devices and Quickview didn’t show any details of the drive. The Passport LED continued to be on solidly.

On a hunch I powered the PC down altogether (rather than restart), and only when I disconnected the power cord did the Passport LED turn off. I waited a few minutes, reconnected the power cord (the Passport drive LED came on immediately) and restarted the PC.

Everything seems to now be functioning as before - the drive is listed among devices, QuickView shows details, and Smartware shows the drive as before the problem. The Passport LED flickers as before.

My guess is that part of the problem lies in the fact that the USB connection needs to be reset in order to fully reset the Passport drive, and this doesn’t seem to happen during a standard reboot, and may not happen for some computers even when powered down unless power is completely disconnected.

I’m not clear on what happened to the data that failed to be written to the Passport drive - are the data queued for another attempt in due course?

Installed update. Last bug fixed, but now neither WD Smartware nor WD Quickview will open. Please fix! Running Windows 8

Installed update on win 7. After the restart, smartware took for ever to start up. Backup and retrieve tabs are blanked out, disk drive icon does not appear on home page. tried another restart, same problem. Tried unplugging USB, no change.

Hey Guys,

I just upgraded to 1.6.5 and I’m noticing that many (maybe all?) of my larger files (those over 50MB are stuck in the “File pending backup.” phase.  I’ve seen this reported in other threads but wanted to let you guys know this is still a problem. They are not outlook files; they’re .mov; .wmv, .pdf, etc.

Running on a Win 7 system.

I just updated to the new software today. It caused my computer to crash. When i rebooted, it went into startup repair mode and said it would remove recently installed programs. I tried several times to reinstall, etc. At first the drive showed up but the backup tab was greyed out. Now it says it doesn’t recognize a partition. Worthless… very frustrating. I’ve wasted at least three hours on this today trying to fix it. Now I’m looking at a ton of other threads over the last three years from thsi kind of problem. You’d think they’d have fixed this issue by now, and yet this is a release from a week ago? I’m going to chuck this in the trash and go buy something worthy.

WD apparently are unconcerned about the customers who already bought the drive so I don’t really think they read the threads by this WD community. As far as they are concerned the sales of their products is still on, but they can’t afford to have a decent back up software. Now we may have to wait he next version to solve the common bugs.

Hi WagWaf,

Are you still having issues backing up files?

Have you contacted support to get your issue resolved?

WagWaf wrote:

WD apparently are unconcerned about the customers who already bought the drive so I don’t really think they read the threads by this WD community. As far as they are concerned the sales of their products is still on, but they can’t afford to have a decent back up software. Now we may have to wait he next version to solve the common bugs.

We are paying attention to these threads.  What specific issues are you having?

Given the trends I’ve seen and experienced in my own use regarding the changes and updates in Smartware 1.6.x through 1.6.4; I elected to go with the Microsoft Anywhere Update to update my primary home computer system (1 of 3) from Windows 7 Home Premium to Windows 7 Pro so that I could take advantage of Windows backup and restore to a network drive; I have two 1TB MyBookLives.

Sadly, with version 1.6.5, my major issues with Smartware versions 1.6.x remain unfixed, so at this point I have to believe that Western Digital intentionally changed Smartware’s functionality and no fix is forthcoming because it is their intended design. Smartware 1.6.x introduced some nice new features and fixed some issues, but all versions of 1.6.x completely removed the functionality that I needed.

As far as I’m concerned, the last working version of Smartware that met my needs, even with all of its problems, was 1.5.4.11B. Starting with 1.6.0.19; Smartware was no longer useable for me, but perhaps it works for others. I’ve tried each 1.6.x version that’s been released; 1.6.0.19, 1.6.2.5, 1.6.4, and now 1.6.5.

A few of the most serious issues I have with Smartware version 1.6.5 (experienced in all versions of 1.6.x) are:

  1. A consistently reported problem with Smartware 1.6.x is it disables or obstructs Windows Power Management; specifically Windows ability to put the computer to sleep based on a Power Management plan you set. With Smartware 1.6.x installed, if you want your computer to sleep, you have to do in manually (Click Start – expand Shutdown menu – click sleep). If by design, WD needed to disable the Sleep Mode feature in Windows’ Power Management settings, they should have at least tied it to the Backup switch in the Smartware Panel; i.e. – Backup Turned On, Sleep Mode disabled; Backup Turned Off, Sleep Mode enabled.

  2. From my experience, backup, initial backup anyway, has taken progressively longer with each release of Smartware. With version 1.6.5 it took me, on an idle computer (nothing else going on), 7 hours and 26 minutes to perform a dedicated Category Backup (11,350 Files – 11.1GB) over a Wireless N connection to one of my 1TB MyBookLives. Using Windows 7 Pro’s network backup to the same 1TB MyBookLive; it took about half that time to back up the same Data Files that Smartware did, plus a System Image of both the Recovery Partition of my local drive and the OS © for a total of 71.3GB. 11.1GB compared to 71.3GB!!!

  3. I prefer to use Backup as “on demand”, not continually performing in the background. So, with versions prior to 1.6.x I would launch Smartware, turn on Backup, it would quickly categorize and back up all of my Category Files (new or changed files), and when complete I would turn Backup off. With 1.6.x, after the initial lengthy Backup, when I launch Smartware it categorizes my files and if you mouse over the categories in your primary drive’s © panel, you can see the file count and note the increase from the same categories that are shown in the MyBookLive Backup panel (current backup). When you select that drive for Backup, for some reason the number of files in the categories of your primary drive are reset (decremented) to match the target MyBookLive; basically showing no files for Backup. At that point nothing happens, it doesn’t perform a Backup. Perhaps if I left Backup turned on it would eventually perform the necessary backup, but that’s not how Smartware versions prior to 1.6.x worked and not how I want to use it. With 1.6.x I’ve never seen a successful backup of files awaiting backup after that initial lengthy backup.

There are other issues, but those are the three that render Smartware unusable for me. I’ve uninstalled Smartware version 1.6.5 and doubt that I’ll try any future versions; it’s just to frustrating. At this point I’m only using WD Quick View. I’ve been an ardent fan of Western Digital products since buying then building PCs starting in the 80’s. Given my recent experiences, not so much with the hardware, but support software and technical support; I doubt that I will buy another Western Digital product nor will I recommend them.

Thanks Buck73 for the insights.  Your number 3 issue is really important to understand.  There is a big difference between “continuous” backups and “non-continuous” backups.  In order to do backup on demand, you must be using a non-continuous backup software.  SmartWare just won’t work for that.  Also, in order to have continuous backup, you really need to be willing to sacrifice some of your processing power for it to run continously.  Nevertheless, we are always working on how much processing power is being used once the initial backup is complete.

As for how long it’s taking to do the initial backup, I will pass your post along for review. 

With your first point, I will pass that along as well.  However, Power Management actually only works when there is no system activity for whatever time you have it set to.  SmartWare never goes off, it just goes more into an idle state.  Whether or not Windows is still seeing it as active, I don’t know.  But I will pass it along.  And if it taking a long time to finish the initial backup, then of course the system won’t be able to go to sleep.

Bill S, Thank you for the feedback, I very much appreciate your response!!

Regards,

Bill (Buck73)

I tried improving the speed of backup by changing the process priority and found it was locked at Low and could not be changed at all.

Perhaps WD might consider unlocking it in future so we can choose to give it a higher priority.

It’s possible we had to do that because it would take control of the processor if nothing else was running.  If you’re doing an initial backup, you might want to consider not running a lot of other programs.  Also, you may consider turning off your antivirus until it’s done.  These are  just my thoughts, not necessarily what Support would recommend.  And if you are using XP, you may want to make sure that your drive isn’t really fragmented. 

I cannot install the upgrade on my Windows 8 64 bit Machine.  I disabled my anti virus program and all the install starts up, but then disappears.

Based on my previous comment, someone from western digital contacted me and walked me through fixing the problem to the point where I could perform the backup. I do appreciate that. However it doesn’t solve the problem about why my hard drive crashes whenever I do a backup every month or two. I’ve never had smooth sailing with the software. It’s always been a struggle. So while it satisfies my need now and I’ve got a functional backup I can say I would not buy this again in the future. Too many problems. And it take a hours (4-6) to do a simple backup of photos and some documents.

Same issue cropped as a week a go - drive light on constantly, error messages from Windows reporting inability to write various files to the drive.

Powered down the PC, disconnected the USB cable, reconnected, powered back up, seems to function OK.

But I still don’t know whether the failed Writes have been lost for good or retried - there’s no feedback.

The upgrade from 1.6.2 to 1.6.5 fails quietly with no error indication.

I’m using Windows 7 Ultimate 64-bit *WITH ALL CURRENT (MARCH 2013 PATCH TUESDAY)* fixes applied.  Could any of those monthly updates be interfering with the upgrade from 1.6.2 to 1.6.5?

I also have the issue of the Smartware disabling Windows power management. I had used the hard drive without installing Smartware for the first few weeks I had it, after reading many reviews, most negative, about the software. I seen the new version 1.6.5 was out, and I wanted to be able to control the power settings of my 2TB My Book Essential, so hoping many of the issues I had been reading about were resolved in the update, I downloaded the firmware check and newest version of Smartware. The firmware check told me mine was up todate, and the software installed without any issues. I did email support, and they did respond quickly. The tech assigned to my case has asked that I call. I have not done that yet, I am concerned it is going to involve a lot of uninstall, re-install etc, and I do not want to make any changes to my Windows 7 Home Premium,given that it worked flawlessly prior to the Smartware, I fail to see any need to modify it. Whatever is in Smartware that is causing it needs to be addressed. In addtion to the power management issues, my startup time has increased dramatically, again, the only change was the Smartware install.

I updated to 1.6.5 and have an issue. This is in Windows 7. Previously everything worked fine. The smartware icon is showing up in the system tray. When I right click it and select “WD Smartware”, nothing happens. The app UI is not coming up.