New Release - WD Smartware Version 1.6.5 for Windows (3/5/13)

Again, the drive failed - but this time I seemed to catch it in the process of failing.

The symptoms included the constantly-on LED (which is what I noticed first), a failure of the WD Utilities to find the drive and when it did, it reported a failure of SMART and a size of 0 for the drive. However, the WD Quick View still functioned - sort of - showing the drive name and the % used but nothing else. I grabbed screenshots of some of the effects.

This time though the OS (WinXpSP3) didn’t report write failures.

So I rebooted/reset the drive, and it seemed to come back up OK.

This time I went into Admin Tools > Event Viewer and noted that around the time I spotted the constantly-on LED, two warnings cropped up:

WDRulesService (text is: The description for Event ID ( 0 ) in Source ( WDRulesService ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Service started/resumed.)

WDBackup (text is: The description for Event ID ( 0 ) in Source ( WDBackup ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Service started/resumed.)

I checked the Services and three were listed as running. Next time (there will be a next time, I am confident) I will check the Services before I do anything else.

Any suggestions?

Hi

Last week i updated my SmartWare from Version 1.5.4.5, which was delivered with my drive to the new one, because I had an issue, that a WD-task took about 80% of my cpu.

Now i have the new 1.6.5 and another issue. Every ~ 45 seconds WDLockedFiles.exe starts my floppy and creates a new task. After ~ 3 hours there were 154 tasks opened and only 37 of them had other names than WDLockedFiles.exe. All of these tasks are not using any cpu, but RAM.

Some more information:

During this ~3 hours my Passport was not connected.

My backup plan only includes one folder on c:.

I am using Windows XP SP3 (and no other updates), the PC is not connected to the Internet, and pretty old.

Disabling the floppy stops WDLockedFiles.exe from starting, but I need my Floppy drive. (Its an internal floppy drive)

Please help me and feel free to ask more questions

I have no prior experience with Smartware, 1.6.5 is my maiden voyage. I have experience with many other backup products though. I run the sw on a Windows XP, SP3 fairly old Dell laptop. 1GB RAM. Backing up to brand new WD Live Book Duo, 4TB, configured as Raid1. Backing up from C: and an external Maxtor drive (previous backup I’m obsoleting).

PC-WD connected 100bT Ethernet over a router and Maxtor-PC over USB 2.0.

C: has about 30GB to back up and old external drive about 80GB.

I choose to perform file based backup rather than category. Main reason that I need to know exactly what gets backed up. I have since learned that you can edit the XMLs to define your own categories, but that’s not what I did.

What I have seen:

Initial backup still not done after one week!  It is painfully slow, much slower than copying the same files between the same endpoints. Every time you restart Smartware it takes about 8 hours to even start backing up.

Once I saw these problems I closed every unnecessary service and booted PC clean from bloatware. I don’t even use it during backup. No visible improvement.

[1] Several files fail with the error “Unspecified Error”. It turns out that for the most they are caches and other stuff I don’t desperately need, but the error seems weird. I solved by removing these from backup plan. Anyone else knows about this? If anyone from WD reads this and wants sample files that fail I can send some to you.

[2] No file over 50 MB backs up. I’ve seen this bug reported in this forum dating back at least a year. Has this ever been resolved? I get “Pending Backup” (Sic!) in the error log.

[3] I can find no way to get a list of the failed backup files so I can write a script to back them up myself. Any suggestions how to do that? (Assuming of course that the better option of getting a fix is not available)

[4] Is there any way to find out what Smartware is currently working on. It says “Copying files” constantly but for the most part no file copying is happening (Verified by looking at file timestamps on WD drive). Normally backup sw has some sort of interaction with the user and can at least tell which directory is being backed up.

[5] I have another question on how to shut the disk down gracefully upon power failure via a UPS. I submitted this to WD support on 3/13/13, got the case number but have seen nothing back now a week later. Therefore I’ll ask my fellow users: Does anyone know how to tell the WD Live book duo drive to start a “graceful shutdown”, meaning of course that it saves its current state and spins down in antecipation of mains power about to get cut.

[6] I don’t mean to sound arrogant here. As a new Smartware user I’m probably more ignorant. Is Smartware commonly used among SOHO users and home users for data backup? Or is it more common that you buy WD NAS drives and use 3rd party software to do the backup?

Thanks folks!

Just upgraded to version 1.6.5, using windows 7.

Still the same problem…

I cannot connect 2 x 2Tb passport drives at the same time. The computer hard disc drive interface only recognises the 1st device connected. This problem does not occur when connecting multiple drives of  other manufacture.

The WD smartware panel does show both devices,however, the 2nd device connected is labelled as having no writable partition and cannot be accessed.

Just loaded the new Software WD Smartware r 1.6.5 and now I can’t get the unit to backup. It would start and backup some files but then after a short time it does not advance with the backup. How can I get back to the previous version?

Bucks 73

Thank you for explaining the problems/issues with Smartware to Bill_S who. These issues in my opinion should be easy to solve and as I have now switched to CashPlan for free I noticed how easy back up software can be.  I think WD should take notice. 

Other problems I have is that the Smartware versions starts well backing up files, but it will only last for few days when problems starts again, such as it stops backing up on 10 or 15% of the capacity, and nothing else happens. I too will no doubt download the next version (may be 1.7 as a revamp of all previous versions) but if that fails to work, I will kiss good bye WD forever and use other hardware manufacturers.

Bill_S: Thank you for taking notice of my earlier thread (3 weeks ago) I have not stopped logging into WD community as often as I used to because I get frustrated when I read the other community threads and nothing is done about them.

WagWaf

You’re welcome! I wish I could say I’m optimistic, but I’m not! :cry:

Bill

…"[2] No file over 50 MB backs up. I’ve seen this bug reported in this forum dating back at least a year. Has this ever been resolved? I get “Pending Backup” (Sic!) in the error log."…

FWIW this is one problem I haven’t seen. I have files up to 90G in size and I just took the largest and checked the integrity of the backup against the original - and it passed. This is under XP Pro SP3 with all recommended patches applied. I have multiple drives (largest is 500G but not full) backed up to a single 1T Passport via USB2.

Best,

Peter

Hi Peter,

thanks for your response. I have to ask, did you do anything to change any settings? I have downloaded the latest firmware to the Duo and I have XP w sp3 up to date.

I have to assume there is something I’m not doing right.

BTW, to anyone from WD reading this, this is referring to:

“New Case Created - Ref # : 031313-6748860 Wednesday, March 13, 2013 3:41 PM”

 

cheers

Knut

Hi Knut

I went with default settings (whatever they may be). One thing that might be a vague possibility is that one or more of the Services are either stalled or damaged in some way. You could try going into Admin Tools and checking Event Viewer - see if that sheds any light.

Alternatively check the WD-related Services; stopping them if they’re running (as they should be) and then restarting them.  As far as I know there are only three (all beginning with WD). These are long shots, but you never know.

Best,

Peter

It happened again - already documented in prior messages. A slight difference this time - probably caused by my stopping and restarting all three WD Services - in that there was a .NET error (which the system forwarded to Microsoft once I successfully rebooted the Passport drive and my system).

I can’t tell whether the failures are related to the number of files backed up during each intervening period - maybe Smartware falls over after backing up X number of files, or Y number of bytes.

I’ll keep an eye on the Passport and report anything different from the items I’ve already reported. In another life I was (still am,  I suppose) a software engineer so I’m acutely aware of how obscure errors can creep in even when the utmost care is taken in designing an application.

It would be helpful if someone on the WD side could provide me/us with a set of items that would be useful to WD engineers trying to debug issues reported in this Community - Registry key values, recorded Events, log files, recent KB updates for MS OSs or other changes (such as Java updates, SQL info, whatever) - that we could report.

Best,

Peter

I have no idea who is in charge of product and/or software development at WD but they should be fired immediately as they are robbing the company blind with whatever salary they make. It is pathetic and sad that I should have to experience the result of such incompetence.

WD Quick View 3.1.7.8 is as stupid as a four-digit version number. It doesn’t see my MBLD and is useless.

WD SmartWare 1.6.5 is not even remotely smart. It doesn’t see my MBLD, either. It is also useless.

I am no longer surprised that WD software doesn’t work. It is all-too-obvious that quality assurance simply doesn’t exist. This is the new WD. Write it and release it, Dilbert-style. To **bleep** with the customers.

Here’s a tip people…uninstall everything, throw your WD into the trash and forget about it. Chalk it up to experience and take joy in knowing you will never buy another WD product as long as you live.

How do I install this on Windows Server 2003.  I’m currently running version 1.4.1.1 and it keep asking me to upgrade.  However, the upgrader said I don’t meet the minimum system requirement.

Rather than throw the product out, keep the drive, uninstall the smartware SW, and install some other reliable backup SW. That’s what I ended up doing. Everything that I wanted from smartware SW worked until 1.6.5. With that upgrade it broke. So, I ended up using another well known backup SW product instead to the WD drive.

Hi,

I finally got around to attempting to install the 1.6.5 update.  Upon completing the install and restarting the computer, Smartware does not detect my MyBook Live 2TB drive network drive.   It also does not show up in the WD Quick View either.

I uninstalled it and reinstalled the version that came with the drive that works.  1.5.1.6

The MyBook Live drive said it was able to apply the last update for it.  MyBookLive 02.41.05-034 : Core F/W

Any ideas why the new version of the software does not detect the drive when the old version does?   This is on a Windows 7 computer.

Thanks

Dirk

Due to new release, this thread is now closed.