Access denied after update

I am having this EXACT problem with my MyBook Live 2T after software and firmware update!!

Authentication Failed, The System cannot find the file specified (Exception from HRESULT: 0x80070002)

I have just created a case for service with them… will see if I get a reply.

Michael Smith

Sequim, WA

Just joined this forum to find the answer to this very question!

Decided to install latest version of SmartWare because of problems with WDFME.EXE hogging system resources on my Win XP laptop. Followed advice elsewhere on this forum and did a full uninstall on the existing version, as apparently the latest is not a true upgrade and leaves bits of the previous version all over the place, including the registry. Then ran the registry cleaner to ensure I’d got rid of all the cr*p, *then* had to install .NET Framework V4 as the installer said it couldn’t proceed without it.

So far so good and on reboot after install no sign of WDFME.EXE in process list so presumably WD has got rid of it somehow - thank goodness.

However, although the drive can be seen in every possible way, including WD Quickview and all related utilities, when I open Smartware (there’s a misnomer) the drive has a padlock symbol next to it and wants a user name and password. I had originally set these up from my other PC, a Win Vista machine, via browser admin access, but I made sure there are no passwords set etc for the two user names I created. Can I connect from the XP machine? Can I b*ll*cks! Instead I get an error dialog saying network path not found and an error exception code that changes every time I try it. What a crock! Meanwhile, I can right click on the padlocked drive and get all other information about it no trouble, so plainly it can be seen by the software but there is some kind of a bug in the wretched SmartWare and I have wasted 3-4 hours trying to fix it.

Great drive, lousy software - don’t want to go back to previous version because of WDFME.EXE resource-grabbing problem.

Anyone got any ideas?



1 Like

Did anbybody find a fix to the Authenticaion Failed in Smartware.   I’ve been working with WD Tech - major waste of time.

Just completed a full Factory restore and reinstall all of the software to have the same authentication error.

I can not run without backup.

Any suggestions?

I have the same error…

Do you have a solution?

I’m having the same problem. Did anyone find the solution yet?

I’m having the same issue.  I’ve never used the SmartWare software before, and just decided to try it today.  But I’m getting this error message trying to access the drive.  Of coruse, I can access it just fine with Windows Explorer.

I have the same problem trying to login and after clicking on the padlock icon and typing in details it won’t let me connect up.

I’m on Windows XP pro. I can transfer files via windows explorer but it’s a pain manually. I want the back-up to incremental as it should be via smartware. Smartware works ok on my other laptop (windows 7).

Very frustraing. Looks like this problem has been around for a long time. Not impressed that there seems to be a lot of people with the same issue (based on view count) yet nothing seems to have been done.

Would appreciate anyone’s receommendations aside from those already posted (as tried those with no success)

After doing a firmware update I get nothing My Book Live can not be discovered, even reseting a does nothing, looks like I’ve lost everything ? Can anyone help?

can you see the device in your router’s device table?

No It does not show in my router device list… connected directly to PC to see what happened but still nothing

I did a firmware update and now cannot get access to the drive.  Can get to backed up data via admin login (win 7) but user cannot get to the public space on the drive.  Software manual is lacking. 

Anyone have a suggestion? 

Looks like there may be some WD mess up. looking around not the only ones with this type or error after upgrading firmware.

I hope someone can advise.

For those experiencing the locked drive on NAS and the authentication failed error, can you try these steps below?

Delete all exist mappings to this NAS drive.  For example, if you mapped a drive letter previously on your Windows PC to any of the shares on the NAS.

The suspicion is IP public/private share mapped to Windows and after the firmware update, the IP may no longer be the same.  Alias/Friendly mapping should be ok.

Did that… nothing

The drive is spinning but can not by discovereved via the install disc either from an XP desktop PC or my Windows 7 Laptop.

Can not access the drive in any way.

Tried direct connection to my PC/Laptop… nothing

Reset router… nothing

The light though is never a solid grenn anymore, sort of amber. I’ve plugged into different power sockets… nothing

All this after updated firmware   :cry:

cheytac01 - thanks for response.

I tried that previously and it didn’t make any difference (plus factory reset and uninstalling and resinstalling of smartware).

When I connect via windows explorer (file manager), when I connect on to the z drive (where I have mapped to the NAS) it comes up with the login screen and I can sign in fine.

It’s via smartware  that I have the issue. It just comes up with the “Authentication failed.  Access Denied (Exception from HRESULT: 0x8007005” message.

With my very limted knowledge. I think it might be something to do with Windows XP.

Any other futher suggestions or is a new Smartware update coming out soon?

After reading some of the forum messages mine seems to be stuck in the boot sequence.

Its blue on switch on then amber and never anything else.

What really frustrates me is this was all after a recommended firmware update before then is was perfect.

I’ll be breaking apart to get at the drive inside and try and recover the data.

No point in a warranty return as I need the data on it.

No more NAS drives for me cant trust them.

tried the WD expert suggestion and various reboots, exactly the same as others, can see the drive in WD quickveiw, and via windows explorer but as soon as I run WD SmartWare (oxymoron) it says drive locked and whatever I type in (I have never set a user name so assume it is admin, although I have tried my e-mail address, WDLiveBook and other users names that I have used in the past on other things as well) and any of the passwords I use to access via dashboard or web it says authentication failed! Please sort soonest


Please can someone from WD send some other suggesitons or a fix so we can actually use the MBL properly. Otherwise, this purchase has been a waste of time.

Have you guys tried the new version of Smartware that was released last week?

New Release - WD Smartware Version 1.6.5 for Windows (3/5/13)



WD is pleased to announce the release of its WD Smartware update for Windows.

  • You may post your experiences in the thread below.…

1 Like

Thanks nfodiz.

Think the update has solved the issue (fingers crossed).