NEW PPUltra partitioned for MAC OSX10.10 but Firmware updater can't install as no drive found

Hi Community,

I have just bought a My Passport Ultra 1TB. I have a MAC running Yosemite 10.10 .  I read that it had to partition the disk for formatting when using on a MAC. I followed the instructions on the community site. Initially, it failed as it couldn’t unmount the disk. So I closed all other apps and tried again. No error messages - all seemed fine.

Next I went to the downloads section of the WD site to get all the driver, utitilites and firmware updates.

  •  The Utilities download works fine - so I ran tests and -  SMART status psassed and QUick drive self test PASSED.
  • Universal firmware updater was then downloaded, saved to desktop and launched  - but there’s my problem - it says : -

        NO DRIVE FOUND. Disconnect all USB devices, Reconnect only the WD drive you wnat to update, and click RESCAN.

I had nothing else attached other than my Pport Ultra. Every time I click RESCAN, I get the same message. I ejected the drive and waited a minute then reconnected, waited for it to show in my Finder and tried to launch the Firmware Updater app again. No success.

My drive is showing in my Finder. So I am able to drag files from my MAC hard drive to my portable drive to use it as a storage device, but I’ve got no other functionality without downloading the WD software. 

Anything that was on the drive when I opened the box this morning was erased with the partitioning.

Help is most definitely needed, and greatly appreciated.  Thank you.



Welcome to the WD Community.

Have you tried downloading the application again?

I had already tried 4 times. I’ve since rebooted and done the steps again and still no change. The firmware will not recognise the drive is connected to the MAC, but the MAC recognises that the Pport Ultra is connected. Any other suggestions please?


I have exactly the same problem. Did you find a solution? Please, share if that is the case.

Many thanks