My Passport could not be found after failed to update WDfirmwareupdate

My Passport 500GB used to function well. However, when I tried to update WDfirmwareupdate yesterday, it failed and I could not find it from any computers, including Mac, even through “diskpart” or “list volume” in cmd.exe. The failed messaged is as “Firmware contains low-level instructions that control drive performance. Before starting this firmware update, it is recommended that you back up your drive data and close all applications accessing the drive. Do not disconnect rive power or the USB cable during the update.” I used “Western Digital Data LifeGuard Diagnostics, WinDlg_v1_29” but it could not find the drive. Neither by WD Drives Utilities. When I pluged the portable drive to my computer, the light is on and I can hear the click sound, as well as the spins in the drive, the same as a external drive plugged in the computer but I could not find it in My Computer in Windows 10 system. The cable is the original I bought. There were any problem before yesterday.

Please help.


Sounds like the firmware did not complete the process properly.

Have you tried to run the firmware updater again? If not, please try that.

I tried many times and it still could not be found. I called WD. They said I installed a malware and they can’t do nothing on it.

I have the same problem.
Last week WDSmartWare wanted to update, Update failed and since than my Passport Ultra ist invisible.
I would be very pleased about help and a solution.