Netflix Crash


#1

Seems the new WDLivePlus I just bought crashes on Netflix a lot. The only resolution to keep playing Netflix or playing any other video source is to power off and power back on.

Anyone have this problem or know any solutions ? 


#2

There are quite a few posts about Netflix issues on the plus, myself my netflix wont even load anymore, as soon as it does it errors out and says cant connect to netflix, no manner of resetting or changing settings will get it to work, everything else on the box runs perfectly fine, so something is definitely wrong with the application or the new hardware they put into this thing, so far I havent received a reply from WD on my problem, so welcome to the club of netflix issues :slight_smile:


#3

I dont have any problem… It works great.

It can be wireless router


#4

I also didnt have any issues for the first 2 weeks or so, then all of a sudden Netflix wouldnt connect through the Live Plus anymore, nothing has worked to fix the issue, but other people are having lots of other issues with Netflix and there are no fixes for them either, supposedly they are working on another firmware to hopefully fix some of these problems, but I cant even get a reply to the tech support email I sent them…


#5

Same here… Netflix worked for a short time now doesn’t work at all…


#6

Very unhappy,

Worked 2 days and will not connect to Netflix anymore. This is unacceptable!


#7

Can everyone having issues with Netflix supply more information about how it’s “not working”.

E.g. do you get a specific error message?  Do you get past the Netflix splash screen?  Does it simply not appear at all?

I’m not an engineer but I can see that vague complaints about “problems” or things “not working” won’t help the WD guys pinpoint any issues.

Personally, I had the “Instant Queue Unavailable” error message, which can’t be resolved unless you:

  1. Log in to Netflix.
  2. Go to your account
  3. Manage Netflix ready devices
  4. Deactivate WD TV Live Plus
  5. Factory reset Live Plus
  6. Re-activate Netflix on Live Plus / website

Worked for me.  Was it a pain in the butt?  OH YES.  But I’m back to watching lots of Avatar episodes on Netflix, so I’m happy.  ;)


#8

Worked fine efor 2 days and then now it just gets past the splash screen and then says loading for a min and then has this message.

“Sorry, your instant queue is temporarily unavailable.  Please try again later. If this problem persists, please visit: netflix.com/tvhelp

Checked the connection several times and it hits the internet fine.


#9

I have exactly the same problem as described with Netflix.  My TV goes black and the WD TV Plus is frozen and unresponsive to the remote except to turn the unit off and then back on.  Once I find my way back into the movie, it will work again for varying lengths of time.  This usually happens on average 3 times in a movie but it never skips a movie.  I have tried wired and wireless connections but it makes no difference.  Everything else seems to be functioning correctly.  This is very irritating as Netflix was the reason I upgraded to this new unit.  Anybody gets a fix, please post.  Thanks