NetFlix no longer working on WD TV Live


I’ve had the WD TV Live for a few months, and use it primarily for playing NetFlix.  So far it’s worked perfectly, other than having to re-log into NetFlix every week or two.  Yesterday NetFlix stopped working alltogether. 

I start up the player, launch the NetFlix app, and then something new pops up, a Terms of Service agreement.  There are two options, Email Me, and Accept.  Email Me just sends you the TOS.  Clicking Accept brings me to a screen that says Failed to Connect.  At that point you can either quit out altogether, or retry.  Retrying brings up the same error again. 

I’ve tried resetting all Internet Service accounts, which didn’t have any effect, other than having to log back into NetFlix.

I’m at the most recent firmware.  The Internet connection is working, as I can watch Hulu Plus without issue.

Anything you guys can think of?  My only guess is that NetFlix updated their application, which is causing a conflict with the current firmware release.


There are others user reporting this as well, have you try contacting WD Tech support and ask why this is happening?

register on netflix’s website instead.  then put in your account info into the player.  that worked for me.

it did take about a min before I could actually log into my account via the player after I set up my account on netflix.