Need some help with Gen 3 media player

I recieved a gen 3 media player from a friend and I am trying to get it working and have run into some issues.

  1. When wd live player boots up all i get is a black screen with a red circle telling me to insert firmware.
  2. I have downloaded the latest firmware for this unit and followed the instructions for installation and it still does nothing. (Have tried numerous usb flash drives with no luck.)
    If someone can help me with getting past this hurdle on this unit it would be awesome. I also have a couple of questions. What is the difference between the original software and the gop software on this page. Is there another way to pit the firmware nack on this unit or reset it somehow i have read that there is a way to reset it through the serial connector but even being very knowlegable with computers the directions are very hard to understand and very vague about the process. Any help you can give me in this situation would be very much appreciated thank you.

I have a gen 2 live plus that runs perfectly with the wdlx tv installed on it and just would like to get this other unit up and running again.

Hi Rick1222,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support if you are having trouble with the form.

I dont think that is gonna do me any good from what i understand wd support is terrible and this unit was discontinued so many years ago i dont think there is a lot anyone can do my gen 2 live still works perfectly and i purchased another gen 3 that seems to be working well so i think this one will just get tossed

  1. I have downloaded the latest firmware for this unit and followed the instructions for installation and it still does nothing.
    [/quote]

Did you try downloading ‘Rollback Firmware’ ?

https://support.wdc.com/knowledgebase/answer.aspx?ID=5860

DON’T INSTALL GPL FIRMWARE ! … it was delete Encryption Keys for Online Services eg. Netflix … which Can Not Be Recovered

When installing firmware on the USB … did you follow steps 1,2,3,4, 6 and 7 ?

Also, maybe try pressing the RESET hole underneath the WDTV

Also, have you tried both USB inputs ? eg. Front and Rear

O have been trying like crazy to find a small usb flash drive and locally here where i live i can not find one under 16 gb i bought one that is listed in the compatable list on the wd website but it seems still not to work i have also been looking for rollback firmware but the problem is i do not know for sure what firmware was on it before it was goven to me

doesent matter rollback firmware version… it will work on any version

the wdtvlivegen3.ver contains a number that is higher than the version you’re running so it will trigger the update detection (you can double check if you open it using notepad)

eg. http://download.wdc.com/wdtv/wdtvlivegen3_rollback_2.01.86.zip

contains

VERSION=‘4.01.86’
LOCATION=‘wdtvlivegen3.bin’
PKG_LOCATION=‘wdtvlivegen3.pkg’
ROOTFS2=‘wdtvlivegen3.bi2’

you can change VERSION=‘4.01.86’ to VERSION=‘9.01.86’ if you really want to make sure

In theory it should still work … my advice is to completely reformat it FAT32 … don’t do a “Quick Format”

It’s also nice if the flashdrive has a LED light (my 2GB Kingston does) … that way, i can see if the drive is being accessed by the WDTV. If the LED does not flash, then i know instantly something is not working.

Joey finally got it to recognize a flash drive if i boot the unit up it has the big red circle telling me to insert usb drive with firmware to recover your wd it reads the drive then the screen says warningyour wd was modified aftermarket and is not running official firmware that is not supported by western digital dont know where to go from here

sounds like it has been flashed with GPL Firmware … so it’s pretty much a brick now.

i guess you now know why it was ‘given’ to you

Yeah i am just gonna get rid of this one i have another gen 3 that seems to work pretty good picked it up in a deal with a tv pretty cheap so gonna play with it and see if it will do everything my gen 2 plus will do the gen 2 has wdlx tv on it and it works perfectly

Joey need some advice got this other gen 3 up and running this one boots right up but need some advice the firmware version is 1.14.09 should i update it and if so to which version and should i put the wdlxtv on this unit like my gen 2 i know that there were a lot of these units with the last firmware update and people were rolling it back would like to have the best firmware with the most options for this player
Joey i also want to make sure whatever firmware i use is the official firmware so i do not run into issues like the other one

I personally can’t recommend any specific firmware as i don’t use WDTV anymore … Sold them all.

(i have been using Kodi / Raspberry Pi 3 for the last few years)

It’s up to you what firmware you want to install … as long as you stay away from GPL firmware.

Joey where do i find the official firmwares i have been doing some reading and most people say the newest one has issues and they rolled back to the one before the last update if i update it on the unit itself instead of loading it to a flash drive will it stay the official firmware

Joey i am also looking at buying a raspberry pi 3 can you recommend any sites or chat boards for me to read up on it i have heard nothing but good things about those little units

To Answer Question 1. You can find all ‘Official Rollback Firmware’ here :

Even if you install ‘Custom Firmware’ eg. WDLXTV you can Rollback to Official Firmware from the link(s) above … as long as the .ver file (i mentioned previously) has a Higher Number than whatever firmware you’re running it will trigger the update/rollback.

I did this when i sold my WDTV’s … eg. some were running WDLXTV, but i re-installed Official Firmware on all of them.

To Answer Question 2. For Raspberry Pi 3 there’s lots of chatboards … but probably the best one for Kodi Support is the Official Website (it’s down at the momment, due to moving servers)

https://forum.kodi.tv/

For installing Kodi the easiest way, i would recommend LibreELEC (i had been using OpenELEC … but LibreELEC gets updated a lot more frequently with latest fixes,security patches and improvements eg. they’ve optimised HEVC X.265 playback … have tested some 1080p 5.1DD/DTS videos and they now playback perfectly of the RPi3 :slight_smile:

https://libreelec.tv/

Installation Guide Here: https://libreelec.wiki/libreelec_usb-sd_creator

One word of advice about Kodi … if you want it to run smoothly on the RPi3 without any problems, don’t be tempted to install Piracy Builds / Wizards / Banned Repos or Banned Add-ons … as they will compromise your system. It’s your choice if you do, but if you do install them and have a problem, then you will be exempt from any support from Official Kodi / OS forums.

I understand i have been using kodi now for about 3 years and i have always followed the rules with it i currently run it on a amazon firestick but they say it runs faster on th pi3 because of the quad core processor. Thank you for all the info, i went ahead and did the update on the wd to the latest firmware and everything went very smooth and everything seems to be working pretty well gonna play with it for a little bit and see if any problems arise if they do i will do the rollback and see if it fixes things

Joey i have 1 more question about this wd tv live gen 3 if i decide to put wdlx tv on this unit i understand that it doesnt get flashed to the unit but to the flash drive and the flash drive needs to stay plugged in my question is this if you unplug the flash drive will the unit preform normally again like it does now as if no modifications were made to it i set up a gen 1 apple tv with osmc and kodi for a buddy of mine and when the flash drive is unpluged the apple tv works as normal

yes, but from memory you need to run unbrewme.dat to fully restore it to factory

http://forum.wdlxtv.com/viewtopic.php?f=66&t=8707&start=0

Joey just curious is there a better guide out there for installing the wdlx tv or is the wiki one the best that is out there i know that the wdlx tv forum website has been down for some time so there is no place to ask questions

a better guide ?

The instructions in the link i posted can’t get much simpler than that :confused:

(note: 3 open with notepad, edit it with your WDTV’'s ip address , 4,5,6 “run” = double click the .bat file on your computer)

Install Instructions

  1. Download package above
  2. Unzip
  3. Edit device-ip.txt (included in download)
  4. run win-homebrew-upload.bat
  5. run win-homebrew-brewme.bat
  6. run win-homebrew-status.bat
  7. place wdlxtv-palace.bin on thumbdrive
  8. place homebrew files on same thumbdrive (wdlxtv-palace.bin, runsit.sh, wdtvlivegen3.bin.mpm, wdtvlivegen3.bin.mpm.sha1.sum)
  9. plug thumbdrive into SMP
  10. Reboot SMP
  11. Confirm settings - system - about shows the firmware version as “2.01.86-EXT3_Palace_Plus-0.0.8”
  12. Thumbdrive must stay plugged in, as firmware is running live on the thumbdrive

Joey thank you so much got it installed tonight and up and running and everything is working perfectly i think i will play with both of them for a little bit then go back to the original firmware on both units or do you think they would sell better with the wdlxtv installed on them

i don’t think so … some people may not want a ‘hacked’ wdtv

WDLTVX doesen’t really add any value to it since it’s free and anyone can install if they wish.

i put the official firmware back on the ones i sold (and still got Good Money for them) and included in the ebay ad that they are all running the latest official firmware. Also, if anything went wrong with them, then they couldn’t blame hacked firmware as being the cause.